Stand: 26. April 2025

Dieser Abschnitt enthält die deutschsprachige Ausgabe von der Wissensdatenbank von OnTheServer.de.

Legende

Sicherheitsrelevanz

  • 0/4 - irrelevant
  • 1/4 - eher irrelevant
  • 2/4 - etwas relevant
  • 3/4 - eher relevant
  • 4/4 - relevant

Wichtigkeit

  • 0/4 - unwichtig
  • 1/4 - eher unwichtig
  • 2/4 - etwas wichtig
  • 3/4 - eher wichtig
  • 4/4 - wichtig

Übersicht über die Aktualisierungen

Aktualisierung: | betroffene Komponente: | Sicherheitsrelevanz: | Wichtigkeit:
OTSKB000001 | WinNT\system32\win32k.sys\CreateXlateObject | 0/4 - irrelevant | 1/4 - eher unwichtig


Aktualisierung "OTSKB000001"


Aktualisierung "OTSKB000001"

Was ist dies?

Zusammenfassung

OTSKB000001 ist eine Aktualisierung für das Betriebssystem "Windows 2000".

Die Aktualisierung behebt einen nicht-sicherheitsrelevanten Fehler, um schwere Ausnahmefälle ("blue screens") zu reduzieren.

weitere Details

Es handelt sich um keine offizielle Aktualisierung von Microsoft Corporation, sondern um eine unoffizielle Aktualisierung von OnTheServer.de.

  • "OTS" steht für "OnTheServer" und gibt den Herausgeber an. Dies entspricht der Angabe "MS" in "MSKB123", um Microsoft Corporation als Herausgeber anzugeben. Microsoft verzichtet jedoch in vielen Fällen auf die Angabe "MS".
  • "KB" steht für "knowledge base" und bedeutet ungefähr "Wissensdatenbank". Eigentlich wird also mit der Nummer ein bestimmter Artikel aus der Wissensdatenbank angegeben. Allerdings wird die Bezeichnung auch für die Aktualisierung selbst verwendet.

    Microsoft Corporation hatte ursprünglich die Abkürzung "Q" anstatt "KB" verwendet, was für "question" stand. "question" bedeutet "Frage". Zur Frage gibt es dann eine Antwort und eine Problemlösung. Die Lösung war oft die Aktualisierung. Die Aktualisierung wurde dann genauso wie der Artikel mit der zugehörigen Frage benannt, sodass die verschiedenen Aktualisierungen ihren Artikeln zugeordnet werden können.

    Dennoch gibt es noch immer alte Aktualisierungen mit einer Bezeichnung im Format "Q123" anstatt "KB123".
  • Die Nummer ist eine fortlaufende Dezimalzahl, um die Aktualisierung eindeutig identifizieren zu können.


Aktualisierung "OTSKB000001"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffenes Betriebssystem: | Windows 2000
betroffene Datei: | WinNT\system32\win32k.sys
betroffene Funktion: | CreateXlateObject

weitere Details

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle Sprachen vom Betriebssystem sind betroffen.

Die Betroffenheit von anderen Betriebssystemen wurde nicht geprüft.


Aktualisierung "OTSKB000001"

Wie wichtig ist die Installation von dieser Aktualisierung?

Zusammenfassung

Die Installation von dieser Aktualisierung ist eher unwichtig.

weitere Details

Das Schlimmste, was unter realistischen Bedingungen passieren kann, ist ein Systemabsturz während einem Schreibzugriff auf die Festplatte. Hierdurch kann in der Folge das Dateisystem korrumpiert werden. Dies hätte einen erheblichen Datenverlust zur Folge und würde gegebenenfalls eine Neuinstallation vom Betriebssystem erfordern.

Allerdings ist es sehr unwahrscheinlich, dass der schlimmste Fall eintritt. Weniger gravierende Auswirkungen sind deutlich wahrscheinlicher. Oft hat das Schreiben über das Ende von einem vorgesehenen Speicherbereich hinaus keine erkennbaren Auswirkungen.

Da eine erhebliche Zufallskomponente enthalten ist, gleicht also ein Verzicht auf die Installation von dieser Aktualisierung dem Spielen von russischem Roulette: Es ist nicht klar, ob überhaupt etwas passieren würde und wenn doch, wann dies der Fall wäre.


Aktualisierung "OTSKB000001"

Worin besteht der Fehler?

Zusammenfassung

In der Datei "win32k.sys" befindet sich in der Funktion "CreateXlateObject" ein Programmierfehler. Dieser Fehler führt dazu, dass über das Ende von einem Speicherbereich hinausgeschrieben wird. Dadurch werden fehlerhafterweise Daten im Arbeitsspeicher überschrieben. Dies kann zu Fehlverhalten, inklusiv Systemabstürzen führen.

weitere Details

Am Anfang von der Funktion wird ein Xlate-Objekt erzeugt. Die Größe von diesem Objekt ist im Wesentlichen von der Anzahl der Farbpaletteneinträge im Quell-Bildspeicher abhängig. Im späteren Funktionsdurchlauf gibt es mehrere Code-Pfade, welche die Farbpalette vom Xlate-Objekt füllen. Hierbei wird teils fälschlicherweise davon ausgegangen, dass
  • 256|d Einträge in der Farbpalette vom Xlate-Object gespeichert werden können oder
  • soviele Einträge in der Farbpalette vom Xlate-Object gespeichert werden können, wie die Farbpalette vom Ziel-Bildspeicher Einträge hat.
Wenn eine Anzeige-Betriebsart mit beispielsweise 16|d Farben verwendet wird, dann ist dies jedoch nicht zwangsweise der Fall.

Hierdurch werden mehr Einträge für die Farbpalette im Arbeitsspeicher gespeichert, als in die Farbpalette vom Xlate-Objekt gespeichert werden können. Somit wird fälschlicherweise über das Ende vom vorgesehenen Speicherbereich hinausgeschrieben, wodurch fälschlicherweise nachfolgende Daten überschrieben werden.


Aktualisierung "OTSKB000001"

Wie wird der Fehler behoben?

Zusammenfassung

Die Aktualisierung überschreibt ein paar wenige Byte vom Maschinencode von der Datei "win32k.sys".

weitere Details

  1. Zunächst wird die Datei "win32k.sys" in ihrem momentanen Zustand gesichert. Dies dient dafür, um diese Aktualisierung bei Bedarf zu einem späteren Zeitpunkt wieder deinstallieren zu können.
  2. Dann werden ein paar wenige Bytes vom Maschinencode von der Datei "win32k.sys" überschrieben. Hierdurch kann nachfolgender Maschinencode bis zu 256|d Einträge in die Farbpalette von dem Xlate-Objekt speichern.

    Diese Lösung ist nicht sauber. Es wäre sauberer, die Größe von der Farbpalette dem Bedarf anzupassen. Bei der gewählten Lösung handelt es sich vielmehr um einen Kompromiss zwischen einer sauberen Lösung und einem geringen Eingriff in den bestehenden Maschinencode.

    Es ist möglich, dass dies mit einer zukünftigen Aktualisierung verbessert wird. Momentan ist es jedoch die beste bekannt Lösung.
  3. Dann wird die Versionsnummer von "5.00.2195.7640" auf "5.00.2196.0001" erhöht.
  4. Dann wird die Prüfsumme neu berechnet und überschrieben.

Änderungen an der Datei "win32k.sys"

Sprache: | Maschinencode
 | Offset: | Inhalt
 |  | alt: | neu:
ARA | E 21 71|h | 8B 45 10 53 56 57 85 C0 74 05 8B 40 14 EB 05 B8 00 01 00 00 | 53 56 57 B8 00 01 00 00 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Sprache: | Prüfsumme
 | Offset: | Inhalt
 |  | alt: | neu:
ARA | 1 20|h | EC 04 1A 00 | 75 A0 19 00
CHS |  | 82 1E 1A 00 | 0B BA 19 00
CHT |  | A0 D1 19 00 | 28 6D 1A 00
CSY |  | 92 CB 19 00 | 1A 67 1A 00
DAN |  | 37 AD 19 00 | BF 48 1A 00
DEU |  | 68 F3 19 00 | F0 8E 1A 00
ELL |  | 2E 49 1A 00 | B7 E4 19 00
ENU |  | A8 DA 19 00 | 30 76 1A 00
ESN |  | 8D 31 1A 00 | 16 CD 19 00
FIN |  | 42 65 1A 00 | CB 00 1A 00
FRA |  | 53 F0 19 00 | DB 8B 1A 00
HEB |  | 54 35 1A 00 | DD D0 19 00
HUN |  | F6 D0 19 00 | 7E 6C 1A 00
ITA |  | 36 9C 1A 00 | BF 37 1A 00
JPN |  | D1 37 1A 00 | D1 37 1A 00
KOR |  | 41 A9 19 00 | 41 A9 19 00
NLD |  | 73 6F 1A 00 | FC 0A 1A 00
NOR |  | 88 62 1A 00 | 11 FE 19 00
PLK |  | 3D 93 1A 00 | C6 2E 1A 00
PTB |  | 39 D6 19 00 | C1 71 1A 00
PTG |  | 7F 5E 1A 00 | 08 FA 19 00
RUS |  | 65 C0 19 00 | ED 5B 1A 00
SVE |  | 8D F5 19 00 | 15 91 1A 00
TRK |  | 57 BF 19 00 | DF 5A 1A 00

Sprache: | Versionsnummer als Ganzzahlen
 | Offset 1: | Offset 2: | Inhalt
 |  |  | alt: | neu:
ARA | 18 C9 10|h | 18 C9 18|h | 00 00 05 00 D8 1D 93 08 | 00 00 05 00 01 00 94 08
CHS | 18 C7 7C|h | 18 C7 84|h
CHT | 18 C7 88|h | 18 C7 90|h
CSY | 18 C9 74|h | 18 C9 7C|h
DAN | 18 C9 2C|h | 18 C9 34|h
DEU | 18 C9 90|h | 18 C9 98|h
ELL | 18 CA 0C|h | 18 CA 14|h
ENU | 18 C6 F0|h | 18 C6 F8|h
ESN | 18 C9 74|h | 18 C9 7C|h
FIN | 18 C9 E0|h | 18 C9 E8|h
FRA | 18 C9 60|h | 18 C9 68|h
HEB | 18 C8 98|h | 18 C8 A0|h
HUN | 18 C9 1C|h | 18 C9 24|h
ITA | 18 C9 44|h | 18 C9 4C|h
JPN | 18 C8 04|h | 18 C8 0C|h
KOR | 18 C7 DC|h | 18 C7 E4|h
NLD | 18 C9 6C|h | 18 C9 74|h
NOR | 18 C9 1C|h | 18 C9 24|h
PLK | 18 C9 AC|h | 18 C9 B4|h
PTB | 18 C9 9C|h | 18 C9 A4|h
PTG | 18 C9 60|h | 18 C9 68|h
RUS | 18 C9 88|h | 18 C9 90|h
SVE | 18 C9 50|h | 18 C9 58|h
TRK | 18 C9 44|h | 18 C9 4C|h

Sprache: | Versionsnummer als Zeichenkette
 | Offset 1: | Offset 2: | Inhalt
 |  |  | alt: | neu:
ARA | 18 CA 3C|h | 18 CB E8|h | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 35 00 2E 00 37 00 36 00 34 00 30 00 00 00 | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 36 00 2E 00 30 00 30 00 30 00 31 00 00 00
CHS | 18 C8 A8|h | 18 CA 58|h
CHT | 18 C8 B4|h | 18 CA 64|h
CSY | 18 CA A0|h | 18 CC 50|h
DAN | 18 CA 58|h | 18 CC 04|h
DEU | 18 CA C4|h | 18 CC 70|h
ELL | 18 CB 50|h | 18 CD 28|h
ENU | 18 C8 1C|h | 18 C9 CC|h
ESN | 18 CA B0|h | 18 CC 60|h
FIN | 18 CB 10|h | 18 CC C4|h
FRA | 18 CA 9C|h | 18 CC 58|h
HEB | 18 C9 E0|h | 18 CB 88|h
HUN | 18 CA 68|h | 18 CC 1C|h
ITA | 18 CA 74|h | 18 CC 24|h
JPN | 18 C9 30|h | 18 CA E0|h
KOR | 18 C9 08|h | 18 CA B8|h
NLD | 18 CA A8|h | 18 CC 58|h
NOR | 18 CA 58|h | 18 CC 14|h
PLK | 18 CA E8|h | 18 CC 98|h
PTB | 18 CA CC|h | 18 CC 80|h
PTG | 18 CA B4|h | 18 CC 64|h
RUS | 18 CA CC|h | 18 CC A4|h
SVE | 18 CA 94|h | 18 CC 50|h
TRK | 18 CA 80|h | 18 CC 30|h

ungeänderte Eigenschaften von der Datei "win32k.sys"

Sprache: | Dateigröße
 | alt: | neu:
ARA | 1.678.352 Byte
CHS | 1.678.320 Byte
CHT | 1.678.320 Byte
CSY | 1.678.448 Byte
DAN | 1.678.384 Byte
DEU | 1.678.480 Byte
ELL | 1.678.672 Byte
ENU | 1.678.320 Byte
ESN | 1.678.480 Byte
FIN | 1.678.576 Byte
FRA | 1.678.448 Byte
HEB | 1.678.320 Byte
HUN | 1.678.416 Byte
ITA | 1.678.416 Byte
JPN | 1.678.320 Byte
KOR | 1.678.320 Byte
NLD | 1.678.448 Byte
NOR | 1.678.384 Byte
PLK | 1.678.512 Byte
PTB | 1.678.512 Byte
PTG | 1.678.480 Byte
RUS | 1.678.544 Byte
SVE | 1.678.448 Byte
TRK | 1.678.416 Byte


Aktualisierung "OTSKB000001"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: | Windows 2000
Version von der Datei "win32k.sys": | 5.00.2195.7640

weitere Details

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Die Aktualisierung kann alle 24 Ausgaben von der Datei "win32k.sys" aktualisieren.

die Datei "win32k.sys" in der Version "5.00.2195.7640"

Die Aktualisierung "OTSKB000001" enthält keine neue Version von der Datei "win32k.sys". Stattdessen wird jene Datei geändert, welche sich bereits auf der Festplatte befindet. Aus diesem Grund muss jene Version von der Datei vorhanden sein, welche die Aktualisierung ändern kann. Hierbei handelt es sich um die Version "5.00.2195.7640". Sie ist die neuste Version für das Betriebssystem. Sie ist in der Aktualisierung "KB3145739" enthalten. Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe von Window 2000
  • CHS - für die vereinfachte, chinesische Ausgabe von Window 2000
  • CHT - für die traditionelle, chinesiche Ausgabe von Window 2000
  • CSY - für die tschechische Ausgabe von Window 2000
  • DAN - für die dänische Ausgabe von Window 2000
  • DEU - für die deutsch Ausgabe von Window 2000
  • ELL - für die griechische Ausgabe von Window 2000
  • ENU - für die englische Ausgabe von Window 2000
  • ESN - für die spanische Ausgabe von Window 2000
  • FIN - für die finnische Ausgabe von Window 2000
  • FRA - für die französische Ausgabe von Window 2000
  • HEB - für die hebräische Ausgabe von Window 2000
  • HUN - für die ungarische Ausgabe von Window 2000
  • ITA - für die italienische Ausgabe von Window 2000
  • JPN - für die japanische Ausgabe von Window 2000 für den IBM PC
  • KOR - für die koreanische Ausgabe von Window 2000
  • NLD - für die holländische/niederländische Ausgabe von Window 2000
  • NOR - für die norwegische Ausgabe von Window 2000
  • PLK - für die polnische Ausgabe von Window 2000
  • PTB - für die portugiesische Ausgabe von Window 2000 mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe von Window 2000 mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe von Window 2000
  • SVE - für die schwedische Ausgabe von Window 2000
  • TRK - für die türkische Ausgabe von Window 2000

Die Aktualisierung "KB3145739" scheint nicht für den PC98 von NEC zu existieren.

Falls die obigen Adressen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3145739.zip

Die Aktualisierung "OTSKB000001" ist lediglich in der Lage, die Originaldateien von Microsoft Corporation zu ändern. Dateien, welche bereits - zu welchem Zweck auch immer - geändert wurden, sind nicht mehr kompatibel mit dieser Aktualisierung. Die Aktualisierung erkennt die Inkompatibilität aufgrund von der unbekannten Prüfsumme und lehnt dann das Ändern ab.

neue Stammzertifikate

Die Aktualisierung "KB3145739" wurde im April 2016 von Microsoft Corporation veröffentlicht. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem service pack 4 wird die Installation von der Aktualisierung "KB3145739" mit einem Verweis auf die Datei "update.inf" scheitern. Die Ausgabe vom April 2016 von den Stammzertifikaten kann hier heruntergeladen werden:
  • http://OnTheServer.de/temp/2025-04-19/rootsupd201604.exe

Falls die obige Adresse nicht mehr funktionieren sollte, dann kann die Aktualisierung "KB3145739" auch manuell ohne eine vorherige Aktualisierung von den Stammzertifikaten installiert werden. Hierzu muss
  1. zunächst die Aktualisierung "KB3145739" mit dem Komandozeilenparameter "-x" aufgerufen werden, um die enthaltenen Dateien zu entpacken.
  2. Dann muss die Datei "WinNT\system32\dllcache\win32k.sys" gelöscht werden, sofern diese existiert.
  3. Dann muss die Datei "WinNT\system32\win32k.sys" irgendwo gesichert werden, damit die Aktualisierung "KB3145739" wieder deinstalliert werden kann.
  4. Dann muss die Datei "WinNT\Driver Cache\i386\win32k.sys" mit der entpackten Datei überschrieben werden. Falls diese Datei nicht existiert, dann muss die entpackte Datei ohne Überschreiben in dieses Verzeichnis kopiert werden.
  5. Dann muss die Datei "WinNT\system32\win32k.sys" mit der entpackten Datei überschrieben werden.

    Dieser Schritt ist im Abgesicherten Modus nicht so einfach möglich.

Die restlichen entpackten Dateien werden nicht benötigt.


revision: 26th of April 2025

This section contains the English edition of the knowledge base from OnTheServer.de.

Legend

Importance

  • 0/4 - unimportant
  • 1/4 - rather unimportant
  • 2/4 - somewhat important
  • 3/4 - rather important
  • 4/4 - important

Relevance to security

  • 0/4 - irrelevant
  • 1/4 - rather irrelevant
  • 2/4 - somewhat relevant
  • 3/4 - rather relevant
  • 4/4 - relevant

Overview of the updates

Update: | Affected components: | Importance: | Relevance to security:
OTSKB000001 | WinNT\system32\win32k.sys\CreateXlateObject | 1/4 - rather unimportant | 0/4 - irrelevant


Update "OTSKB000001"


Update "OTSKB000001"

What is this?

Summary

OTSKB000001 is an update for the operating system "Windows 2000".

The update fixes a non-security-related bug to reduce system crashes ("blue screens").

Additional details

This is not an official update from Microsoft Corporation, but rather an unofficial update from OnTheServer.de.

  • "OTS" stands for "OnTheServer" and indicates the publisher. This corresponds to the designation "MS" in "MSKB123", which indicates Microsoft Corporation as the publisher. However, Microsoft often omits the "MS" designation.
  • "KB" stands for "knowledge base" and roughly means "knowledge database". Actually, the number refers to a specific article in the knowledge base. However, the term is also used for the update itself.

    Microsoft Corporation originally used the abbreviation "Q" instead of "KB", which stood for "question". For the question, there is an answer and a solution to the problem. The solution was often the update. The update was then named just like the article with the corresponding question, so that the various updates could be matched to their articles.

    Nevertheless, there are still old updates with a designation in the format "Q123" instead of "KB123".
  • The number is a consecutive decimal number used to uniquely identify the update.


Update "OTSKB000001"

Which components are affected?

Summary

Affected operating system: | Windows 2000
Affected file: | WinNT\system32\win32k.sys
Affected function: | CreateXlateObject

Additional details

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.

Whether other operating systems are affected, has not been investigated.


Update "OTSKB000001"

How important is the installation of this update?

Summary

The installation of this update is rather unimportant.

Additional details

The worst that can happen under realistic conditions is a system crash during a write access to the hard drive. As a result, the file system could become corrupted. This would lead to a significant data loss and might require a reinstallation of the operating system.

However, it is very unlikely that the worst case will occur. Less severe effects are much more probable. Often, writing beyond the end of an intended memory area has no noticeable effects.

Since there is a considerable element of randomness involved, abstaining from installing this update is akin to playing Russian roulette: It is unclear whether anything would happen at all, and if so, when that would be the case.


Update "OTSKB000001"

What is the nature of the bug?

Summary

In the file "win32k.sys" there is a programming error in the function "CreateXlateObject". This error causes data to be written beyond the end of a memory area. As a result, data in the memory is erroneously overwritten, which can lead to malfunctions, including system crashes.

Additional details

At the beginning of the function, an Xlate object is created. The size of this object essentially depends on the number of color palette entries in the source surface. Later in the function's execution, there are several code paths that populate the color palette of the Xlate object. In some cases, it is incorrectly assumed that:
  • 256|d entries can be stored in the color palette of the Xlate object, or
  • as many entries can be stored in the color palette of the Xlate object as there are entries in the color palette of the destination surface.
However, this is not necessarily the case when a display mode with, for example, 16|d colors is used.

This results in more entries being stored in the color palette in memory than can actually fit in the color palette of the Xlate object. Consequently, data is erroneously written beyond the end of the intended memory area, causing subsequent data to be overwritten.


Update "OTSKB000001"

How is the bug fixed?

Summary

The update overwrites a few bytes of the machine code in the file "win32k.sys".

Additional details

  1. First, the file "win32k.sys" is backed up in its current state. This serves to allow this update to be uninstalled later if necessary.
  2. Then, a few bytes of the machine code in the file "win32k.sys" are overwritten. As a result, following machine code can store up to 256|d entries in the color palette of the Xlate object.

    This solution is not clean. It would be cleaner to set the size of the color palette according to the need. The chosen solution is more of a compromise between a clean solution and minimal change to the existing machine code.

    It is possible that this will be improved with a future update. However, for now, it is the best known solution.
  3. Then, the version number is increased from "5.00.2195.7640" to "5.00.2196.0001".
  4. Finally, the checksum is overwritten.

Changes in the file "win32k.sys"

Language: | Machine code
 | Offset: | Content
 |  | Old: | New:
ARA | E 21 71|h | 8B 45 10 53 56 57 85 C0 74 05 8B 40 14 EB 05 B8 00 01 00 00 | 53 56 57 B8 00 01 00 00 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Language: | Checksum
 | Offset: | Content
 |  | Old: | New:
ARA | 1 20|h | EC 04 1A 00 | 75 A0 19 00
CHS |  | 82 1E 1A 00 | 0B BA 19 00
CHT |  | A0 D1 19 00 | 28 6D 1A 00
CSY |  | 92 CB 19 00 | 1A 67 1A 00
DAN |  | 37 AD 19 00 | BF 48 1A 00
DEU |  | 68 F3 19 00 | F0 8E 1A 00
ELL |  | 2E 49 1A 00 | B7 E4 19 00
ENU |  | A8 DA 19 00 | 30 76 1A 00
ESN |  | 8D 31 1A 00 | 16 CD 19 00
FIN |  | 42 65 1A 00 | CB 00 1A 00
FRA |  | 53 F0 19 00 | DB 8B 1A 00
HEB |  | 54 35 1A 00 | DD D0 19 00
HUN |  | F6 D0 19 00 | 7E 6C 1A 00
ITA |  | 36 9C 1A 00 | BF 37 1A 00
JPN |  | D1 37 1A 00 | D1 37 1A 00
KOR |  | 41 A9 19 00 | 41 A9 19 00
NLD |  | 73 6F 1A 00 | FC 0A 1A 00
NOR |  | 88 62 1A 00 | 11 FE 19 00
PLK |  | 3D 93 1A 00 | C6 2E 1A 00
PTB |  | 39 D6 19 00 | C1 71 1A 00
PTG |  | 7F 5E 1A 00 | 08 FA 19 00
RUS |  | 65 C0 19 00 | ED 5B 1A 00
SVE |  | 8D F5 19 00 | 15 91 1A 00
TRK |  | 57 BF 19 00 | DF 5A 1A 00

Language: | Version number as integers
 | Offset 1: | Offset 2: | Content
 |  |  | Old: | New:
ARA | 18 C9 10|h | 18 C9 18|h | 00 00 05 00 D8 1D 93 08 | 00 00 05 00 01 00 94 08
CHS | 18 C7 7C|h | 18 C7 84|h
CHT | 18 C7 88|h | 18 C7 90|h
CSY | 18 C9 74|h | 18 C9 7C|h
DAN | 18 C9 2C|h | 18 C9 34|h
DEU | 18 C9 90|h | 18 C9 98|h
ELL | 18 CA 0C|h | 18 CA 14|h
ENU | 18 C6 F0|h | 18 C6 F8|h
ESN | 18 C9 74|h | 18 C9 7C|h
FIN | 18 C9 E0|h | 18 C9 E8|h
FRA | 18 C9 60|h | 18 C9 68|h
HEB | 18 C8 98|h | 18 C8 A0|h
HUN | 18 C9 1C|h | 18 C9 24|h
ITA | 18 C9 44|h | 18 C9 4C|h
JPN | 18 C8 04|h | 18 C8 0C|h
KOR | 18 C7 DC|h | 18 C7 E4|h
NLD | 18 C9 6C|h | 18 C9 74|h
NOR | 18 C9 1C|h | 18 C9 24|h
PLK | 18 C9 AC|h | 18 C9 B4|h
PTB | 18 C9 9C|h | 18 C9 A4|h
PTG | 18 C9 60|h | 18 C9 68|h
RUS | 18 C9 88|h | 18 C9 90|h
SVE | 18 C9 50|h | 18 C9 58|h
TRK | 18 C9 44|h | 18 C9 4C|h

Language: | Version number as a string
 | Offset 1: | Offset 2: | Content
 |  |  | Old: | New:
ARA | 18 CA 3C|h | 18 CB E8|h | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 35 00 2E 00 37 00 36 00 34 00 30 00 00 00 | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 36 00 2E 00 30 00 30 00 30 00 31 00 00 00
CHS | 18 C8 A8|h | 18 CA 58|h
CHT | 18 C8 B4|h | 18 CA 64|h
CSY | 18 CA A0|h | 18 CC 50|h
DAN | 18 CA 58|h | 18 CC 04|h
DEU | 18 CA C4|h | 18 CC 70|h
ELL | 18 CB 50|h | 18 CD 28|h
ENU | 18 C8 1C|h | 18 C9 CC|h
ESN | 18 CA B0|h | 18 CC 60|h
FIN | 18 CB 10|h | 18 CC C4|h
FRA | 18 CA 9C|h | 18 CC 58|h
HEB | 18 C9 E0|h | 18 CB 88|h
HUN | 18 CA 68|h | 18 CC 1C|h
ITA | 18 CA 74|h | 18 CC 24|h
JPN | 18 C9 30|h | 18 CA E0|h
KOR | 18 C9 08|h | 18 CA B8|h
NLD | 18 CA A8|h | 18 CC 58|h
NOR | 18 CA 58|h | 18 CC 14|h
PLK | 18 CA E8|h | 18 CC 98|h
PTB | 18 CA CC|h | 18 CC 80|h
PTG | 18 CA B4|h | 18 CC 64|h
RUS | 18 CA CC|h | 18 CC A4|h
SVE | 18 CA 94|h | 18 CC 50|h
TRK | 18 CA 80|h | 18 CC 30|h

Unchanged properties of the file "win32k.sys"

Language: | File size
 | Old: | New:
ARA | 1,678,352 bytes
CHS | 1,678,320 bytes
CHT | 1,678,320 bytes
CSY | 1,678,448 bytes
DAN | 1,678,384 bytes
DEU | 1,678,480 bytes
ELL | 1,678,672 bytes
ENU | 1,678,320 bytes
ESN | 1,678,480 bytes
FIN | 1,678,576 bytes
FRA | 1,678,448 bytes
HEB | 1,678,320 bytes
HUN | 1,678,416 bytes
ITA | 1,678,416 bytes
JPN | 1,678,320 bytes
KOR | 1,678,320 bytes
NLD | 1,678,448 bytes
NOR | 1,678,384 bytes
PLK | 1,678,512 bytes
PTB | 1,678,512 bytes
PTG | 1,678,480 bytes
RUS | 1,678,544 bytes
SVE | 1,678,448 bytes
TRK | 1,678,416 bytes


Update "OTSKB000001"

What are the system requirements for the update?

Summary

Operating System: | Windows 2000
Version of the file "win32k.sys": | 5.00.2195.7640

Additional details

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. The update can update all 24 editions of the file "win32k.sys".

Version "5.00.2195.7640" of the file "win32k.sys"

The update "OTSKB000001" does not contain a new version of the file "win32k.sys". Instead, the file already present on the hard drive is modified. For this reason, the specific version of the file that can be modified by the update must be present. This is version "5.00.2195.7640", which is the latest version for the operating system and is included in the update "KB3145739". This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of Windows 2000
  • CHS - for the simplified Chinese edition of Windows 2000
  • CHT - for the traditional Chinese edition of Windows 2000
  • CSY - for the Czech edition of Windows 2000
  • DAN - for the Danish edition of Windows 2000
  • DEU - for the German edition of Windows 2000
  • ELL - for the Greek edition of Windows 2000
  • ENU - for the English edition of Windows 2000
  • ESN - for the Spanish edition of Windows 2000
  • FIN - for the Finnish edition of Windows 2000
  • FRA - for the French edition of Windows 2000
  • HEB - for the Hebrew edition of Windows 2000
  • HUN - for the Hungarian edition of Windows 2000
  • ITA - for the Italian edition of Windows 2000
  • JPN - for the Japanese edition of Windows 2000 for IBM PC
  • KOR - for the Korean edition of Windows 2000
  • NLD - for the Dutch edition of Windows 2000
  • NOR - for the Norwegian edition of Windows 2000
  • PLK - for the Polish edition of Windows 2000
  • PTB - for the Portuguese edition of Windows 2000 with local peculiarities from Brazil
  • PTG - for the Portuguese edition of Windows 2000 with local peculiarities from Portugal
  • RUS - for the Russian edition of Windows 2000
  • SVE - for the Swedish edition of Windows 2000
  • TRK - for the Turkish edition of Windows 2000

The update "KB3145739" does not seem to exist for the NEC PC98.

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3145739.zip

The update "OTSKB000001" is only capable of modifying original files from Microsoft Corporation. Files that have already been modified - for any purpose - are no longer compatible with this update. The update detects the incompatibility due to the unknown checksum and then rejects to modify the altered file.

New root certificates

The update "KB3145739" was released by Microsoft Corporation in April 2016. Therefore, it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update "KB3145739" will fail with a reference to the file "update.inf". The April 2016 version of the root certificates can be downloaded here:
  • http://OnTheServer.de/temp/2025-04-19/rootsupd201604.exe

If the above link no longer works, the update "KB3145739" can also be manually installed without prior updating of the root certificates. To do this, one has to
  1. call the update "KB3145739" with the command-line parameter "-x" to extract the contained files, first.
  2. Then, the file "WinNT\system32\dllcache\win32k.sys" needs to be deleted if it exists.
  3. Then, the file "WinNT\system32\win32k.sys" needs to be backed up somewhere so that it becomes possible to uninstall the update "KB3145739" again.
  4. Then, the file "WinNT\Driver Cache\i386\win32k.sys" needs to be overwritten with the extracted file. If this file does not exist, the extracted file needs to be copied into this directory without overwriting.
  5. Then, the file "WinNT\system32\win32k.sys" needs to be overwritten with the extracted file.

    This step is not easily possible in Safe Mode.

The remaining extracted files are not needed.


  • DEU - deutsche Ausgabe von dieser Wissensdatenbank
  • ENU - English edition of this knowledge base (machine translated with only few manual corrections)