Stand: 1. August 2025

Dieser Abschnitt enthält die deutschsprachige Ausgabe von der Wissensdatenbank von OnTheServer.de.


Windows 2000


Windows 2000

offizielle Aktualisierungen von Microsoft Corporation

Aktualisierungsarten

  • Fehlerbehebung = nicht-sicherheitsrelevante Fehlerbehebung
  • Funktionserweiterung = fügt eine neue Funktion hinzu, welche kein Bestandteil von einer normalen "Windows 2000"-Installation ist
  • Funktionsreduzierung = deaktiviert eine bestehende Funktion
  • nutzlos = laut dem Artikel behebt die Aktualisierung einen sicherheitsrelevanten Fehler, welcher allerdings in Windows 2000 nicht ausgenutzt werden kann oder Ähnliches
  • Sicherheit = sicherheitsrelevante Fehlerbehebung

Übersicht über die Aktualisierungen

Art: Artikel Stand: betroffene Komponenten: enthaltene Dateien:
allgemein: Sicherheit:
Sicherheit Zertifikate - 2016-04 - aktuelle Version Zertifikate
  • advpack.dll (7.00.5489.0)
  • authroots.sst (2016-04-27)
  • delroots.sst (2016-04-27)
  • disallowedcert.sst (2015-12-18)
  • roots.sst (2015-12-18)
  • updroots.sst (2016-04-27)
  • w95inf16.dll (4.71.704.0)
  • w95inf32.dll (4.71.0016.0)
Sicherheit KB3032323 MS15-021 wurde ersetzt Schriftverarbeitung
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7624)
KB3097877 MS15-115 wurde ersetzt
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7633)
KB3109094 MS15-128 wurde ersetzt
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7635)
KB3124000 MS16-005 wurde ersetzt Speicherverwaltung
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7636)
KB3145739 MS16-039 aktuelle Version Schriftverarbeitung
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7640)


Aktualisierung "Zertifikate - 2016-04"


Aktualisierung "Zertifikate - 2016-04"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: Zertifikate - 2016-04
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • - unbekannt -

betroffene Funktion

  • - keine -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "Zertifikate - 2016-04"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von OnTheServer.de heruntergeladen werden, da nicht bekannt ist, ob diese Aktualisierung noch auf den Servern von Microsoft Corporation existiert:
  • INTL - für alle Sprach-Ausgaben vom Betriebssystem


Aktualisierung "Zertifikate - 2016-04"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Die Aktualisierung kann alle 24 Ausgaben aktualisieren.


Aktualisierung "Zertifikate - 2016-04"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
- ohne Pfad - | authroots.sst | 2016-04-27
- ohne Pfad - | delroots.sst | 2016-04-27
- ohne Pfad - | disallowedcert.sst | 2015-12-18
- ohne Pfad - | roots.sst | 2015-12-18
- ohne Pfad - | updroots.sst | 2016-04-27
%windir%\system32\ | advpack.dll | 7.00.5489.0
%windir%\system32\ | w95inf16.dll | 4.71.704.0
%windir%\system32\ | w95inf32.dll | 4.71.0016.0


Aktualisierung "(MS)KB3032323"


Aktualisierung "(MS)KB3032323"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: (MS)KB3032323
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB3032323"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2015-0074:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0087:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0088:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0089:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0090:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0091:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0092:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-0093:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • MS15-021:
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB3032323"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:

Version 1:

  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • JPN - für die japanische Ausgabe vom Betriebssystem für den NEC PC98
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Version 2:

  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • JPN - für die japanische Ausgabe vom Betriebssystem für den NEC PC98
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3032323.7z


Aktualisierung "(MS)KB3032323"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Zertifikate: 2016-04

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.

die Zertifikate in der Version "2016-04"

Die Aktualisierung wurde deutlich später veröffentlich, als das Service Pack 4. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem Service Pack 4 wird die Installation von der Aktualisierung mit einem Verweis auf die Datei "update.inf" scheitern.

Bezugsquellen für die Ausgabe vom April 2016 von den Zertifikaten befinden sich im entsprechenden Artikel.


Aktualisierung "(MS)KB3032323"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7624


Aktualisierung "(MS)KB3097877"


Aktualisierung "(MS)KB3097877"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: (MS)KB3097877
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB3097877"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2015-6100:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6101:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6102:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6103:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6104:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6109:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6113:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • MS15-115:
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB3097877"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • JPN - für die japanische Ausgabe vom Betriebssystem für den NEC PC98
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3097877.7z


Aktualisierung "(MS)KB3097877"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Zertifikate: 2016-04

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.

die Zertifikate in der Version "2016-04"

Die Aktualisierung wurde deutlich später veröffentlich, als das Service Pack 4. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem Service Pack 4 wird die Installation von der Aktualisierung mit einem Verweis auf die Datei "update.inf" scheitern.

Bezugsquellen für die Ausgabe vom April 2016 von den Zertifikaten befinden sich im entsprechenden Artikel.


Aktualisierung "(MS)KB3097877"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7633


Aktualisierung "(MS)KB3109094"


Aktualisierung "(MS)KB3109094"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: (MS)KB3109094
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB3109094"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2015-6106:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6107:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2015-6108:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • MS15-128:
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB3109094"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • JPN - für die japanische Ausgabe vom Betriebssystem für den NEC PC98
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3109094.7z


Aktualisierung "(MS)KB3109094"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Zertifikate: 2016-04

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.

die Zertifikate in der Version "2016-04"

Die Aktualisierung wurde deutlich später veröffentlich, als das Service Pack 4. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem Service Pack 4 wird die Installation von der Aktualisierung mit einem Verweis auf die Datei "update.inf" scheitern.

Bezugsquellen für die Ausgabe vom April 2016 von den Zertifikaten befinden sich im entsprechenden Artikel.


Aktualisierung "(MS)KB3109094"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7635


Aktualisierung "(MS)KB3124000"


Aktualisierung "(MS)KB3124000"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: (MS)KB3124000
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB3124000"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2016-0008:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • CVE-2016-0009:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
  • MS16-005:
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB3124000"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • JPN - für die japanische Ausgabe vom Betriebssystem für den NEC PC98
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3124000.7z


Aktualisierung "(MS)KB3124000"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Zertifikate: 2016-04

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.

die Zertifikate in der Version "2016-04"

Die Aktualisierung wurde deutlich später veröffentlich, als das Service Pack 4. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem Service Pack 4 wird die Installation von der Aktualisierung mit einem Verweis auf die Datei "update.inf" scheitern.

Bezugsquellen für die Ausgabe vom April 2016 von den Zertifikaten befinden sich im entsprechenden Artikel.


Aktualisierung "(MS)KB3124000"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7636


Aktualisierung "(MS)KB3145739"


Aktualisierung "(MS)KB3145739"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: (MS)KB3145739
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB3145739"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2016-0143:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2016-0145:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2016-0165:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2016-0167:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • MS16-039:
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB3145739"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Die Aktualisierung scheint nicht für den PC98 von NEC zu existieren.

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/KB3145739.7z


Aktualisierung "(MS)KB3145739"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Zertifikate: 2016-04

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.

die Zertifikate in der Version "2016-04"

Die Aktualisierung wurde deutlich später veröffentlich, als das Service Pack 4. Sie erfordert daher für die Installation eine relativ neue Ausgabe von den Stammzertifikaten. Mit der alten Ausgabe von den Stammzertifikaten aus dem Service Pack 4 wird die Installation von der Aktualisierung mit einem Verweis auf die Datei "update.inf" scheitern.

Bezugsquellen für die Ausgabe vom April 2016 von den Zertifikaten befinden sich im entsprechenden Artikel.


Aktualisierung "(MS)KB3145739"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7640


Windows 2000

Inoffizielle Aktualisierungen von OnTheServer.de

Legende

Sicherheitsrelevanz

  • 0/4 - irrelevant
  • 1/4 - eher irrelevant
  • 2/4 - etwas relevant
  • 3/4 - eher relevant
  • 4/4 - relevant

Wichtigkeit

  • 0/4 - unwichtig
  • 1/4 - eher unwichtig
  • 2/4 - etwas wichtig
  • 3/4 - eher wichtig
  • 4/4 - wichtig

Übersicht über die Aktualisierungen

Aktualisierung: betroffene Komponente: Sicherheitsrelevanz: Wichtigkeit:
OTSKB000001 WinNT\system32\win32k.sys\CreateXlateObject 1/4 - eher irrelevant 2/4 - etwas wichtig


Aktualisierung "OTSKB000001"


Aktualisierung "OTSKB000001"

Was ist dies?

Zusammenfassung

OTSKB000001 ist eine Aktualisierung für das Betriebssystem "Windows 2000".

Die Aktualisierung behebt einen Fehler, um schwere Ausnahmefälle ("blue screens") zu reduzieren.

weitere Details

Es handelt sich um keine offizielle Aktualisierung von Microsoft Corporation, sondern um eine unoffizielle Aktualisierung von OnTheServer.de.

  • "OTS" steht für "OnTheServer" und gibt den Herausgeber an. Dies entspricht der Angabe "MS" in "MSKB123", um Microsoft Corporation als Herausgeber anzugeben. Microsoft verzichtet jedoch in vielen Fällen auf die Angabe "MS".
  • "KB" steht für "knowledge base" und bedeutet ungefähr "Wissensdatenbank". Eigentlich wird also mit der Nummer ein bestimmter Artikel aus der Wissensdatenbank angegeben. Allerdings wird die Bezeichnung auch für die Aktualisierung selbst verwendet.

    Microsoft Corporation hatte ursprünglich die Abkürzung "Q" anstatt "KB" verwendet, was für "question" stand. "question" bedeutet "Frage". Zur Frage gibt es dann eine Antwort und eine Problemlösung. Die Lösung war oft die Aktualisierung. Die Aktualisierung wurde dann genauso wie der Artikel mit der zugehörigen Frage benannt, sodass die verschiedenen Aktualisierungen ihren Artikeln zugeordnet werden können.

    Dennoch gibt es noch immer alte Aktualisierungen mit einer Bezeichnung im Format "Q123" anstatt "KB123".
  • Die Nummer ist eine fortlaufende Dezimalzahl, um die Aktualisierung eindeutig identifizieren zu können.


Aktualisierung "OTSKB000001"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - keine verfügbar -
Windows 2: - keine verfügbar -
Windows 3.0: - keine verfügbar -
Windows 3.1: - keine verfügbar -
Windows 95: - keine verfügbar -
Windows 98: - keine verfügbar -
Windows Me: - keine verfügbar -
Windows NT 3.1: - keine verfügbar -
Windows NT 3.5.0: - keine verfügbar -
Windows NT 3.5.1: - keine verfügbar -
Windows NT 4.0: - keine verfügbar -
Windows 2000: OTSKB000001
Windows XP (32 Bit): - keine verfügbar -
Windows Server 2003 (32 Bit): - keine verfügbar -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - keine verfügbar -
Windows Server 2008: - keine verfügbar -

nicht hilfreich:
(MS)KB4525239
(MS)KB4541504
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - keine verfügbar -

nicht hilfreich:
(MS)KB4525233
(MS)KB4541500
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - keine verfügbar -

nicht hilfreich:
(MS)KB4525233
(MS)KB4541500
Windows 8: - keine verfügbar -
Windows Phone 8: - unbekannt -
Windows 8.1: - keine verfügbar -

nicht hilfreich:
(MS)KB4525250
(MS)KB4541505
Windows RT 8.1: - keine verfügbar -

nicht hilfreich:
(MS)KB4525243
(MS)KB4541509
Windows Server 2012: - keine verfügbar -

nicht hilfreich:
(MS)KB4525253
(MS)KB4540694
Windows Server 2012 R2: - keine verfügbar -

nicht hilfreich:
(MS)KB4525250
(MS)KB4541505
Windows 10: - keine verfügbar -

nicht hilfreich:
(MS)KB4525232
(MS)KB4525236
(MS)KB4540693
Windows 10 Version 1607: - keine verfügbar -

nicht hilfreich:
(MS)KB4525236
(MS)KB4540670
Windows 10 Version 1709: - keine verfügbar -

nicht hilfreich:
(MS)KB4525241
(MS)KB4540681
Windows 10 Version 1803: - keine verfügbar -

nicht hilfreich:
(MS)KB4525237
(MS)KB4540689
Windows Server Version 1803: - keine verfügbar -

nicht hilfreich:
(MS)KB4525237
Windows 10 Version 1809: - keine verfügbar -

nicht hilfreich:
(MS)KB4523205
(MS)KB4538461
Windows 10 Version 1903: - keine verfügbar -

nicht hilfreich:
(MS)KB4524570
(MS)KB4540673
Windows Server Version 1903: - keine verfügbar -

nicht hilfreich:
(MS)KB4524570
(MS)KB4540673
Windows 10 Version 1909: - keine verfügbar -

nicht hilfreich:
(MS)KB4540673
Windows Server Version 1909: - keine verfügbar -

nicht hilfreich:
(MS)KB4540673
Windows Server 2016: - keine verfügbar -

nicht hilfreich:
(MS)KB4525236
(MS)KB4540670
Windows Server 2019: - keine verfügbar -

nicht hilfreich:
(MS)KB4523205
(MS)KB4538461
Windows Server 2022: - keine verfügbar -
Windows 11: - keine verfügbar -
Windows Server 2025: - keine verfügbar -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • CreateXlateObject

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows 2000 Professional,
  • als auch Windows 2000 Advanced Server.

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "OTSKB000001"

Wie wichtig ist die Installation von dieser Aktualisierung?

Zusammenfassung

0/4 - unwichtig:
1/4 - eher unwichtig:
2/4 - etwas wichtig:
3/4 - eher wichtig:
4/4 - wichtig:

weitere Details

Das Schlimmste, was unter realistischen Bedingungen passieren kann, ist ein Systemabsturz während einem Schreibzugriff auf die Festplatte. Hierdurch kann in der Folge das Dateisystem korrumpiert werden. Dies hätte einen erheblichen Datenverlust zur Folge und würde gegebenenfalls eine Neuinstallation vom Betriebssystem erfordern.

Allerdings ist es sehr unwahrscheinlich, dass der schlimmste Fall eintritt. Weniger gravierende Auswirkungen sind deutlich wahrscheinlicher. Oft hat das Schreiben über das Ende von einem vorgesehenen Speicherbereich hinaus keine erkennbaren Auswirkungen.

Da eine erhebliche Zufallskomponente enthalten ist, gleicht also ein Verzicht auf die Installation von dieser Aktualisierung dem Spielen von russischem Roulette: Es ist nicht klar, ob überhaupt etwas passieren würde und wenn doch, wann dies der Fall wäre.


Aktualisierung "OTSKB000001"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

Zusammenfassung

Bewertung gemäß dem Maßstab von OnTheServer.de

0/4 - irrelevant:
1/4 - eher irrelevant:
2/4 - etwas relevant:
3/4 - eher relevant:
4/4 - relevant:

Bewertung gemäß dem Maßstab "Common Vulnerability Scoring System" ("CVSS"), Version 3.1

allgemein: | 8,8 | keine: | 0,0
Auswirkungen: | 6,0 | niedrig: | von 0,1 bis 3,9
Ausnutzbarkeit: | 2,0 | mittelmäßig: | von 4,0 bis 6,9
zeitabhängige Bewertung: | 7,8 | hoch: | von 7,0 bis 8,9
Gesamt: | 7,8 | kritisch: | von 9,0 bis 10,0

weitere Details

unterschiedliche Einstufungen

Der Fehler wurde von 2 Personen unabhängig voneinander entdeckt:
  • Im Jahr "2019" von Herrn Marcin Wiazowski.
  • Im Jahr "2025" von Herrn Gary Luck (von OnTheServer.de).

Ursprünglich hatte Herr Luck den Fehler als "irrelevant für die Sicherheit" eingeschätzt. Als ihm bekannt wurde, dass Herr Wiazowski den Fehler als sicherheitsrelevant eingeschätzt hat, hat Herr Luck seine Einschätzung um 1 Stufe auf "eher irrelevant" erhöht. Die Erhöhung von der Einstufung wurde alleine Aufgrund von der Behauptung von Herrn Wiazowski durchgeführt. Herr Luck verfügt über keine eigenen Erkenntnisse, wie der Fehler sicherheitsrelevante Auswirkungen haben könnte, bestreitet jedoch auch nicht, dass dies möglich ist.

Bewertung gemäß dem Maßstab "Common Vulnerability Scoring System" ("CVSS"), Version 3.1

Adresse zum Rechner

Ausnutzbarkeit
Herr Luck und Herr Wiazowski sind in dieser Kategorie zur selben Einschätzung gekommen:

Angriffsdistanz: | Netzwerk: | Gibt an, aus welcher Entfernung die Schwachstelle ausgenutzt werden kann.
 | benachbartes Netzwerk:
 | lokal:
 | physisch:
Vorbedingungen: | niedrig: | Gibt an, wieviele Gegebenheiten erfüllt sein müssen, auf welche der Angreifer keinen Einfluss hat. Dies ist zum Beispiel dann erfüllt, wenn das System auf eine bestimmte Weise konfiguriert sein muss.
 | hoch:
Zugriffsrechte: | keine: | Gibt an, wieviele Zugriffsrechte ein Angreifer haben muss.
 | wenige:
 | viele:
Benutzermitwirkung: | keine: | Gibt an, ob der Benutzer mitwirken muss. Dies ist zum Beispiel dann erfüllt, wenn er eine bestimmte Datei öffnen muss.
 | wird benötigt:
Ausbruch: | unverändert: | Gibt an, ob es durch eine Ausnutzung von dieser Schwachstelle möglich ist, auszubrechen. Dies ist zum Beispiel dann erfüllt, wenn ein laufendes Programm, welches die Schwachstelle ausnutzt, von dann an auf die Speicherbereiche von anderen Programmen zugreifen kann.
 | wird ermöglicht:

Auswirkungen
Herr Luck und Herr Wiazowski sind in dieser Kategorie zur selben Einschätzung gekommen:

Geheimnisverlust: | keiner: | Gibt an, ob es durch eine Ausnutzung von dieser Schwachstelle möglich ist, Informationen zu lesen, welche vom Angreifer nicht gelesen werden sollen.
 | niedrig:
 | hoch:
Datenverfälschung: | keine: | Gibt an, ob es durch eine Ausnutzung von dieser Schwachstelle möglich ist, Informationen zu schreiben, welche vom Angreifer nicht geschrieben werden sollen.
 | niedrig:
 | hoch:
Verfügbarkeitsverlust: | keiner: | Gibt an, ob die Verfügbarkeit vom System beeinträchtigt werden kann. Dies ist zum Beispiel dann erfüllt, wenn der Benutzer anschließend nicht mehr auf das Netzwerk zugreifen kann.
 | niedrig:
 | hoch:

zeitabhängige Bewertung
Herr Luck hat Angaben in dieser Kategorie gemacht.
Herr Wiazowski hat keine Angaben in dieser Kategorie gemacht.

Eigenleistung: | undefiniert: | Gibt an, wie leicht Angreifer die Schwachstelle ausnutzen können, bzw. wie viel Eigenleistung sie dafür zunächst aufbringen müssen.
 | Ausnutzbarkeit unbewiesen:
 | Prinzip bewiesen:
 | unausgereifter Schadcode vorhanden:
 | ausgereifter Schadcode vorhanden:
Fehlerbehebung: | undefiniert: | Gibt an, wie der Fehler behoben werden kann.
 | offizielle, endgültige Fehlerbehebung existiert:
 | offizielle, Übergangs-Fehlerbehebung existiert:
 | inoffizielle, Fehlerbehebung existiert:
 | keine Fehlerbehebung existiert:
Zuverlässigkeit vom Bericht: | undefiniert: | Gibt an, ob der Bericht über den Fehler geprüft wurde und wie detailiert der Bericht ist.
 | Fehlerursache unbekannt:
 | Bericht ist plausibel:
 | Bericht wurde bestätigt:

Die Angabe zur Fehlerbehebung bezieht sich auf das Betriebssystem "Windows 2000". Für andere Betriebssysteme gelten andere Angaben, welche jedoch in diesem Dokument nicht enthalten sind.

Die Angabe, dass der Bericht bestätigt wurde, bezieht sich auf die Tatsache, dass ein Fehler existiert. Herr Luck verfügt über keine eigenen Erkenntnisse, welche bestätigen würden, dass der Fehler sicherheitsrelevant ist. Die Sicherheitsrelevanz wurde lediglich von Herrn Wiazowski bejaht. Dieses Kriterium ist nicht nur dann erfüllt, wenn der ursprüngliche Bericht bestätigt wurde, sondern auch dann, wenn ein detailierter Bericht vorhanden ist. Dies ist mit dieser Hilfe-Datei der Fall. Diese Hilfe-Datei macht jedoch auch keine Aussage darüber, wie dieser Fehler sicherheitsrelevant ausgenutzt werden kann.

weitere Dokumente

  • CVE-2019-1395:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2019-1396:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2020-0788:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • ZDI-19-981:
    • offline Artikel von ZeroDayInitiative.com
    • online Artikel auf ZeroDayInitiative.com
  • ZDI-19-982:
    • offline Artikel von ZeroDayInitiative.com
    • online Artikel auf ZeroDayInitiative.com
  • ZDI-20-279:
    • offline Artikel von ZeroDayInitiative.com
    • online Artikel auf ZeroDayInitiative.com


Aktualisierung "OTSKB000001"

Worin besteht der Fehler?

Zusammenfassung

In der Datei "win32k.sys" befindet sich in der Funktion "CreateXlateObject" ein Programmierfehler. Dieser Fehler führt dazu, dass über das Ende von einem Speicherbereich hinausgeschrieben wird. Dadurch werden fehlerhafterweise Daten im Arbeitsspeicher überschrieben. Dies kann zu Fehlverhalten, inklusiv Systemabstürzen führen.

weitere Details

Am Anfang von der Funktion wird ein Xlate-Objekt erzeugt. Die Größe von diesem Objekt ist im Wesentlichen von der Anzahl der Farbpaletteneinträge im Quell-Bildspeicher abhängig. Im späteren Funktionsdurchlauf gibt es mehrere Code-Pfade, welche die Farbpalette vom Xlate-Objekt füllen. Hierbei wird teils fälschlicherweise davon ausgegangen, dass
  • 256|d Einträge in der Farbpalette vom Xlate-Object gespeichert werden können oder
  • soviele Einträge in der Farbpalette vom Xlate-Object gespeichert werden können, wie die Farbpalette vom Ziel-Bildspeicher Einträge hat.
Wenn eine Anzeige-Betriebsart mit beispielsweise 16|d Farben verwendet wird, dann ist dies jedoch nicht zwangsweise der Fall.

Hierdurch werden mehr Einträge für die Farbpalette im Arbeitsspeicher gespeichert, als in die Farbpalette vom Xlate-Objekt gespeichert werden können. Somit wird fälschlicherweise über das Ende vom vorgesehenen Speicherbereich hinausgeschrieben, wodurch fälschlicherweise nachfolgende Daten überschrieben werden.


Aktualisierung "OTSKB000001"

Wie wird der Fehler behoben?

Zusammenfassung

Die Aktualisierung überschreibt ein paar Byte vom Maschinencode von der Datei "win32k.sys".

weitere Details

  1. Zunächst werden ein paar Byte vom Maschinencode von der Datei "win32k.sys" überschrieben. Hierdurch werden Schreibzugriffe über das Ende von der Farbpalette vom Xlate-Objekt verhindert.
  2. Dann wird die Versionsnummer von "5.00.2195.7640" auf "5.00.2196.0001" erhöht.
  3. Dann wird die neue Prüfsumme gespeichert.

Änderungen an der Datei "win32k.sys"

Sprache: Maschinencode
Offset: Inhalt
alt: neu:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A 01 FF 75 | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 75 1B 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 89 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00 59
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7F|h | 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F EB 08 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 5A|h | 39 45 14 0F 84 14 02 00 00 39 45 20 0F 85 0B 02 00 00 | 83 7D 14 00 75 05 E9 12 02 00 00 83 7D 20 00 75 F5 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 33|h | 8B 5B 10 F6 C7 10 74 | 8B 43 11 A8 10 74 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3A|h | 13 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 E9 29 01 00 00 F7 C3 00 | 31 C9 89 4E 3C 8B 45 FC 85 C0 74 06 B1 FF 89 4C 86 38 E9 26 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 51|h | 00 01 00 0F 85 1D 01 00 00 | C1 E8 09 0F 83 1D 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5A|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 31 C9 80 F9 0A 75 02 B1 F6 3B 4D FC 73 09 89 4C 8E 3C 80 C1 01 73 EB E9 01 01 00 00 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Es gibt ein weiteres Dokument, welches eine Gegenüberstellung vom Quellcode
  • vom Zeitpunkt vor der Installation von der Aktualisierung und
  • vom Zeitpunkt nach der Installation von der Aktualisierung
enthält. Dieses Dokument steht aus rechtlichen Gründen nur für wissenschaftliche Zwecke zur Verfügung und darf nicht zweckentfremdet werden. Das Dokument befindet sich in einem passwortgeschützem Archiv. Es kann von der folgenden Quelle bezogen werden:
http://OnTheServer.de/temp/2025-05-27/code.7z

Um das Passwort zu erhalten, müssen Sie Ihren wissenschaftlichen Verwendungszweck glaubhaft darlegen können. Um das Archiv zu entschlüsseln benötigen Sie aus rechtlichen Gründen jedoch tatsächlich einen wissenschaftlichen Grund und nicht nur eine glaubhafte Darlegung. Sie können glaubhaft darlegen, indem Sie
  • entweder das Passwort anhand vom nachfolgenden Rätsel korrekt erraten können (Glaubwürdigkeit durch theoretische Fähigkeiten im Bereich).
  • oder ein Passwortrateprogramm schreiben können, welches alle Möglichkeiten durchläuft (Glaubwürdigkeit durch praktische Fähigkeiten im Bereich).
  • oder genügend Ihrer Lebzeit opfern, um alle Möglichkeiten manuell zu durchlaufen (Glaubwürdigkeit durch besondere Hingabe).

Hier ist der Hinweis für das Rätsel:
  • Das Passwort ist eine Zeichenkette, welche aus 8 Zeichen besteht.
  • Alle Zeichen sind jeweils entweder das Zeichen "0" oder das Zeichen "1".
  • Eine Maschine würde die Zeichenkette ausführen, wenn Sie den Befehl erhalten würde, die folgende Berechnung durchzuführen:
    eax =+ (
    123456789012345678901234567890123456789012345678901234567890
    + 1
    - 1234567890123456789012345678901234567890123456789012345678 * 100
    - 90
    + 4294967295
    + 4294967295
    )

Teilen Sie bitte Anderen nicht dieses Passwort mit. Es ist ein Mechanismus, um jene davon abzuhalten, das Dokument zu lesen, für welche es nicht bestimmt ist.

Sprache: Prüfsumme
Offset: Inhalt
alt: neu:
ARA | 1 20|h | EC 04 1A 00 | 7C 95 1A 00
CHS | 82 1E 1A 00 | 13 AF 19 00
CHT | A0 D1 19 00 | 30 62 1A 00
CSY | 92 CB 19 00 | 22 5C 1A 00
DAN | 37 AD 19 00 | C7 3D 1A 00
DEU | 68 F3 19 00 | F8 83 1A 00
ELL | 2E 49 1A 00 | BF D9 19 00
ENU | A8 DA 19 00 | 38 6B 1A 00
ESN | 8D 31 1A 00 | 1E C2 19 00
FIN | 42 65 1A 00 | D3 F5 19 00
FRA | 53 F0 19 00 | E3 80 1A 00
HEB | 54 35 1A 00 | E5 C5 19 00
HUN | F6 D0 19 00 | 86 61 1A 00
ITA | 36 9C 1A 00 | C7 2C 1A 00
JPN | D1 37 1A 00 | 62 C8 19 00
KOR | 41 A9 19 00 | D1 39 1A 00
NLD | 73 6F 1A 00 | 04 00 1A 00
NOR | 88 62 1A 00 | 19 F3 19 00
PLK | 3D 93 1A 00 | CE 23 1A 00
PTB | 39 D6 19 00 | C9 66 1A 00
PTG | 7F 5E 1A 00 | 10 EF 19 00
RUS | 65 C0 19 00 | F5 50 1A 00
SVE | 8D F5 19 00 | 1D 86 1A 00
TRK | 57 BF 19 00 | E7 4F 1A 00

Sprache: Versionsnummer als Ganzzahlen
Offset 1: Offset 2: Inhalt
alt: neu:
ARA | 18 C9 10|h | 18 C9 18|h | 00 00 05 00 D8 1D 93 08 | 00 00 05 00 01 00 94 08
CHS | 18 C7 7C|h | 18 C7 84|h
CHT | 18 C7 88|h | 18 C7 90|h
CSY | 18 C9 74|h | 18 C9 7C|h
DAN | 18 C9 2C|h | 18 C9 34|h
DEU | 18 C9 90|h | 18 C9 98|h
ELL | 18 CA 0C|h | 18 CA 14|h
ENU | 18 C6 F0|h | 18 C6 F8|h
ESN | 18 C9 74|h | 18 C9 7C|h
FIN | 18 C9 E0|h | 18 C9 E8|h
FRA | 18 C9 60|h | 18 C9 68|h
HEB | 18 C8 98|h | 18 C8 A0|h
HUN | 18 C9 1C|h | 18 C9 24|h
ITA | 18 C9 44|h | 18 C9 4C|h
JPN | 18 C8 04|h | 18 C8 0C|h
KOR | 18 C7 DC|h | 18 C7 E4|h
NLD | 18 C9 6C|h | 18 C9 74|h
NOR | 18 C9 1C|h | 18 C9 24|h
PLK | 18 C9 AC|h | 18 C9 B4|h
PTB | 18 C9 9C|h | 18 C9 A4|h
PTG | 18 C9 60|h | 18 C9 68|h
RUS | 18 C9 88|h | 18 C9 90|h
SVE | 18 C9 50|h | 18 C9 58|h
TRK | 18 C9 44|h | 18 C9 4C|h

Sprache: Versionsnummer als Zeichenkette
Offset 1: Offset 2: Inhalt
alt: neu:
ARA | 18 CA 3C|h | 18 CB E8|h | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 35 00 2E 00 37 00 36 00 34 00 30 00 00 00 | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 36 00 2E 00 30 00 30 00 30 00 31 00 00 00
CHS | 18 C8 A8|h | 18 CA 58|h
CHT | 18 C8 B4|h | 18 CA 64|h
CSY | 18 CA A0|h | 18 CC 50|h
DAN | 18 CA 58|h | 18 CC 04|h
DEU | 18 CA C4|h | 18 CC 70|h
ELL | 18 CB 50|h | 18 CD 28|h
ENU | 18 C8 1C|h | 18 C9 CC|h
ESN | 18 CA B0|h | 18 CC 60|h
FIN | 18 CB 10|h | 18 CC C4|h
FRA | 18 CA 9C|h | 18 CC 58|h
HEB | 18 C9 E0|h | 18 CB 88|h
HUN | 18 CA 68|h | 18 CC 1C|h
ITA | 18 CA 74|h | 18 CC 24|h
JPN | 18 C9 30|h | 18 CA E0|h
KOR | 18 C9 08|h | 18 CA B8|h
NLD | 18 CA A8|h | 18 CC 58|h
NOR | 18 CA 58|h | 18 CC 14|h
PLK | 18 CA E8|h | 18 CC 98|h
PTB | 18 CA CC|h | 18 CC 80|h
PTG | 18 CA B4|h | 18 CC 64|h
RUS | 18 CA CC|h | 18 CC A4|h
SVE | 18 CA 94|h | 18 CC 50|h
TRK | 18 CA 80|h | 18 CC 30|h

ungeänderte Eigenschaften von der Datei "win32k.sys"

Sprache: Dateigröße
alt: neu:
ARA | 1.678.352 Byte
CHS | 1.678.320 Byte
CHT | 1.678.320 Byte
CSY | 1.678.448 Byte
DAN | 1.678.384 Byte
DEU | 1.678.480 Byte
ELL | 1.678.672 Byte
ENU | 1.678.320 Byte
ESN | 1.678.480 Byte
FIN | 1.678.576 Byte
FRA | 1.678.448 Byte
HEB | 1.678.320 Byte
HUN | 1.678.416 Byte
ITA | 1.678.416 Byte
JPN | 1.678.320 Byte
KOR | 1.678.320 Byte
NLD | 1.678.448 Byte
NOR | 1.678.384 Byte
PLK | 1.678.512 Byte
PTB | 1.678.512 Byte
PTG | 1.678.480 Byte
RUS | 1.678.544 Byte
SVE | 1.678.448 Byte
TRK | 1.678.416 Byte


Aktualisierung "OTSKB000001"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von OnTheServer.de heruntergeladen werden:
  • INTL - für alle Sprach-Ausgaben vom Betriebssystem

Die Aktualisierung existiert nicht für den PC98 von NEC.


Aktualisierung "OTSKB000001"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows 2000
Version von der Datei "win32k.sys": 5.00.2195.7640

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows 2000 Professional,
  • als auch für Windows 2000 Advanced Server
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Die Aktualisierung kann alle 24 Ausgaben von der Datei "win32k.sys" aktualisieren.

die Datei "win32k.sys" in der Version "5.00.2195.7640"

Die Aktualisierung "OTSKB000001" enthält keine neue Version von der Datei "win32k.sys". Stattdessen wird jene Datei geändert, welche sich bereits auf der Festplatte befindet.

Aus diesem Grund muss jene Version von der Datei vorhanden sein, welche von der Aktualisierung geändert werden kann. Hierbei handelt es sich um die Version "5.00.2195.7640". Sie ist die neuste offizielle Version für das Betriebssystem. Sie ist in der Aktualisierung "KB3145739" enthalten. Im entsprechenden Artikel sind Bezugsquellen für die Aktualisierung "KB3145739" aufgelistet.

Die Aktualisierung "OTSKB000001" ist lediglich in der Lage, die Originaldateien von Microsoft Corporation zu ändern. Dateien, welche bereits - zu welchem Zweck auch immer - geändert wurden, sind nicht mehr kompatibel mit dieser Aktualisierung. Die Aktualisierung erkennt die Inkompatibilität aufgrund von der unbekannten Prüfsumme und lehnt dann das Ändern ab.


Aktualisierung "OTSKB000001"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version: Datei enthalten?:
%windir%\Help\ | OTSKB.chm | 2025-07-16 | ja
%windir%\system32\ | win32k.sys | 5.00.2196.0001 | nein, diese Version wird anhand von der bestehenden Version "5.00.2195.7640" erzeugt


Aktualisierung "OTSKB000001"

Welche externen Akteure haben an der Aktualisierung mitgewirkt?

  • BlackWingCat:
    update.exe hatte eine digitale Unterschrift für update.inf erfordert. BlackWingCat hatte dieses Erfordernis entfernt, sodass update.inf geändert werden kann, ohne dass eine neue digitale Unterschrift für update.inf notwendig wird. Dies hat während dem Alpha- und dem Betatest geholfen.

  • MilkChan:
    MilkChan hat darauf hingewiesen, dass
    • die Aktualisierung "(MS)KB4039384" die neuste Aktualisierung für Windows XP (32 Bit) ist, welche die Datei "win32k.sys" enthält.
    • die Aktualisierung "(MS)KB4516665" die neuste Aktualisierung für Windows Server 2003 (32 Bit) ist, welche die Datei "win32k.sys" enthält.
    • die Aktualisierung "(MS)KB4493927" die neuste Aktualisierung für Windows Embedded POSReady 2009 (32 Bit) ist, welche die Datei "win32k.sys" enthält.

    Hierdurch ist es möglich geworden, Aktualisierungen zu schreiben, welche der Aktualisierung "OTSKB000001" ähnlich sind, aber kompatibel mit den obigen Betriebssystemen sind.

  • New Damage X (新DamageX):
    New Damage X (新DamageX) hat darauf hingewiesen, dass das Dokument "ZDI-19-982" möglicherweise mit dieser Angelegenheit zusammenhängt. Hierdurch ist bekannt geworden, dass es sich scheinbar hierbei um einen sicherheitsrelevanten Fehler handelt und in der Folge, dass Microsoft Corporation diesen Fehler scheinbar bereits in neueren Versionen von Windows behoben hat. Beim Versuch, die Lösung von Microsoft zu analysiert, hat sich jedoch herausgestellt, dass Microsoft Corporation den Fehler nicht behoben hat.

  • Windows2000Warrior:
    Windows2000Warrior hat durch das Melden von einem Fehler in der Dokumentation und durch anfeuern/motivieren geholfen.

  • Jumper:
    anfeuern/motivieren


Aktualisierung "OTSKB000001"

Die öffentliche Diskussion hatte am 28. April 2025 (GMT + 0) im MSFN.org-Diskussionsforum begonnen.

Welche Änderungen hat es an der Aktualisierung gegeben?

Version 1

Für diese Version wurde nie eine Aktualisierung veröffentlicht. Sie war vielmehr ein Vorschlag, wie das Problem gelöst werden könnte. Hierbei wurde vorgeschlagen, den Maschinencode wie folgt zu ändern:

Sprache: Maschinencode
Offset: Inhalt
alt: neu:
ARA E 21 71|h 8B 45 10 53 56 57 85 C0 74 05 8B 40 14 EB 05 B8 00 01 00 00 53 56 57 B8 00 01 00 00 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Diese Lösung ist nicht sauber. Es wäre sauberer, die Größe von der Farbpalette dem Bedarf anzupassen. Bei der gewählten Lösung handelt es sich vielmehr um einen Kompromiss zwischen einer sauberen Lösung und einem geringen Eingriff in den bestehenden Maschinencode.

Tests hatten ergeben, dass diese Lösung zu mehr Systemabstürzen führt. Außerdem werden manchmal - im Speziellen bei manchen Symbolbildern - falsche Farben angezeigt:

5.00.2195.7640: 5.00.2196.0001V1:

Version 2

Diese Version enthält eine saubere Lösung, bei welcher dezentral an jeder Stelle in der Funktion, an welcher der Speicher beschrieben wird, geprüft wird, wieviel maximal geschrieben werden kann.

Für diese Version wurde vorgeschlagen, den Maschinencode wie folgt zu ändern:

Sprache: Maschinencode
Offset: Inhalt
alt: neu:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 74 03
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 64|h | 01 FF 75 | 51 EB 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7E|h | 89 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 59 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F 31 C0 EB 06 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3B|h | 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 | 31 C9 89 4E 3C 8B 45 FC B1 FF 89 4C 86 38
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5C|h | 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 80 F9 0A 75 02 B1 F6 3B 4D FC 73 0A 89 4C 8E 3C 41 80 FD 01 72 EA E9 00 01 00 00 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Der Alphatest für diese Version wurde am 28. Mai 2025 beendet.

Version 3

Diese Version behebt Fehler, welche in der Version 2 enthalten sind.

Für diese Version wurde vorgeschlagen, den Maschinencode wie folgt zu ändern:

Sprache: Maschinencode
Offset: Inhalt
alt: neu:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A 01 FF 75 | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 75 1B 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 89 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00 59
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7F|h | 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F EB 08 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 5A|h | 39 45 14 0F 84 14 02 00 00 39 45 20 0F 85 0B 02 00 00 | 83 7D 14 00 75 05 E9 12 02 00 00 83 7D 20 00 75 F5 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 33|h | 8B 5B 10 F6 C7 10 74 | 8B 43 11 A8 10 74 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3A|h | 13 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 E9 29 01 00 00 F7 C3 00 | 31 C9 89 4E 3C 8B 45 FC 85 C0 74 06 B1 FF 89 4C 86 38 E9 26 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 51|h | 00 01 00 0F 85 1D 01 00 00 | C1 E8 08 0F 83 1D 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5A|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 31 C9 80 F9 0A 75 02 B1 F6 3B 4D FC 73 09 89 4C 8E 3C 80 C1 01 73 EB E9 01 01 00 00 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

Der Alphatest für diese Version wurde am 16. Juli 2025 beendet.

Die Veröffentlichung von dieser Version für die Allgemeinheit hatte (ebenfalls) am 16. Juli 2025 stattgefunden.

Version 4

Diese Version behebt einen Fehler, welcher am 28. Juli 2025 in der Version 3 gefunden wurde. Der Fehler befindet sich in der Version 3 am Offset "E2551|h" im Maschinencode von der Datei "win32k.sys".

Da es sich um die aktuelle Version handelt, sind die Änderungen am Maschinencode im Kapitel "Fehlerbehebung" dokumentiert.

Der Alphatest für diese Version wurde am 1. August 2025 beendet.

Die Veröffentlichung von dieser Version für die Allgemeinheit hatte (ebenfalls) am 1. August 2025 stattgefunden.


Windows XP (32 Bit)


Windows XP (32 Bit)

offizielle Aktualisierungen von Microsoft Corporation

Aktualisierungsarten

  • Fehlerbehebung = nicht-sicherheitsrelevante Fehlerbehebung
  • Funktionserweiterung = fügt eine neue Funktion hinzu, welche kein Bestandteil von einer normalen "Windows 2000"-Installation ist
  • Funktionsreduzierung = deaktiviert eine bestehende Funktion
  • nutzlos = laut dem Artikel behebt die Aktualisierung einen sicherheitsrelevanten Fehler, welcher allerdings in Windows 2000 nicht ausgenutzt werden kann oder Ähnliches
  • Sicherheit = sicherheitsrelevante Fehlerbehebung

Übersicht über die Aktualisierungen

Art: Artikel Stand: betroffene Komponenten: enthaltene Dateien:
allgemein: Sicherheit:
Sicherheit KB4039384 - aktuelle Version Schriftverarbeitung
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)

weitere Aktualisierungen

Aktualisierungen für Windows Embedded for Point of Service in Windows XP

Es ist möglich, Aktualisierungen zu installieren, welche eigentlich für Windows Embedded for Point of Service vorgesehen sind.

Allerdings ist es während der Installation notwendig, einen bestimmten Wert in der Registrierung zu haben. Dieser Wert kann eingefügt werden, indem die nachfolgende Datei in die Registrierung importiert wird:
  • registry value to install updates for Windows Embedded for Point of Service in Windows XP.reg

Aktualisierungen für Windows Embedded POSReady 2009 in Windows XP

Falls
  • der Prozessor von der lokalen Maschine die Befehlssatzerweiterung "streaming SIMD extentions 2" ("SSE2") unterstützt,
dann
  • ist es möglich, Aktualisierungen zu installieren, welche eigentlich für Windows Embedded POSReady 2009 vorgesehen sind.

    Allerdings ist es während der Installation notwendig, einen bestimmten Wert in der Registrierung zu haben. Dieser Wert kann eingefügt werden, indem die nachfolgende Datei in die Registrierung importiert wird:
    • registry value to install updates for Windows Embedded POSReady 2009 in Windows XP.reg

weitere Dokumente
  • über die SSE2-Angelegenheit:
    • offline Artikel von LegacyUpdate.net
    • online Artikel auf LegacyUpdate.net


Aktualisierung "(MS)KB4039384"


Aktualisierung "(MS)KB4039384"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: - unbekannt -
Windows XP (32 Bit): (MS)KB4039384
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): (MS)KB4039384
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): (MS)KB4039384
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Dateien

  • %windir%\system32\usp10.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows XP Home (32 Bit),
  • als auch Windows XP Professional (32 Bit).

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB4039384"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2017-8675:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8676:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8678:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8680:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8681:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8682:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8683:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8684:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8685:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8687:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8688:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8695:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8696:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com
  • CVE-2017-8720:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB4039384"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSXP-KB4039384.7z


Aktualisierung "(MS)KB4039384"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows XP (32 Bit)

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows XP Home (32 Bit),
  • als auch für Windows XP Professional (32 Bit)
verwendet werden.

Es spielt auch keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle 24 Ausgaben.


Aktualisierung "(MS)KB4039384"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.3.0013.0
%windir%\system32\ | usp10.dll | 1.0420.2600.7334
%windir%\system32\ | win32k.sys | 5.1.2600.7334
%windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\ | gdiplus.dll | 5.2.6002.24180


Windows Server 2003 (32 Bit)


Windows Server 2003 (32 Bit)

offizielle Aktualisierungen von Microsoft Corporation

Aktualisierungsarten

  • Fehlerbehebung = nicht-sicherheitsrelevante Fehlerbehebung
  • Funktionserweiterung = fügt eine neue Funktion hinzu, welche kein Bestandteil von einer normalen "Windows 2000"-Installation ist
  • Funktionsreduzierung = deaktiviert eine bestehende Funktion
  • nutzlos = laut dem Artikel behebt die Aktualisierung einen sicherheitsrelevanten Fehler, welcher allerdings in Windows 2000 nicht ausgenutzt werden kann oder Ähnliches
  • Sicherheit = sicherheitsrelevante Fehlerbehebung

Übersicht über die Aktualisierungen

Art: Artikel Stand: betroffene Komponenten: enthaltene Dateien:
allgemein: Sicherheit:
Sicherheit KB4516665 - aktuelle Version Schriftverarbeitung
  • atmfd.dll (5.2.2.253)
  • gdiplus.dll (5.2.6003.20617)
  • spmsg.dll (6.3.0004.1)
  • win32k.sys (5.2.3790.6946)


Aktualisierung "(MS)KB4516665"


Aktualisierung "(MS)KB4516665"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: - unbekannt -
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): (MS)KB4516665
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): - unbekannt -
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Dateien

  • %windir%\system32\atmfd.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle Variante vom Betriebssystem sind betroffen. Diese sind also zum Beispiel
  • sowohl Windows Server 2003 Standard (32 Bit),
  • als auch Windows Server 2003 Enterprise (32 Bit).

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB4516665"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • - Für diese Aktualisierung scheint es keine sicherheitsrelevanten Dokumente zu geben. -


Aktualisierung "(MS)KB4516665"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSSERVER2003-KB4516665.7z


Aktualisierung "(MS)KB4516665"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows Server 2003 (32 Bit)
Service Pack: 2

weitere Details

Betriebssystem

Es spielt keine Rolle, welche Variante vom Betriebssystem installiert wurde. Die Aktualisierung kann also beispielsweise
  • sowohl für Windows Server 2003 Standard (32 Bit),
  • als auch für Windows Server 2003 Enterprise (32 Bit)
verwendet werden.

Es spielt fast keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für fast alle Ausgaben.


Aktualisierung "(MS)KB4516665"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | atmfd.dll | 5.2.2.253
%windir%\system32\ | spmsg.dll | 6.3.0004.1
%windir%\system32\ | win32k.sys | 5.2.3790.6946
%windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\ | gdiplus.dll | 5.2.6003.20617


Windows Embedded for Point of Service (32 Bit)


Windows Embedded for Point of Service (32 Bit)

offizielle Aktualisierungen von Microsoft Corporation

Aktualisierungsarten

  • Fehlerbehebung = nicht-sicherheitsrelevante Fehlerbehebung
  • Funktionserweiterung = fügt eine neue Funktion hinzu, welche kein Bestandteil von einer normalen "Windows 2000"-Installation ist
  • Funktionsreduzierung = deaktiviert eine bestehende Funktion
  • nutzlos = laut dem Artikel behebt die Aktualisierung einen sicherheitsrelevanten Fehler, welcher allerdings in Windows 2000 nicht ausgenutzt werden kann oder Ähnliches
  • Sicherheit = sicherheitsrelevante Fehlerbehebung

Übersicht über die Aktualisierungen

Art: Artikel Stand: betroffene Komponenten: enthaltene Dateien:
allgemein: Sicherheit:
Sicherheit KB4039384 - aktuelle Version Schriftverarbeitung
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)


Aktualisierung "(MS)KB4039384"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: - unbekannt -
Windows XP (32 Bit): (MS)KB4039384
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): (MS)KB4039384
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): (MS)KB4039384
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Dateien

  • %windir%\system32\usp10.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB4039384"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSEPOS-KB4039384.7z


Aktualisierung "(MS)KB4039384"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows Embedded for Point of Service (32 Bit)

weitere Details

Betriebssystem

Es spielt keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle Ausgaben.


Windows Embedded POSReady 2009 (32 Bit)


Windows Embedded POSReady 2009 (32 Bit)

offizielle Aktualisierungen von Microsoft Corporation

Aktualisierungsarten

  • Fehlerbehebung = nicht-sicherheitsrelevante Fehlerbehebung
  • Funktionserweiterung = fügt eine neue Funktion hinzu, welche kein Bestandteil von einer normalen "Windows 2000"-Installation ist
  • Funktionsreduzierung = deaktiviert eine bestehende Funktion
  • nutzlos = laut dem Artikel behebt die Aktualisierung einen sicherheitsrelevanten Fehler, welcher allerdings in Windows 2000 nicht ausgenutzt werden kann oder Ähnliches
  • Sicherheit = sicherheitsrelevante Fehlerbehebung

Übersicht über die Aktualisierungen

Art: Artikel Stand: betroffene Komponenten: enthaltene Dateien:
allgemein: Sicherheit:
Sicherheit KB4039384 - aktuelle Version Schriftverarbeitung
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)
Sicherheit KB4493927 - aktuelle Version Kernel
  • spmsg.dll (6.3.0013.0)
  • win32k.sys (5.1.2600.7684)


Aktualisierung "(MS)KB4039384"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSPOSREADY2009-KB4039384.7z


Aktualisierung "(MS)KB4039384"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows Embedded POSReady 2009 (32 Bit)

weitere Details

Betriebssystem

Es spielt keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle Ausgaben.


Aktualisierung "(MS)KB4493927"


Aktualisierung "(MS)KB4493927"

Welche Komponenten sind betroffen?

Zusammenfassung

betroffene Betriebssysteme

Betriebssystem: unbekannt: nein: ja: Aktualisierung:
Windows 1: - unbekannt -
Windows 2: - unbekannt -
Windows 3.0: - unbekannt -
Windows 3.1: - unbekannt -
Windows 95: - unbekannt -
Windows 98: - unbekannt -
Windows Me: - unbekannt -
Windows NT 3.1: - unbekannt -
Windows NT 3.5.0: - unbekannt -
Windows NT 3.5.1: - unbekannt -
Windows NT 4.0: - unbekannt -
Windows 2000: - unbekannt -
Windows XP (32 Bit): - unbekannt -
Windows Server 2003 (32 Bit): - unbekannt -
Windows Embedded for Point of Service (32 Bit): - unbekannt -
Windows Vista: - unbekannt -
Windows Server 2008: - unbekannt -
Windows Embedded POSReady 2009 (32 Bit): (MS)KB4493927
Windows 7: - unbekannt -
Windows Phone 7: - unbekannt -
Windows Server 2008 R2: - unbekannt -
Windows 8: - unbekannt -
Windows Phone 8: - unbekannt -
Windows 8.1: - unbekannt -
Windows RT 8.1: - unbekannt -
Windows Server 2012: - unbekannt -
Windows Server 2012 R2: - unbekannt -
Windows 10: - unbekannt -
Windows 10 Version 1607: - unbekannt -
Windows 10 Version 1709: - unbekannt -
Windows 10 Version 1803: - unbekannt -
Windows Server Version 1803: - unbekannt -
Windows 10 Version 1809: - unbekannt -
Windows 10 Version 1903: - unbekannt -
Windows Server Version 1903: - unbekannt -
Windows 10 Version 1909: - unbekannt -
Windows Server Version 1909: - unbekannt -
Windows Server 2016: - unbekannt -
Windows Server 2019: - unbekannt -
Windows Server 2022: - unbekannt -
Windows 11: - unbekannt -
Windows Server 2025: - unbekannt -

betroffene Datei

  • %windir%\system32\win32k.sys

betroffene Funktion

  • - unbekannt -

weitere Details

betroffene Betriebssysteme

Alle sprachspezifische Ausgaben vom Betriebssystem sind betroffen.


Aktualisierung "(MS)KB4493927"

Welche Relevanz hat die Aktualisierung für die Sicherheit?

weitere Dokumente

  • CVE-2019-0848:
    • offline Artikel von CVE.org
    • online Artikel auf CVE.org
    • offline Artikel von Microsoft.com
    • online Artikel auf Microsoft.com


Aktualisierung "(MS)KB4493927"

Woher kann man die Aktualisierung bekommen?

Diese Aktualisierung kann von Microsoft Corporation heruntergeladen werden:
  • ARA - für die arabische Ausgabe vom Betriebssystem
  • CHS - für die vereinfachte, chinesische Ausgabe vom Betriebssystem
  • CHT - für die traditionelle, chinesiche Ausgabe vom Betriebssystem
  • CSY - für die tschechische Ausgabe vom Betriebssystem
  • DAN - für die dänische Ausgabe vom Betriebssystem
  • DEU - für die deutsch Ausgabe vom Betriebssystem
  • ELL - für die griechische Ausgabe vom Betriebssystem
  • ENU - für die englische Ausgabe vom Betriebssystem
  • ESN - für die spanische Ausgabe vom Betriebssystem
  • FIN - für die finnische Ausgabe vom Betriebssystem
  • FRA - für die französische Ausgabe vom Betriebssystem
  • HEB - für die hebräische Ausgabe vom Betriebssystem
  • HUN - für die ungarische Ausgabe vom Betriebssystem
  • ITA - für die italienische Ausgabe vom Betriebssystem
  • JPN - für die japanische Ausgabe vom Betriebssystem für den IBM PC
  • KOR - für die koreanische Ausgabe vom Betriebssystem
  • NLD - für die holländische/niederländische Ausgabe vom Betriebssystem
  • NOR - für die norwegische Ausgabe vom Betriebssystem
  • PLK - für die polnische Ausgabe vom Betriebssystem
  • PTB - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Brasilien
  • PTG - für die portugiesische Ausgabe vom Betriebssystem mit den lokalen Besonderheiten aus Portugal
  • RUS - für die russische Ausgabe vom Betriebssystem
  • SVE - für die schwedische Ausgabe vom Betriebssystem
  • TRK - für die türkische Ausgabe vom Betriebssystem

Falls die obigen Verknüpfungen nicht mehr funktionieren sollten, dann kann die folgende Alternative verwendet werden, um sämtliche Ausgaben von der Aktualisierung in einem komprimierten Archiv herunterzuladen:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSPOSREADY2009-KB4493927.7z


Aktualisierung "(MS)KB4493927"

Welche Systemvoraussetzungen erfordert die Aktualisierung?

Zusammenfassung

Betriebssystem: Windows Embedded POSReady 2009 (32 Bit)

weitere Details

Betriebssystem

Es spielt keine Rolle, in welcher Sprache das Betriebssystem installiert wurde. Es gibt Aktualisierungen für alle Ausgaben.


Aktualisierung "(MS)KB4493927"

Welche Dateien sind enthalten?

Zusammenfassung

Pfad: Dateiname: Version:
%windir%\system32\ | spmsg.dll | 6.3.0013.0
%windir%\system32\ | win32k.sys | 5.1.2600.7684


revision: 1st of August 2025

This section contains the English edition of the knowledge base from OnTheServer.de.


Windows 2000

Official updates from Microsoft Corporation

Types of updates

  • bug fix = non-security-relevant bug fix
  • function extension = adds a new function to the operating system, which is no part of a vanilla Windows 2000 installation
  • function reduction = removes or deactivates an existing function
  • useless = fixes a bug, which doesn't occure in Windows 2000 or similar things
  • security = security-relevant bug fix

Overview of the updates

Type: Article Status: Affected components: Contained files:
General: Security:
security certificates - 2016-04 - current version certificates
  • advpack.dll (7.00.5489.0)
  • authroots.sst (2016-04-27)
  • delroots.sst (2016-04-27)
  • disallowedcert.sst (2015-12-18)
  • roots.sst (2015-12-18)
  • updroots.sst (2016-04-27)
  • w95inf16.dll (4.71.704.0)
  • w95inf32.dll (4.71.0016.0)
security KB3032323 MS15-021 has been replaced font processing
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7624)
KB3097877 MS15-115 has been replaced
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7633)
KB3109094 MS15-128 has been replaced
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7635)
KB3124000 MS16-005 has been replaced memory management
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7636)
KB3145739 MS16-039 current version font processing
  • spmsg.dll (6.2.0029.0)
  • win32k.sys (5.00.2195.7640)


Update "certificates - 2016-04"


Update "certificates - 2016-04"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: certificates - 2016-04
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • - unknown -

Affected function

  • - none -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "certificates - 2016-04"

How can one obtain the update?

This update can be downloaded from OnTheServer.de, because it is not known whether this update still exists on the servers of Microsoft Corporation:
  • INTL - for all language editions of the operating system


Update "certificates - 2016-04"

What are the system requirements for the update?

Summary

Operating system: Windows 2000

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. The update can update all 24 editions.


Update "certificates - 2016-04"

Which files are contained?

Summary

Path: File name: Version:
- without path - | authroots.sst | 2016-04-27
- without path - | delroots.sst | 2016-04-27
- without path - | disallowedcert.sst | 2015-12-18
- without path - | roots.sst | 2015-12-18
- without path - | updroots.sst | 2016-04-27
%windir%\system32\ | advpack.dll | 7.00.5489.0
%windir%\system32\ | w95inf16.dll | 4.71.704.0
%windir%\system32\ | w95inf32.dll | 4.71.0016.0


Update "(MS)KB3032323"


Update "(MS)KB3032323"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: (MS)KB3032323
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "(MS)KB3032323"

How is the update relevant to security?

Additional documents

  • CVE-2015-0074:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0087:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0088:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0089:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0090:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0091:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0092:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-0093:
    • offline article from CVE.org
    • online article on CVE.org
  • MS15-021:
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB3032323"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:

Version 1:

  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • JPN - for the Japanese edition of the operating system for the NEC PC98
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

Version 2:

  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • JPN - for the Japanese edition of the operating system for the NEC PC98
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3032323.7z


Update "(MS)KB3032323"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Certificates: 2016-04

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.

Version "2016-04" of the certificates

The update has been released much later than service pack 4. For this reason it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update will fail with a reference to the file "update.inf".

Download links for the April 216 edition of the certificates are in the matching article.


Update "(MS)KB3032323"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7624


Update "(MS)KB3097877"


Update "(MS)KB3097877"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: (MS)KB3097877
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "(MS)KB3097877"

How is the update relevant to security?

Additional documents

  • CVE-2015-6100:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6101:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6102:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6103:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6104:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6109:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6113:
    • offline article from CVE.org
    • online article on CVE.org
  • MS15-115:
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB3097877"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • JPN - for the Japanese edition of the operating system for the NEC PC98
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3097877.7z


Update "(MS)KB3097877"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Certificates: 2016-04

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.

Version "2016-04" of the certificates

The update has been released much later than service pack 4. For this reason it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update will fail with a reference to the file "update.inf".

Download links for the April 216 edition of the certificates are in the matching article.


Update "(MS)KB3097877"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7633


Update "(MS)KB3109094"


Update "(MS)KB3109094"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: (MS)KB3109094
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "(MS)KB3109094"

How is the update relevant to security?

Additional documents

  • CVE-2015-6106:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6107:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2015-6108:
    • offline article from CVE.org
    • online article on CVE.org
  • MS15-128:
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB3109094"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • JPN - for the Japanese edition of the operating system for the NEC PC98
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3109094.7z


Update "(MS)KB3109094"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Certificates: 2016-04

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.

Version "2016-04" of the certificates

The update has been released much later than service pack 4. For this reason it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update will fail with a reference to the file "update.inf".

Download links for the April 216 edition of the certificates are in the matching article.


Update "(MS)KB3109094"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7635


Update "(MS)KB3124000"


Update "(MS)KB3124000"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: (MS)KB3124000
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "(MS)KB3124000"

How is the update relevant to security?

Additional documents

  • CVE-2016-0008:
    • offline article from CVE.org
    • online article on CVE.org
  • CVE-2016-0009:
    • offline article from CVE.org
    • online article on CVE.org
  • MS16-005:
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB3124000"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • JPN - for the Japanese edition of the operating system for the NEC PC98
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3124000.7z


Update "(MS)KB3124000"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Certificates: 2016-04

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.

Version "2016-04" of the certificates

The update has been released much later than service pack 4. For this reason it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update will fail with a reference to the file "update.inf".

Download links for the April 216 edition of the certificates are in the matching article.


Update "(MS)KB3124000"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7636


Update "(MS)KB3145739"


Update "(MS)KB3145739"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: (MS)KB3145739
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "(MS)KB3145739"

How is the update relevant to security?

Additional documents

  • CVE-2016-0143:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2016-0145:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2016-0165:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2016-0167:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • MS16-039:
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB3145739"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

The update does not seem to exist for the NEC PC98.

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/KB3145739.7z


Update "(MS)KB3145739"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Certificates: 2016-04

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.

Version "2016-04" of the certificates

The update has been released much later than service pack 4. For this reason it requires a relatively recent version of the root certificates for installation. With the old version of the root certificates from Service Pack 4, the installation of the update will fail with a reference to the file "update.inf".

Download links for the April 216 edition of the certificates are in the matching article.


Update "(MS)KB3145739"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.2.0029.0
%windir%\system32\ | win32k.sys | 5.00.2195.7640


Windows 2000

Inofficial updates from OnTheServer.de

Legend

Importance

  • 0/4 - unimportant
  • 1/4 - rather unimportant
  • 2/4 - somewhat important
  • 3/4 - rather important
  • 4/4 - important

Relevance to security

  • 0/4 - irrelevant
  • 1/4 - rather irrelevant
  • 2/4 - somewhat relevant
  • 3/4 - rather relevant
  • 4/4 - relevant

Overview of the updates

Update: Affected components: Importance: Relevance to security:
OTSKB000001 WinNT\system32\win32k.sys\CreateXlateObject 2/4 - somewhat important 1/4 - rather irrelevant


Update "OTSKB000001"


Update "OTSKB000001"

What is this?

Summary

OTSKB000001 is an update for the operating system "Windows 2000".

The update fixes a bug to reduce system crashes ("blue screens").

Additional details

This is not an official update from Microsoft Corporation, but rather an unofficial update from OnTheServer.de.

  • "OTS" stands for "OnTheServer" and indicates the publisher. This corresponds to the designation "MS" in "MSKB123", which indicates Microsoft Corporation as the publisher. However, Microsoft often omits the "MS" designation.
  • "KB" stands for "knowledge base" and roughly means "knowledge database". Actually, the number refers to a specific article in the knowledge base. However, the term is also used for the update itself.

    Microsoft Corporation originally used the abbreviation "Q" instead of "KB", which stood for "question". For the question, there is an answer and a solution to the problem. The solution was often the update. The update was then named just like the article with the corresponding question, so that the various updates could be matched to their articles.

    Nevertheless, there are still old updates with a designation in the format "Q123" instead of "KB123".
  • The number is a consecutive decimal number used to uniquely identify the update.


Update "OTSKB000001"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - none available -
Windows 2: - none available -
Windows 3.0: - none available -
Windows 3.1: - none available -
Windows 95: - none available -
Windows 98: - none available -
Windows Me: - none available -
Windows NT 3.1: - none available -
Windows NT 3.5.0: - none available -
Windows NT 3.5.1: - none available -
Windows NT 4.0: - none available -
Windows 2000: OTSKB000001
Windows XP (32 bits): - none available -
Windows Server 2003 (32 bits): - none available -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - none available -
Windows Server 2008: - none available -

not related:
(MS)KB4525239
(MS)KB4541504
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - none available -

not related:
(MS)KB4525233
(MS)KB4541500
Windows Phone 7: - unknown -
Windows Server 2008 R2: - none available -

not related:
(MS)KB4525233
(MS)KB4541500
Windows 8: - none available -
Windows Phone 8: - unknown -
Windows 8.1: - none available -

not related:
(MS)KB4525250
(MS)KB4541505
Windows RT 8.1: - none available -

not related:
(MS)KB4525243
(MS)KB4541509
Windows Server 2012: - none available -

not related:
(MS)KB4525253
(MS)KB4540694
Windows Server 2012 R2: - none available -

not related:
(MS)KB4525250
(MS)KB4541505
Windows 10: - none available -

not related:
(MS)KB4525232
(MS)KB4525236
(MS)KB4540693
Windows 10 Version 1607: - none available -

not related:
(MS)KB4525236
(MS)KB4540670
Windows 10 Version 1709: - none available -

not related:
(MS)KB4525241
(MS)KB4540681
Windows 10 Version 1803: - none available -

not related:
(MS)KB4525237
(MS)KB4540689
Windows Server Version 1803: - none available -

not related:
(MS)KB4525237
Windows 10 Version 1809: - none available -

not related:
(MS)KB4523205
(MS)KB4538461
Windows 10 Version 1903: - none available -

not related:
(MS)KB4524570
(MS)KB4540673
Windows Server Version 1903: - none available -

not related:
(MS)KB4524570
(MS)KB4540673
Windows 10 Version 1909: - none available -

not related:
(MS)KB4540673
Windows Server Version 1909: - none available -

not related:
(MS)KB4540673
Windows Server 2016: - none available -

not related:
(MS)KB4525236
(MS)KB4540670
Windows Server 2019: - none available -

not related:
(MS)KB4523205
(MS)KB4538461
Windows Server 2022: - none available -
Windows 11: - none available -
Windows Server 2025: - none available -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • CreateXlateObject

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows 2000 Professional and
  • Windows 2000 Advanced Server.

All language-specific editions of the operating system are affected.


Update "OTSKB000001"

How important is the installation of this update?

Summary

0/4 - unimportant:
1/4 - rather unimportant:
2/4 - somewhat important:
3/4 - rather important:
4/4 - important:

Additional details

The worst that can happen under realistic conditions is a system crash during a write access to the hard drive. As a result, the file system could become corrupted. This would lead to a significant data loss and might require a reinstallation of the operating system.

However, it is very unlikely that the worst case will occur. Less severe effects are much more probable. Often, writing beyond the end of an intended memory area has no noticeable effects.

Since there is a considerable element of randomness involved, abstaining from installing this update is akin to playing Russian roulette: It is unclear whether anything would happen at all, and if so, when that would be the case.


Update "OTSKB000001"

How is the update relevant to security?

Summary

Score according to the criterias of OnTheServer.de

0/4 - irrelevant:
1/4 - rather irrelevant:
2/4 - somewhat relevant:
3/4 - rather relevant:
4/4 - relevant:

Score according to the criterias of the "Common Vulnerability Scoring System" ("CVSS"), version 3.1

Base: | 8,8 | None: | 0,0
Impact: | 6,0 | Low: | from 0.1 to 3.9
Exploitability: | 2,0 | Medium: | from 4.0 to 6.9
Temporal score: | 7,8 | High: | from 7.0 to 8.9
Overall score: | 7,8 | Critical: | from 9.0 to 10.0

Additional details

Different classifications

The bug was discovered independently of one another by 2 persons:
  • In the year "2019" by Mr. Marcin Wiazowski.
  • In the year "2025" by Mr. Gary Luck (from OnTheServer.de).

Originally, Mr. Luck had assessed the bug as "irrelevant to security". When he became aware that Mr. Wiazowski assessed the bug as security-relevant, Mr. Luck increased his assessment by 1 level to "rather irrelevant". The increase in classification was carried out solely on the basis of the claim of Mr. Wiazowski. Mr. Luck has no knowledge of how the bug could have security-related effects, but does not deny that this is possible.

Score according to the criterias of the "Common Vulnerability Scoring System" ("CVSS"), version 3.1

Link to the calculator

Exploitability
Mr. Luck and Mr. Wiazowski came to the same assessment in this category:

Attack vector: | Network: | Indicates the distance from which the vulnerability can be exploited.
 | Adjacent Network:
 | Local:
 | Physical:
Attack complexity: | Low: | Indicates how many circumstances must be met, on which the attacker has no influence. This is fulfilled, for example, if the system must be configured in a certain way.
 | High:
Privileges required: | None: | Indicates how many access rights the attacker needs to have.
 | Low:
 | High:
User interaction: | None: | Indicates whether the user has to participate. This is fulfilled, for example, if he has to open a specific file.
 | Required:
Scope: | Unchanged: | Indicates whether exploiting this vulnerability enables breaking out. This is fulfilled, for example, when a running program that exploits this vulnerability can access the memory areas from another program from then on.
 | Changed:

Impact
Mr. Luck and Mr. Wiazowski came to the same assessment in this category:

Confidentiality impact: | None: | Indicates whether it is possible to read information by exploiting this vulnerability, which was not meant to be read by the attacker.
 | Low:
 | High:
Integrity impact: | None: | Indicates whether it is possible to write information by exploiting this vulnerability, which was not meant to be written by the attacker.
 | Low:
 | High:
Availability impact: | None: | Indicates whether the availability of a system can be affected. This is fulfilled, for example, if the user can then no longer access the network.
 | Low:
 | High:

Temporal score
Mr. Luck has given information in this category.
Mr. Wiazowski has not given information in this category.

Exploit code maturity: | Not defined: | Indicates how easily attackers can take advantage of the vulnerability, or how much personal contribution they have to apply first.
 | Unproven that exploit exists:
 | Proof of concept code:
 | Functional exploit exists:
 | High:
Remediation level: | Not defined: | Indicates how the bug can be fixed.
 | Official fix:
 | (Official but) temporary fix:
 | Workaround (or inofficial fix):
 | Unavailable:
Report confidence: | Not defined: | Indicates whether the report about the bug was checked and how detailed the report is.
 | (Cause) unknown:
 | Reasonable:
 | Confirmed:

The indication of the remediation level refers to the operating system "Windows 2000". Other information applies to other operating systems, which is not included in this document.

The statment that the report has been confirmed refers to the fact, that there is a bug. Mr. Luck does not have knowledge of his own that would confirm that the bug is security-relevant. The security relevance was only affirmed by Mr. Wiazowski. This criterion is not only fulfilled if the original report has been confirmed, but also when a detailed report is available. This is the case with this help file. However, this help file does not make a statement about how this bug can be exploited in a security-relevant manner.

Additional documents

  • CVE-2019-1395:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2019-1396:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2020-0788:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • ZDI-19-981:
    • offline article from ZeroDayInitiative.com
    • online article on ZeroDayInitiative.com
  • ZDI-19-982:
    • offline article from ZeroDayInitiative.com
    • online article on ZeroDayInitiative.com
  • ZDI-20-279:
    • offline article from ZeroDayInitiative.com
    • online article on ZeroDayInitiative.com


Update "OTSKB000001"

What is the nature of the bug?

Summary

In the file "win32k.sys" there is a programming error in the function "CreateXlateObject". This error causes data to be written beyond the end of a memory area. As a result, data in the memory is erroneously overwritten, which can lead to malfunctions, including system crashes.

Additional details

At the beginning of the function, an Xlate object is created. The size of this object essentially depends on the number of color palette entries in the source surface. Later in the function's execution, there are several code paths that populate the color palette of the Xlate object. In some cases, it is incorrectly assumed that:
  • 256|d entries can be stored in the color palette of the Xlate object, or
  • as many entries can be stored in the color palette of the Xlate object as there are entries in the color palette of the destination surface.
However, this is not necessarily the case when a display mode with, for example, 16|d colors is used.

This results in more entries being stored in the color palette in memory than can actually fit in the color palette of the Xlate object. Consequently, data is erroneously written beyond the end of the intended memory area, causing subsequent data to be overwritten.


Update "OTSKB000001"

How is the bug fixed?

Summary

The update overwrites a few bytes of the machine code in the file "win32k.sys".

Additional details

  1. First, a few bytes of the machine code in the file "win32k.sys" are overwritten. As a result, write accesses beyond the end of the color palette of the Xlate object no longer take place.
  2. Then, the version number is increased from "5.00.2195.7640" to "5.00.2196.0001".
  3. Finally, the new checksum is stored.

Changes in the file "win32k.sys"

Language: Machine code
Offset: Content
Old: New:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A 01 FF 75 | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 75 1B 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 89 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00 59
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7F|h | 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F EB 08 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 5A|h | 39 45 14 0F 84 14 02 00 00 39 45 20 0F 85 0B 02 00 00 | 83 7D 14 00 75 05 E9 12 02 00 00 83 7D 20 00 75 F5 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 33|h | 8B 5B 10 F6 C7 10 74 | 8B 43 11 A8 10 74 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3A|h | 13 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 E9 29 01 00 00 F7 C3 00 | 31 C9 89 4E 3C 8B 45 FC 85 C0 74 06 B1 FF 89 4C 86 38 E9 26 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 51|h | 00 01 00 0F 85 1D 01 00 00 | C1 E8 09 0F 83 1D 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5A|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 31 C9 80 F9 0A 75 02 B1 F6 3B 4D FC 73 09 89 4C 8E 3C 80 C1 01 73 EB E9 01 01 00 00 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

There is another document that contains a side-by-side comparison of the source code
  • from the time before the update was installed and
  • from the time after the update was installed.
For legal reasons, this document is available for scientific purposes only and may not be misused for a different purpose. The document is located inside a password-protected archive. The archive can be downloaded from the following address:
http://OnTheServer.de/temp/2025-05-27/code.7z

To obtain the password, you must be able to credibly demonstrate your scientific purpose. However, for legal reasons, to decrypt the archive, you need an actual scientific reason, not just a credible demonstration. You can demonstrate credibility
  • either by correctly guessing the password using the following puzzle (credibility through theoretical skills in the domain).
  • or by writing a password guessing program that iterates through all possibilities (credibility through practical skills in the domain).
  • or by sacrificing enough of your life time to manually run through all possibilities (credibility through extensive devotion).

Here is the clue for the puzzle:
  • The password is a string consisting of 8 characters.
  • All characters are either the character "0" or the character "1".
  • A machine would execute the string if it were instructed to perform the following calculation:
    eax =+ (
    123456789012345678901234567890123456789012345678901234567890
    + 1
    - 1234567890123456789012345678901234567890123456789012345678 * 100
    - 90
    + 4294967295
    + 4294967295
    )

Don't share this password with others, please. It's a mechanism to keep those out, who are not meant to read the document.

Language: Checksum
Offset: Content
Old: New:
ARA | 1 20|h | EC 04 1A 00 | 7C 95 1A 00
CHS | 82 1E 1A 00 | 13 AF 19 00
CHT | A0 D1 19 00 | 30 62 1A 00
CSY | 92 CB 19 00 | 22 5C 1A 00
DAN | 37 AD 19 00 | C7 3D 1A 00
DEU | 68 F3 19 00 | F8 83 1A 00
ELL | 2E 49 1A 00 | BF D9 19 00
ENU | A8 DA 19 00 | 38 6B 1A 00
ESN | 8D 31 1A 00 | 1E C2 19 00
FIN | 42 65 1A 00 | D3 F5 19 00
FRA | 53 F0 19 00 | E3 80 1A 00
HEB | 54 35 1A 00 | E5 C5 19 00
HUN | F6 D0 19 00 | 86 61 1A 00
ITA | 36 9C 1A 00 | C7 2C 1A 00
JPN | D1 37 1A 00 | 62 C8 19 00
KOR | 41 A9 19 00 | D1 39 1A 00
NLD | 73 6F 1A 00 | 04 00 1A 00
NOR | 88 62 1A 00 | 19 F3 19 00
PLK | 3D 93 1A 00 | CE 23 1A 00
PTB | 39 D6 19 00 | C9 66 1A 00
PTG | 7F 5E 1A 00 | 10 EF 19 00
RUS | 65 C0 19 00 | F5 50 1A 00
SVE | 8D F5 19 00 | 1D 86 1A 00
TRK | 57 BF 19 00 | E7 4F 1A 00

Language: Version number as integers
Offset 1: Offset 2: Content
Old: New:
ARA | 18 C9 10|h | 18 C9 18|h | 00 00 05 00 D8 1D 93 08 | 00 00 05 00 01 00 94 08
CHS | 18 C7 7C|h | 18 C7 84|h
CHT | 18 C7 88|h | 18 C7 90|h
CSY | 18 C9 74|h | 18 C9 7C|h
DAN | 18 C9 2C|h | 18 C9 34|h
DEU | 18 C9 90|h | 18 C9 98|h
ELL | 18 CA 0C|h | 18 CA 14|h
ENU | 18 C6 F0|h | 18 C6 F8|h
ESN | 18 C9 74|h | 18 C9 7C|h
FIN | 18 C9 E0|h | 18 C9 E8|h
FRA | 18 C9 60|h | 18 C9 68|h
HEB | 18 C8 98|h | 18 C8 A0|h
HUN | 18 C9 1C|h | 18 C9 24|h
ITA | 18 C9 44|h | 18 C9 4C|h
JPN | 18 C8 04|h | 18 C8 0C|h
KOR | 18 C7 DC|h | 18 C7 E4|h
NLD | 18 C9 6C|h | 18 C9 74|h
NOR | 18 C9 1C|h | 18 C9 24|h
PLK | 18 C9 AC|h | 18 C9 B4|h
PTB | 18 C9 9C|h | 18 C9 A4|h
PTG | 18 C9 60|h | 18 C9 68|h
RUS | 18 C9 88|h | 18 C9 90|h
SVE | 18 C9 50|h | 18 C9 58|h
TRK | 18 C9 44|h | 18 C9 4C|h

Language: Version number as a string
Offset 1: Offset 2: Content
Old: New:
ARA | 18 CA 3C|h | 18 CB E8|h | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 35 00 2E 00 37 00 36 00 34 00 30 00 00 00 | 35 00 2E 00 30 00 30 00 2E 00 32 00 31 00 39 00 36 00 2E 00 30 00 30 00 30 00 31 00 00 00
CHS | 18 C8 A8|h | 18 CA 58|h
CHT | 18 C8 B4|h | 18 CA 64|h
CSY | 18 CA A0|h | 18 CC 50|h
DAN | 18 CA 58|h | 18 CC 04|h
DEU | 18 CA C4|h | 18 CC 70|h
ELL | 18 CB 50|h | 18 CD 28|h
ENU | 18 C8 1C|h | 18 C9 CC|h
ESN | 18 CA B0|h | 18 CC 60|h
FIN | 18 CB 10|h | 18 CC C4|h
FRA | 18 CA 9C|h | 18 CC 58|h
HEB | 18 C9 E0|h | 18 CB 88|h
HUN | 18 CA 68|h | 18 CC 1C|h
ITA | 18 CA 74|h | 18 CC 24|h
JPN | 18 C9 30|h | 18 CA E0|h
KOR | 18 C9 08|h | 18 CA B8|h
NLD | 18 CA A8|h | 18 CC 58|h
NOR | 18 CA 58|h | 18 CC 14|h
PLK | 18 CA E8|h | 18 CC 98|h
PTB | 18 CA CC|h | 18 CC 80|h
PTG | 18 CA B4|h | 18 CC 64|h
RUS | 18 CA CC|h | 18 CC A4|h
SVE | 18 CA 94|h | 18 CC 50|h
TRK | 18 CA 80|h | 18 CC 30|h

Unchanged properties of the file "win32k.sys"

Language: File size
Old: New:
ARA | 1,678,352 bytes
CHS | 1,678,320 bytes
CHT | 1,678,320 bytes
CSY | 1,678,448 bytes
DAN | 1,678,384 bytes
DEU | 1,678,480 bytes
ELL | 1,678,672 bytes
ENU | 1,678,320 bytes
ESN | 1,678,480 bytes
FIN | 1,678,576 bytes
FRA | 1,678,448 bytes
HEB | 1,678,320 bytes
HUN | 1,678,416 bytes
ITA | 1,678,416 bytes
JPN | 1,678,320 bytes
KOR | 1,678,320 bytes
NLD | 1,678,448 bytes
NOR | 1,678,384 bytes
PLK | 1,678,512 bytes
PTB | 1,678,512 bytes
PTG | 1,678,480 bytes
RUS | 1,678,544 bytes
SVE | 1,678,448 bytes
TRK | 1,678,416 bytes


Update "OTSKB000001"

How can one obtain the update?

This update can be downloaded from OnTheServer.de:
  • INTL - for all language editions of the operating system

The update does not exist for the NEC PC98.


Update "OTSKB000001"

What are the system requirements for the update?

Summary

Operating system: Windows 2000
Version of the file "win32k.sys": 5.00.2195.7640

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows 2000 Professional and
  • for Windows 2000 Advanced Server.

The language in which the operating system was installed also does not matter. The update can update all 24 editions of the file "win32k.sys".

Version "5.00.2195.7640" of the file "win32k.sys"

The update "OTSKB000001" does not contain a new version of the file "win32k.sys". Instead, the file already present on the hard drive is modified.

For this reason, the specific version of the file that can be modified by the update must be present. The necessary version is version "5.00.2195.7640", which is the latest official version for the operating system and is included in the update "KB3145739". Download links for the update "KB3145739" are listed in the matching article for the update.

The update "OTSKB000001" is only capable of modifying original files from Microsoft Corporation. Files that have already been modified - for any purpose - are no longer compatible with this update. The update detects the incompatibility due to the unknown checksum and then rejects to modify the altered file.


Update "OTSKB000001"

Which files are contained?

Summary

Path: File name: Version: File contained?:
%windir%\Help\ | OTSKB.chm | 2025-07-16 | yes
%windir%\system32\ | win32k.sys | 5.00.2196.0001 | no, this version is created with the help of the existing version "5.00.2195.7640"


Update "OTSKB000001"

Which external actors have contributed to the update?

  • BlackWingCat:
    update.exe required a digital signature for update.inf. BlackWingCat removed this requirement, so that update.inf can be modified without needing a new digital signature for update.inf. It helped during the alpha and beta tests.

  • MilkChan:
    MilkChan noted, that
    • the update "(MS)KB4039384" is the newest update for Windows XP (32 bits), which contains the file "win32k.sys".
    • the update "(MS)KB4516665" is the newest update for Windows Server 2003 (32 bits), which contains the file "win32k.sys".
    • the update "(MS)KB4493927" is the newest update for Windows Embedded POSReady 2009 (32 bits), which contains the file "win32k.sys".

    With this information it became possible to write updates similar to the update "OTSKB000001", but which are compatible with the operating systems mentioned above.

  • New Damage X (新DamageX):
    New Damage X (新DamageX) noted, that the document "ZDI-19-982" could be related to this issue. This revealed, that this issue could be relevant to security. This lead to the speculation, that Microsoft Corporation might have fixed this problem in newer versions of Windows and with that Microsoft's solution to the problem could be analysed. However, the analysis has revealed, that Microsoft Corporation did not fix the issue.

  • Windows2000Warrior:
    Windows2000Warrior helped by reporting a bug in the documentation and with cheerleading.

  • Jumper:
    cheerleading


Update "OTSKB000001"

The public discussion started on the 28th of April 2025 (GMT + 0) on the MSFN.org discussion board.

Which changes have been done to the update?

Version 1

For this version there was never an update released. The version was rather a suggestion for how the problem could be solved. It was suggested to modify the machine code as follows:

Language: Machine code
Offset: Content
Old: New:
ARA E 21 71|h 8B 45 10 53 56 57 85 C0 74 05 8B 40 14 EB 05 B8 00 01 00 00 53 56 57 B8 00 01 00 00 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

This solution is not clean. It would be cleaner to set the size of the color palette according to the need. The chosen solution is more of a compromise between a clean solution and minimal change to the existing machine code.

Tests have shown, that this solution leads to more system crashes. Also, sometimes - especially with some icons - wrong colors are displayed:

5.00.2195.7640: 5.00.2196.0001V1:

Version 2

This version has a decentral, clean solution by checking the storage space of the buffer everytime a write happens from within the function.

It was suggested to modify the machine code as follows:

Language: Machine code
Offset: Content
Old: New:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 74 03
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 64|h | 01 FF 75 | 51 EB 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7E|h | 89 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 59 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F 31 C0 EB 06 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3B|h | 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 | 31 C9 89 4E 3C 8B 45 FC B1 FF 89 4C 86 38
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5C|h | 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 80 F9 0A 75 02 B1 F6 3B 4D FC 73 0A 89 4C 8E 3C 41 80 FD 01 72 EA E9 00 01 00 00 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

The alpha test for this version ended on the 28th of May 2025.

Version 3

This version fixes bugs, which exist in version 2.

It was suggested to modify the machine code as follows:

Sprache: Maschinencode
Offset: Inhalt
alt: neu:
ARA | E 22 81|h | 33 C9 8D 46 3C 89 08 41 83 C0 04 81 F9 00 01 00 00 72 F2 E9 59 02 00 00 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 E9 5E 02 00 00 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 B0|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 22 C2|h | 83 7F 14 00 76 2D 8B 55 08 8B 4D 0C 6A FC 2B CA 8D 42 04 5A 2B 55 08 89 55 1C 0F B6 18 0F B6 14 01 89 54 9E 3C 8B 55 1C 40 03 D0 3B 57 14 72 EA | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 54 8E 3C 83 E8 01 73 E9 EB 0A 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 0C|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 47 03 00 00 | E9 49 02 00 00 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 42|h | 83 66 3C 00 C7 46 40 01 00 00 00 E9 25 03 00 00 | 8B 45 FC 83 F8 02 76 03 6A 02 58 E9 38 FF FF FF
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 52|h | 83 7D F8 00 74 0B 8B 45 20 89 46 3C 8B 45 24 EB 1B 6A 01 FF 75 | 8B 4D 20 89 4E 18 8B 45 24 89 46 1C 83 7D F8 00 75 1B 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 67|h | 20 57 53 E8 19 55 02 00 6A 01 89 46 3C FF 75 24 57 53 E8 0A 55 02 00 89 | 6A 01 51 57 53 E8 17 55 02 00 50 6A 01 FF 75 24 57 53 E8 0A 55 02 00 59
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 23 7F|h | 46 40 8B 45 20 80 4E 39 01 89 46 18 8B 45 24 89 46 1C E9 E1 02 00 00 | 83 7D FC 01 72 03 89 4E 3C 76 03 89 46 40 80 4E 39 01 E9 E1 02 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 31|h | 49 89 4D FC 8D 7C 8E 3C 8B 45 10 8B 4D FC 8B 40 4C 8B 14 88 8B 4D 1C FF 51 3C 89 07 8B 45 FC FF 4D FC 83 EF 04 85 C0 75 DF | 57 8B 7D FC EB 13 8B 4D 1C 8B 55 10 8B 52 4C 8B 14 BA FF 51 3C 89 44 BE 3C 83 EF 01 73 E8 5F EB 08 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 5A|h | 39 45 14 0F 84 14 02 00 00 39 45 20 0F 85 0B 02 00 00 | 83 7D 14 00 75 05 E9 12 02 00 00 83 7D 20 00 75 F5 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 9F|h | 33 C0 8D 4E 3C 89 01 40 83 C1 04 3D 00 01 00 00 72 F3 | 8B 45 FC EB 04 89 44 86 3C 83 E8 01 73 F7 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 24 FB|h | 83 7F 14 00 76 32 8B 4D 0C 8B 55 08 6A FC 2B D1 8D 41 04 59 2B 4D 0C 89 55 10 89 4D 1C EB 03 8B 55 10 0F B6 0C 02 0F B6 10 40 89 4C 96 3C 8B 4D 1C 03 C8 3B 4F 14 72 E7 | 8B 47 14 3B 45 FC 76 03 8B 45 FC EB 12 8B 4D 08 0F B6 49 04 8B 55 0C 0F B6 52 04 89 4C 96 3C 83 E8 01 73 E9 EB 12 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 33|h | 8B 5B 10 F6 C7 10 74 | 8B 43 11 A8 10 74 17
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 3A|h | 13 83 66 3C 00 C7 86 38 04 00 00 FF 00 00 00 E9 29 01 00 00 F7 C3 00 | 31 C9 89 4E 3C 8B 45 FC 85 C0 74 06 B1 FF 89 4C 86 38 E9 26 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 51|h | 00 01 00 0F 85 1D 01 00 00 | C1 E8 08 0F 83 1D 01 00 00
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 5A|h | 33 C9 8D 86 14 04 00 00 8D 91 F6 00 00 00 89 88 28 FC FF FF 89 10 41 83 C0 04 83 F9 0A 72 E9 E9 F9 00 00 00 | 31 C9 80 F9 0A 75 02 B1 F6 3B 4D FC 73 09 89 4C 8E 3C 80 C1 01 73 EB E9 01 01 00 00 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 81|h | B9 00 01 00 00 | 8B 4D FC 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 25 C1|h | 8D 86 14 04 00 00 C7 45 1C 84 92 17 A0 89 45 20 8B 45 1C 8B CB 8B 50 D8 FF 53 3C 8B 4D 20 89 81 28 FC FF FF 8B 45 1C 8B CB 8B 10 FF 53 3C 8B 4D 20 83 45 1C 04 83 45 20 04 81 7D 1C AC 92 17 A0 89 01 72 CC | 57 31 FF 83 FF 0A 75 05 BF F6 00 00 00 3B 7D FC 73 26 89 D9 83 FF 0A 73 09 8B 14 BD 5C 92 17 A0 EB 07 8B 14 BD AC 8E 17 A0 FF 53 3C 89 44 BE 3C 47 66 81 FF 00 01 72 CB 5F EB 09 90 90 90 90 90 90 90 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK
ARA | E 26 47|h | 83 65 10 00 83 7F 14 00 76 26 8B 47 4C 8B 4D 10 8B 14 88 8B CB FF 53 3C 8B 4D 10 8B 55 0C 0F B6 54 11 04 41 89 44 96 3C 3B 4F 14 89 4D 10 72 DA | 57 8B 7F 14 8B 7D FC 76 03 8B 7D FC EB 1A 8B 14 24 8B 52 4C 8B 14 BA 89 D9 FF 53 3C 8B 55 0C 0F B6 54 17 04 89 44 96 3C 83 EF 01 73 E1 5F 90 90
CHS
CHT
CSY
DAN
DEU
ELL
ENU
ESN
FIN
FRA
HEB
HUN
ITA
JPN
KOR
NLD
NOR
PLK
PTB
PTG
RUS
SVE
TRK

The alpha test for this version ended on the 16th of July 2025.

The release of this version to the general public was (also) on the 16th of July 2025.

Version 4

This version fixes a bug, which was found in the version 3 on the 28th of July 2025. The bug from the version 3 is at the offset "E2551|h" in the machine code of the file "win32k.sys".

Since this is the current version, the changes to the machine code are documented in the chapter "Bug fix description".

The alpha test for this version ended on the 1st of August 2025.

The release of this version to the general public was (also) on the 1st of August 2025.


Windows XP (32 bits)


Windows XP (32 bits)

Official updates from Microsoft Corporation

Types of updates

  • bug fix = non-security-relevant bug fix
  • function extension = adds a new function to the operating system, which is no part of a vanilla Windows 2000 installation
  • function reduction = removes or deactivates an existing function
  • useless = fixes a bug, which doesn't occure in Windows 2000 or similar things
  • security = security-relevant bug fix

Overview of the updates

Type: Article Status: Affected components: Contained files:
General: Security:
security KB4039384 - current version font processing
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)

Additional updates

Updates for Windows Embedded for Point of Service in Windows XP

It is possible to install updates, which were meant for Windows Embedded for Point of Service.

Allerdings ist es während der Installation notwendig, einen bestimmten Wert in der Registrierung zu haben. Dieser Wert kann eingefügt werden, indem die nachfolgende Datei in die Registrierung importiert wird:
  • registry value to install updates for Windows Embedded for Point of Service in Windows XP.reg

Updates for Windows Embedded POSReady 2009 in Windows XP

If
  • the processor in the local machine supports the instruction set extension "streaming SIMD extentions 2" ("SSE2"),
then
  • it is possible to install updates, which were meant for Windows Embedded POSReady 2009.

    However, to install these updates it is necessary to have a specific value in the registry during the installation. This value can be added by importing the following file into the registry:
    • registry value to install updates for Windows Embedded POSReady 2009 in Windows XP.reg

Additional documents
  • about the SSE2 issue:
    • offline article from LegacyUpdate.net
    • online article on LegacyUpdate.net


Update "(MS)KB4039384"


Update "(MS)KB4039384"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: - unknown -
Windows XP (32 bits): (MS)KB4039384
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): (MS)KB4039384
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): (MS)KB4039384
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected files

  • %windir%\system32\usp10.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows XP Home (32 bits) and
  • Windows XP Professional (32 bits).

All language-specific editions of the operating system are affected.


Aktualisierung "(MS)KB4039384"

How is the update relevant to security?

Additional documents

  • CVE-2017-8675:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8676:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8678:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8680:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8681:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8682:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8683:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8684:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8685:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8687:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8688:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8695:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8696:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com
  • CVE-2017-8720:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB4039384"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSXP-KB4039384.7z


Update "(MS)KB4039384"

What are the system requirements for the update?

Summary

Operating system: Windows XP (32 bits)

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows XP Home (32 bits) and
  • for Windows XP Professional (32 bits).

The language in which the operating system was installed also does not matter. There are updates for all 24 editions.


Update "(MS)KB4039384"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.3.0013.0
%windir%\system32\ | usp10.dll | 1.0420.2600.7334
%windir%\system32\ | win32k.sys | 5.1.2600.7334
%windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\ | gdiplus.dll | 5.2.6002.24180


Windows Server 2003 (32 bits)


Windows Server 2003 (32 bits)

Official updates from Microsoft Corporation

Types of updates

  • bug fix = non-security-relevant bug fix
  • function extension = adds a new function to the operating system, which is no part of a vanilla Windows 2000 installation
  • function reduction = removes or deactivates an existing function
  • useless = fixes a bug, which doesn't occure in Windows 2000 or similar things
  • security = security-relevant bug fix

Overview of the updates

Type: Article Status: Affected components: Contained files:
General: Security:
security KB4516665 - current version font processing
  • atmfd.dll (5.2.2.253)
  • gdiplus.dll (5.2.6003.20617)
  • spmsg.dll (6.3.0004.1)
  • win32k.sys (5.2.3790.6946)


Update "(MS)KB4516665"


Update "(MS)KB4516665"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: - unknown -
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): (MS)KB4516665
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): - unknown -
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected files

  • %windir%\system32\atmfd.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

Affected function

  • - unknown -

Additional details

Affected operating systems

All variants of the operating system are affected. These include, for example:
  • Windows Server 2003 Standard (32 bits) and
  • Windows Server 2003 Enterprise (32 bits).

All language-specific editions of the operating system are affected.


Aktualisierung "(MS)KB4516665"

How is the update relevant to security?

Additional documents

  • - It does not seem as if there are any security related documents for this update available. -


Update "(MS)KB4516665"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DEU - for the German edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FRA - for the French edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSSERVER2003-KB4516665.7z


Update "(MS)KB4516665"

What are the system requirements for the update?

Summary

Operating system: Windows Server 2003 (32 bits)
Service pack: 2

Additional details

Operating system

It does not matter which variant of the operating system has been installed. The update can be used for all variants. For example:
  • for Windows Server 2003 Standard (32 bits) and
  • for Windows Server 2003 Enterprise (32 bits).

The language in which the operating system was installed barely matters. There are updates for nearly all editions.


Update "(MS)KB4516665"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | atmfd.dll | 5.2.2.253
%windir%\system32\ | spmsg.dll | 6.3.0004.1
%windir%\system32\ | win32k.sys | 5.2.3790.6946
%windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\ | gdiplus.dll | 5.2.6003.20617


Windows Embedded for Point of Service (32 bits)


Windows Embedded for Point of Service (32 bits)

Official updates from Microsoft Corporation

Types of updates

  • bug fix = non-security-relevant bug fix
  • function extension = adds a new function to the operating system, which is no part of a vanilla Windows 2000 installation
  • function reduction = removes or deactivates an existing function
  • useless = fixes a bug, which doesn't occure in Windows 2000 or similar things
  • security = security-relevant bug fix

Overview of the updates

Type: Article Status: Affected components: Contained files:
General: Security:
security KB4039384 - current version font processing
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)


Update "(MS)KB4039384"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: - unknown -
Windows XP (32 bits): (MS)KB4039384
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): (MS)KB4039384
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): (MS)KB4039384
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected files

  • %windir%\system32\usp10.dll
  • %windir%\system32\win32k.sys
  • %windir%\WinSxS\x86_Microsoft.Windows.GdiPlus_*\gdiplus.dll

Affected function

  • - unknown -

Additional details

Affected operating systems

All language-specific editions of the operating system are affected.


Update "(MS)KB4039384"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSEPOS-KB4039384.7z


Update "(MS)KB4039384"

What are the system requirements for the update?

Summary

Operating system: Windows Embedded for Point of Service (32 bits)

Additional details

Operating system

The language in which the operating system was installed does not matter. There are updates for all editions.


Windows Embedded POSReady 2009 (32 bits)


Windows Embedded POSReady 2009 (32 bits)

Official updates from Microsoft Corporation

Types of updates

  • bug fix = non-security-relevant bug fix
  • function extension = adds a new function to the operating system, which is no part of a vanilla Windows 2000 installation
  • function reduction = removes or deactivates an existing function
  • useless = fixes a bug, which doesn't occure in Windows 2000 or similar things
  • security = security-relevant bug fix

Overview of the updates

Type: Article Status: Affected components: Contained files:
General: Security:
security KB4039384 - current version font processing
  • gdiplus.dll (5.2.6002.24180)
  • spmsg.dll (6.3.0013.0)
  • usp10.dll (1.0420.2600.7334)
  • win32k.sys (5.1.2600.7334)
security KB4493927 - current version kernel
  • spmsg.dll (6.3.0013.0)
  • win32k.sys (5.1.2600.7684)


Update "(MS)KB4039384"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSPOSREADY2009-KB4039384.7z


Update "(MS)KB4039384"

What are the system requirements for the update?

Summary

Operating system: Windows Embedded POSReady 2009 (32 bits)

Additional details

Operating system

The language in which the operating system was installed does not matter. There are updates for all editions.


Update "(MS)KB4493927"


Update "(MS)KB4493927"

Which components are affected?

Summary

Affected operating systems

Operating system: Unknown: No: Yes: Update:
Windows 1: - unknown -
Windows 2: - unknown -
Windows 3.0: - unknown -
Windows 3.1: - unknown -
Windows 95: - unknown -
Windows 98: - unknown -
Windows Me: - unknown -
Windows NT 3.1: - unknown -
Windows NT 3.5.0: - unknown -
Windows NT 3.5.1: - unknown -
Windows NT 4.0: - unknown -
Windows 2000: - unknown -
Windows XP (32 bits): - unknown -
Windows Server 2003 (32 bits): - unknown -
Windows Embedded for Point of Service (32 bits): - unknown -
Windows Vista: - unknown -
Windows Server 2008: - unknown -
Windows Embedded POSReady 2009 (32 bits): (MS)KB4493927
Windows 7: - unknown -
Windows Phone 7: - unknown -
Windows Server 2008 R2: - unknown -
Windows 8: - unknown -
Windows Phone 8: - unknown -
Windows 8.1: - unknown -
Windows RT 8.1: - unknown -
Windows Server 2012: - unknown -
Windows Server 2012 R2: - unknown -
Windows 10: - unknown -
Windows 10 Version 1607: - unknown -
Windows 10 Version 1709: - unknown -
Windows 10 Version 1803: - unknown -
Windows Server Version 1803: - unknown -
Windows 10 Version 1809: - unknown -
Windows 10 Version 1903: - unknown -
Windows Server Version 1903: - unknown -
Windows 10 Version 1909: - unknown -
Windows Server Version 1909: - unknown -
Windows Server 2016: - unknown -
Windows Server 2019: - unknown -
Windows Server 2022: - unknown -
Windows 11: - unknown -
Windows Server 2025: - unknown -

Affected file

  • %windir%\system32\win32k.sys

Affected function

  • - unknown -

Additional details

Affected operating systems

All language-specific editions of the operating system are affected.


Aktualisierung "(MS)KB4493927"

How is the update relevant to security?

Additional documents

  • CVE-2019-0848:
    • offline article from CVE.org
    • online article on CVE.org
    • offline article from Microsoft.com
    • online article on Microsoft.com


Update "(MS)KB4493927"

How can one obtain the update?

This update can be downloaded from Microsoft Corporation:
  • ARA - for the Arabic edition of the operating system
  • CHS - for the simplified Chinese edition of the operating system
  • CHT - for the traditional Chinese edition of the operating system
  • CSY - for the Czech edition of the operating system
  • DAN - for the Danish edition of the operating system
  • DEU - for the German edition of the operating system
  • ELL - for the Greek edition of the operating system
  • ENU - for the English edition of the operating system
  • ESN - for the Spanish edition of the operating system
  • FIN - for the Finnish edition of the operating system
  • FRA - for the French edition of the operating system
  • HEB - for the Hebrew edition of the operating system
  • HUN - for the Hungarian edition of the operating system
  • ITA - for the Italian edition of the operating system
  • JPN - for the Japanese edition of the operating system for the IBM PC
  • KOR - for the Korean edition of the operating system
  • NLD - for the Dutch edition of the operating system
  • NOR - for the Norwegian edition of the operating system
  • PLK - for the Polish edition of the operating system
  • PTB - for the Portuguese edition of the operating system with local peculiarities from Brazil
  • PTG - for the Portuguese edition of the operating system with local peculiarities from Portugal
  • RUS - for the Russian edition of the operating system
  • SVE - for the Swedish edition of the operating system
  • TRK - for the Turkish edition of the operating system

If the above links no longer work, the following alternative can be used to download all editions of the update in a compressed archive:
  • http://OnTheServer.de/temp/2025-04-19/WINDOWSPOSREADY2009-KB4493927.7z


Update "(MS)KB4493927"

What are the system requirements for the update?

Summary

Operating system: Windows Embedded POSReady 2009 (32 bits)

Additional details

Operating system

The language in which the operating system was installed does not matter. There are updates for all editions.


Update "(MS)KB4493927"

Which files are contained?

Summary

Path: File name: Version:
%windir%\system32\ | spmsg.dll | 6.3.0013.0
%windir%\system32\ | win32k.sys | 5.1.2600.7684


  • DEU - deutsche Ausgabe von dieser Wissensdatenbank
  • ENU - English edition of this knowledge base (machine translated with only few manual corrections)


CVE Record: CVE-2015-0074
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0074
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 does not properly allocate memory, which allows remote attackers to cause a denial of service via a crafted (1) web site or (2) file, aka "Adobe Font Driver Denial of Service Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securityfocus.com/bid/72892
    * http://www.securitytracker.com/id/1031889


CVE Record: CVE-2015-0087
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0087
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to obtain sensitive information from kernel memory, and possibly bypass the KASLR protection mechanism, via a crafted font, aka "Adobe Font Driver Information Disclosure Vulnerability," a different vulnerability than CVE-2015-0089.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securitytracker.com/id/1031889
    * http://www.securityfocus.com/bid/72893


CVE Record: CVE-2015-0088
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0088
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to execute arbitrary code via a crafted (1) web site or (2) file, aka "Adobe Font Driver Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-0090, CVE-2015-0091, CVE-2015-0092, and CVE-2015-0093.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securityfocus.com/bid/72898
    * http://www.securitytracker.com/id/1031889


CVE Record: CVE-2015-0089
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0089
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to obtain sensitive information from kernel memory, and possibly bypass the KASLR protection mechanism, via a crafted font, aka "Adobe Font Driver Information Disclosure Vulnerability," a different vulnerability than CVE-2015-0087.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securityfocus.com/bid/72896
    * http://www.securitytracker.com/id/1031889


CVE Record: CVE-2015-0090
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0090
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to execute arbitrary code via a crafted (1) web site or (2) file, aka "Adobe Font Driver Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-0088, CVE-2015-0091, CVE-2015-0092, and CVE-2015-0093.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securityfocus.com/bid/72904
    * http://www.securitytracker.com/id/1031889


CVE Record: CVE-2015-0091
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0091
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to execute arbitrary code via a crafted (1) web site or (2) file, aka "Adobe Font Driver Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-0088, CVE-2015-0090, CVE-2015-0092, and CVE-2015-0093.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securitytracker.com/id/1031889
    * http://www.securityfocus.com/bid/72905


CVE Record: CVE-2015-0092
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0092
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to execute arbitrary code via a crafted (1) web site or (2) file, aka "Adobe Font Driver Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-0088, CVE-2015-0090, CVE-2015-0091, and CVE-2015-0093.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securityfocus.com/bid/72906
    * http://www.securitytracker.com/id/1031889


CVE Record: CVE-2015-0093
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-0093
=============

CNA: Microsoft Corporation
==========================

Published: 2015-03-11
Updated: 2018-10-12

Description
-----------

Adobe Font Driver in Microsoft Windows Server 2003 SP2, Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to execute arbitrary code via a crafted (1) web site or (2) file, aka "Adobe Font Driver Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-0088, CVE-2015-0090, CVE-2015-0091, and CVE-2015-0092.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-021
    * http://www.securitytracker.com/id/1031889
    * http://www.securityfocus.com/bid/72907


Microsoft Security Bulletin MS15-021 - Critical

Vulnerabilities in Adobe Font Driver Could Allow Remote Code Execution (3032323)

Published: March 10, 2015

Version: 1.0

Executive Summary

This security update resolves vulnerabilities in Microsoft Windows. The most severe of the vulnerabilities could allow remote code execution if a user views a specially crafted file or website. An attacker who successfully exploited the vulnerability could take complete control of an affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

This security update is rated Critical for all supported releases of Microsoft Windows. For more information, see the Affected Software section.

The security update addresses the vulnerability by correcting how the font parser allocates memory and by correcting how objects in memory are handled. For more information about the vulnerability, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3032323.

Affected Software

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected.

Operating System | Maximum Security Impact | Aggregate Severity Rating | Updates Replaced
Windows Server 2003
Windows Server 2003 Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2003 x64 Edition Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2003 with SP2 for Itanium-based Systems (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Vista
Windows Vista Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Vista x64 Edition Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 for x64-based Systems Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows 7 for x64-based Systems Service Pack 1 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows 8 for x64-based Systems (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows 8.1 for 32-bit Systems (3032323) | Remote Code Execution | Critical | None
Windows 8.1 for x64-based Systems (3032323) | Remote Code Execution | Critical | None
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2012 R2 (3032323) | Remote Code Execution | Critical | None
Windows RT and Windows RT 8.1
Windows RT[1](3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows RT 8.1[1](3032323) | Remote Code Execution | Critical | None
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2012 (Server Core installation) (3032323) | Remote Code Execution | Critical | 2847311 in MS13-081
Windows Server 2012 R2 (Server Core installation) (3032323) | Remote Code Execution | Critical | None

Note The update is available for Windows Technical Preview and Windows Server Technical Preview. Customers running these operating systems are encouraged to apply the update, which is available via Windows Update.

[1]This update is available via Windows Update only.

Severity Ratings and Vulnerability Identifiers

The following severity ratings assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin's release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the March bulletin summary.

Vulnerability Severity Rating and Maximum Security Impact by Affected Software
Affected Software | Adobe Font Driver Denial of Service Vulnerability - CVE-2015-0074 | Adobe Font Driver Information Disclosure Vulnerability - CVE-2015-0087 | Adobe Font Driver Remote Code Execution Vulnerability - CVE-2015-0088 | Adobe Font Driver Information Disclosure Vulnerability - CVE-2015-0089 | Adobe Font Driver Remote Code Execution Vulnerability - CVE-2015-0090 | Adobe Font Driver Remote Code Execution Vulnerability - CVE-2015-0091 | Adobe Font Driver Remote Code Execution Vulnerability - CVE-2015-0092 | Adobe Font Driver Remote Code Execution Vulnerability - CVE-2015-0093 | Aggregate Severity Rating
Windows Server 2003
Windows Server 2003 Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2003 x64 Edition Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2003 with SP2 for Itanium-based Systems (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Vista
Windows Vista Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Vista x64 Edition Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 for x64-based Systems Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 7 for x64-based Systems Service Pack 1 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 8 for x64-based Systems (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 8.1 for 32-bit Systems (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows 8.1 for x64-based Systems (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2012 R2 (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows RT and Windows RT 8.1
Windows RT[1](3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows RT 8.1[1](3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2012 (Server Core installation) (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical
Windows Server 2012 R2 (Server Core installation) (3032323) | Moderate Denial of Service | Important Information Disclosure | Critical Remote Code Execution | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | Critical

Vulnerability Information

Adobe Font Driver Denial of Service Vulnerability - CVE-2015-0074

A denial of service vulnerability exists in how the Adobe Font Driver manages memory when parsing fonts. A user who visited a specially crafted website or opened a specially crafted file could be affected by this vulnerability. The update addresses this vulnerability by correcting how the font parser allocates memory.

Microsoft received information about this vulnerability through coordinated vulnerability disclosure. When this security bulletin was issued, Microsoft had not received any information to indicate that this vulnerability had been publicly used to attack customers when this security bulletin was originally issued.

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Multiple Adobe Font Driver Information Disclosure Vulnerabilities

Information disclosure vulnerabilities exist in the Adobe Font Driver that could allow the disclosure of memory contents to an attacker. These vulnerabilities are caused when the Adobe Font Driver tries to read or display certain fonts. An attacker could use the vulnerabilities to gain information about the system that could then be combined with other attacks to compromise the system. The information disclosure vulnerabilities by themselves do not allow arbitrary code execution. However, an attacker could use these vulnerabilities in conjunction with another vulnerability to bypass security features such as Kernel Address Space Layout Randomization (KASLR). The update addresses the vulnerabilities by correcting how objects in memory are handled.

The following table contains links to the standard entry for each vulnerability in the Common Vulnerabilities and Exposures list:

Vulnerability title | CVE number | Publicly Disclosed | Exploited
Adobe Font Driver Information Disclosure Vulnerability | CVE-2015-0087 | No | No
Adobe Font Driver Information Disclosure Vulnerability | CVE-2015-0089 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Multiple Adobe Font Driver Remote Code Execution Vulnerabilities

Vulnerabilities exist in the Adobe Font Driver that could allow remote code execution if a user views a specially crafted file or website. The vulnerabilities are caused when the Adobe Font Driver improperly overwrites objects in memory. The vulnerabilities could allow an attacker to run code in kernel-mode and then install programs; view, change, or delete data; or create new accounts with full administrative rights. The update addresses these vulnerabilities by correcting how the Adobe Font Driver handles objects in memory.

The following table contains links to the standard entry for each vulnerability in the Common Vulnerabilities and Exposures list:

Vulnerability title | CVE number | Publicly Disclosed | Exploited
Adobe Font Driver Remote Code Execution Vulnerability | CVE-2015-0088 | No | No
Adobe Font Driver Remote Code Execution Vulnerability | CVE-2015-0090 | No | No
Adobe Font Driver Remote Code Execution Vulnerability | CVE-2015-0091 | No | No
Adobe Font Driver Remote Code Execution Vulnerability | CVE-2015-0092 | No | No
Adobe Font Driver Remote Code Execution Vulnerability | CVE-2015-0093 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

The following workarounds may be helpful in your situation:

  • In a web-based attack scenario, an attacker could host a website that contains a web page that is used to exploit this vulnerability. In addition, compromised websites and websites that accept or host user-provided content or advertisements could contain specially crafted content that could exploit this vulnerability. In all cases, however, an attacker would have no way to force users to visit these websites. Instead, an attacker would have to convince users to visit the website, typically by getting them to click a link in an instant messenger or email message that takes users to the attacker's website.
  • By default, all supported versions of Microsoft Outlook, Microsoft Outlook Express, and Windows Mail open HTML email messages in the Restricted sites zone, which disables font download by default. If a user clicks a link in an email message, the user could still be vulnerable to exploitation of this vulnerability through the web-based attack scenario. The vulnerability could also be exploited if a user opens an attachment that is sent in an email message.

Security Update Deployment

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced in the Executive Summary.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

Disclaimer

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (March 10, 2015): Bulletin published.

Page generated 2015-03-05 13:42Z-08:00.


CVE Record: CVE-2015-6100
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6100
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The kernel in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows local users to gain privileges via a crafted application, aka "Windows Kernel Memory Elevation of Privilege Vulnerability," a different vulnerability than CVE-2015-6101.

Product Status
--------------

Information not provided

References
----------

    * https://www.exploit-db.com/exploits/38796/
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * https://blog.fortinet.com/2016/08/17/root-cause-analysis-of-windows-kernel-uaf-vulnerability-lead-to-cve-2016-3310
    * http://www.securitytracker.com/id/1034114


CVE Record: CVE-2015-6101
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6101
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The kernel in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows local users to gain privileges via a crafted application, aka "Windows Kernel Memory Elevation of Privilege Vulnerability," a different vulnerability than CVE-2015-6100.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * https://www.exploit-db.com/exploits/38795/
    * http://www.securitytracker.com/id/1034114


CVE Record: CVE-2015-6102
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6102
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The kernel in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows local users to bypass the KASLR protection mechanism, and consequently discover a driver base address, via a crafted application, aka "Windows Kernel Memory Information Disclosure Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * https://www.exploit-db.com/exploits/38794/
    * http://www.securitytracker.com/id/1034114
    * http://packetstormsecurity.com/files/134519/Microsoft-Windows-Cursor-Object-Potential-Memory-Leak.html


CVE Record: CVE-2015-6103
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6103
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The Adobe Type Manager Library in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Windows Graphics Memory Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-6104.

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * https://code.google.com/p/google-security-research/issues/detail?id=506
    * http://www.securitytracker.com/id/1034114
    * https://www.exploit-db.com/exploits/38714/
    * http://packetstormsecurity.com/files/134397/Microsoft-Windows-Kernel-Win32k.sys-TTF-Font-Processing-Buffer-Overflow.html


CVE Record: CVE-2015-6104
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6104
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The Adobe Type Manager Library in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Windows Graphics Memory Remote Code Execution Vulnerability," a different vulnerability than CVE-2015-6103.

Product Status
--------------

Information not provided

References
----------

    * https://www.exploit-db.com/exploits/38713/
    * http://packetstormsecurity.com/files/134398/Microsoft-Windows-Kernel-Win32k.sys-TTF-Font-Processing-Buffer-Overflow.html
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * https://code.google.com/p/google-security-research/issues/detail?id=507
    * http://www.securitytracker.com/id/1034114


CVE Record: CVE-2015-6109
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6109
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The kernel in Microsoft Windows 8.1, Windows Server 2012 R2, Windows RT 8.1, and Windows 10 Gold and 1511 allows local users to bypass the KASLR protection mechanism, and consequently discover a driver base address, via a crafted application, aka "Windows Kernel Memory Information Disclosure Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * http://www.securitytracker.com/id/1034114


CVE Record: CVE-2015-6113
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6113
=============

CNA: Microsoft Corporation
==========================

Published: 2015-11-11
Updated: 2018-10-12

Description
-----------

The kernel in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, and Windows 10 Gold and 1511 allows local users to bypass intended filesystem permissions by leveraging Low Integrity access, aka "Windows Kernel Security Feature Bypass Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-115
    * http://www.securitytracker.com/id/1034114


Microsoft Security Bulletin MS15-115 - Critical

Security Update for Microsoft Windows to Address Remote Code Execution (3105864)

Published: November 10, 2015 | Updated: April 7, 2016

Version: 2.1

Executive Summary

This security update resolves vulnerabilities in Microsoft Windows. The most severe of the vulnerabilities could allow remote code execution if an attacker convinces a user to open a specially crafted document or to visit an untrusted webpage that contains embedded fonts.

This security update is rated Critical for all supported releases of Windows. For more information, see the Affected Software section.

The security update addresses the vulnerabilities by correcting how:
  • Windows handles objects in memory
  • Adobe Type Manager Library in Windows handles embedded fonts
  • Windows Kernel validates certain permissions

For more information about the vulnerabilities, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3105864.

Affected Software

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected.

Operating System | Maximum Security Impact | Aggregate Severity Rating | Updates Replaced*
Windows Vista
Windows Vista Service Pack 2 (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Vista Service Pack 2 (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Vista x64 Edition Service Pack 2 (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Vista x64 Edition Service Pack 2 (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Server 2008 for 32-bit Systems Service Pack 2 (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 for x64-based Systems Service Pack 2 (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Server 2008 for x64-based Systems Service Pack 2 (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 7 for 32-bit Systems Service Pack 1 [1](3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows 7 for x64-based Systems Service Pack 1 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 7 for x64-based Systems Service Pack 1 [1](3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2008 R2 for x64-based Systems Service Pack 1 [1](3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 [1](3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 8 for 32-bit Systems [2](3101746) | Security Feature Bypass | Important | 3057154 in SA3057154
Windows 8 for x64-based Systems (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 8 for x64-based Systems [2](3101746) | Security Feature Bypass | Important | 3050514 in MS15-052
Windows 8.1 for 32-bit Systems (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 8.1 for 32-bit Systems (3101746) | Security Feature Bypass | Important | 3035131 in MS15-025
Windows 8.1 for x64-based Systems (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows 8.1 for x64-based Systems (3101746) | Security Feature Bypass | Important | 3035131 in MS15-025
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2012 [2](3101746) | Security Feature Bypass | Important | 3050514 in MS15-052
Windows Server 2012 R2 (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2012 R2 [2](3101746) | Security Feature Bypass | Important | 3035131 in MS15-025
Windows RT and Windows RT 8.1
Windows RT[3](3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows RT[3](3101746) | Security Feature Bypass | Important | 3057154 in SA3057154
Windows RT 8.1[3](3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows RT 8.1[3](3101746) | Security Feature Bypass | Important | 3035131 in MS15-025
Windows 10
Windows 10 for 32-bit Systems[4] (3105213) | Remote Code Execution | Critical | 3097617
Windows 10 for x64-based Systems[4] (3105213) | Remote Code Execution | Critical | 3097617
Windows 10 Version 1511 for 32-bit Systems[4] (3105211) | Remote Code Execution | Critical | None
Windows 10 Version 1511 for x64-based Systems[4] (3105211) | Remote Code Execution | Critical | None
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3097877) | Remote Code Execution | Critical | 3087135 in MS15-097
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)[1](3101746) | Security Feature Bypass | Important | 3088195 in MS15-111
Windows Server 2012 (Server Core installation) (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2012 (Server Core installation)[2](3101746) | Security Feature Bypass | Important | 3050514 in MS15-052
Windows Server 2012 R2 (Server Core installation) (3097877) | Remote Code Execution | Critical | 3070102 in MS15-073
Windows Server 2012 R2 (Server Core installation) (3101746) | Security Feature Bypass | Important | 3035131 in MS15-025

[1]Note that update 3081320 in MS15-121 and update 3101246 in MS15-122 are releasing concurrently with update 3101746 in this bulletin, MS15-115. Customers who intend to install all three updates manually on Windows 7 Service Pack 1 or Windows Server 2008 R2 Service Pack 1 should install the updates in the following order: 3101246 first, 3081320 second, and 3101746 third (this is taken care of automatically for customers with automatic updating enabled). Alternatively, customers can install only 3101746, which contains the updates for 3101246 and 3081320. For more information see the Known Issues section of Microsoft Knowledge Base Article 3105256.

[2]Note that update 3081320 in MS15-121 and update 3101246 in MS15-122 are releasing concurrently with update 3101746 in this bulletin, MS15-115. Customers who intend to install all three updates manually on Windows 8 or Windows Server 2012 should install the updates in the following order: 3101246 first, 3101746 second, and 3081320 third (this is taken care of automatically for customers with automatic updating enabled). Alternatively, customers can install only 3081320, which contains the updates for 3101246 and 3101746. For more information see the Known Issues section of Microsoft Knowledge Base Article 3105256.

[3]This update is only available via Windows Update.

[4]Windows 10 updates are cumulative. In addition to containing non-security updates, they also contain all of the security fixes for all of the Windows 10-affected vulnerabilities shipping with the monthly security release. The updates are available via the Microsoft Update Catalog.

Note Windows Server Technical Preview 3 is affected. Customers running this operating system are encouraged to apply the update, which is available via Windows Update.

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Severity Ratings and Vulnerability Identifiers

The following severity ratings assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin's release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the November bulletin summary.

Vulnerability Severity Rating and Maximum Security Impact by Affected Software
Affected Software | Windows Kernel Memory Elevation of Privilege Vulnerability - CVE-2015-6100 | Windows Kernel Memory Elevation of Privilege Vulnerability - CVE-2015-6101 | Windows Kernel Memory Information Disclosure Vulnerability - CVE-2015-6102 | Windows Graphics Memory Remote Code Execution Vulnerability - CVE-2015-6103 | Windows Graphics Memory Remote Code Execution Vulnerability - CVE-2015-6104 | Windows Kernel Memory Information Disclosure Vulnerability - CVE-2015-6109 | Windows Kernel Security Feature Bypass Vulnerability - CVE-2015-6113 | Aggregate Severity Rating
(3097877) | (3097877) | (3097877) | (3097877) | (3097877) | (3097877) | (3101746)
Windows Vista
Windows Vista Service Pack 2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Vista x64 Edition Service Pack 2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 for x64-based Systems Service Pack 2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 for Itanium-based Systems Service Pack 2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows 7 for x64-based Systems Service Pack 1 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows 8 for x64-based Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows 8.1 for 32-bit Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows 8.1 for x64-based Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2012 R2 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows RT and Windows RT 8.1
Windows RT | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows RT 8.1 | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows 10
Windows 10 for 32-bit Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows 10 for x64-based Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows 10 Version 1511 for 32-bit Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Windows 10 Version 1511 for x64-based Systems | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2012 (Server Core installation) | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Not applicable | Important Security Feature Bypass | Critical
Windows Server 2012 R2 (Server Core installation) | Important Elevation of Privilege | Important Elevation of Privilege | Important Information Disclosure | Critical Remote Code Execution | Critical Remote Code Execution | Important Information Disclosure | Important Security Feature Bypass | Critical

Vulnerability Information

Multiple Windows Kernel Memory Elevation of Privilege Vulnerabilities

Multiple elevation of privilege vulnerabilities exist in the way that Windows handles objects in memory. An attacker who successfully exploited the vulnerabilities could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit the vulnerabilities, an attacker would first have to log on to the target system. An attacker could then run a specially crafted application that could exploit the vulnerabilities and take control over an affected system. The update addresses the vulnerabilities by correcting how Windows handles objects in memory.

Vulnerability title | CVE number | Publicly disclosed | Exploited
Windows Kernel Memory Elevation of Privilege Vulnerability | CVE-2015-6100 | No | No
Windows Kernel Memory Elevation of Privilege Vulnerability | CVE-2015-6101 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for the vulnerabilities.

Workarounds

Microsoft has not identified any workarounds for the vulnerabilities.

Multiple Windows Kernel Memory Information Disclosure Vulnerabilities

Multiple information disclosure vulnerabilities exist when Windows fails to properly initialize memory addresses, allowing an attacker to retrieve information that could lead to a Kernel Address Space Layout Randomization (KASLR) bypass. An attacker who successfully exploited the vulnerabilities could retrieve the base address of the Kernel driver from a compromised process.

To exploit the vulnerabilities, an attacker would have to log on to an affected system and run a specially crafted application. The security update addresses the vulnerabilities by correcting how Windows handles memory addresses.

Vulnerability title | CVE number | Publicly disclosed | Exploited
Windows Kernel Memory Information Disclosure Vulnerability | CVE-2015-6102 | No | No
Windows Kernel Memory Information Disclosure Vulnerability | CVE-2015-6109 | Yes | No

Mitigating Factors

Microsoft has not identified any mitigating factors for the vulnerabilities.

Workarounds

Microsoft has not identified any workarounds for the vulnerabilities.

Multiple Windows Graphics Memory Remote Code Execution Vulnerabilities

Multiple remote code execution vulnerabilities exist when the Adobe Type Manager Library in Windows improperly handles specially crafted embedded fonts. An attacker who successfully exploited the vulnerabilities could install programs; view, change, or delete data; or create new accounts with full user rights.

There are several ways an attacker could exploit the vulnerabilities, such as by convincing a user to open a specially crafted document or to visit an untrusted webpage that contains embedded fonts. The update addresses the vulnerabilities by correcting how the Adobe Type Manager Library in Windows handles embedded fonts.

Vulnerability title | CVE number | Publicly disclosed | Exploited
Windows Graphics Memory Remote Code Execution Vulnerability | CVE-2015-6103 | No | No
Windows Graphics Memory Remote Code Execution Vulnerability | CVE-2015-6104 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for the vulnerabilities.

Workarounds

Microsoft has not identified any workarounds for the vulnerabilities.

Windows Kernel Security Feature Bypass Vulnerability - CVE-2015-6113

A security feature bypass vulnerability exists when the Windows kernel fails to properly validate permissions, allowing an attacker to inappropriately interact with the filesystem from low integrity level user-mode applications. An attacker who successfully exploited this vulnerability could potentially modify files outside a low integrity level application.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The security update addresses the vulnerability by correcting certain permissions validation performed by the Windows kernel.

Microsoft received information about this vulnerability through coordinated vulnerability disclosure. At the time this security bulletin was originally issued, Microsoft was unaware of any attack attempting to exploit this vulnerability.

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Security Update Deployment

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced in the Executive Summary.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

Disclaimer

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (November 10, 2015): Bulletin published.
  • V2.0 (November 12, 2015): Bulletin revised to inform customers that the 3097877 update for Windows 7 and Windows Server 2008 R2 has been rereleased to correct a problem with the original update that could cause some applications to quit unexpectedly. Customers who have already successfully installed the update on Windows 7 or Windows Server 2008 R2 systems should reinstall the update.
  • V2.1 (April 7, 2016): Updated the footnotes following the Affected Software table to further clarify installation order for security update 3101746 in MS15-115, 3081320 in MS15-121, and 3101246 in MS15-122. This is an informational change only. Customers who have already successfully installed the update do not need to take any action.

Page generated 2016-04-07 10:15-07:00.


CVE Record: CVE-2015-6106
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6106
=============

CNA: Microsoft Corporation
==========================

Published: 2015-12-09
Updated: 2018-10-12

Description
-----------

The Windows font library in Microsoft Windows Vista SP2, Windows Server 2008 SP2, Office 2007 SP3, Office 2010 SP2, Word Viewer, Skype for Business 2016, Lync 2010, Lync 2013 SP1, and Live Meeting 2007 Console allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Graphics Memory Corruption Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1034333
    * http://www.securitytracker.com/id/1034331
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-128
    * http://www.securitytracker.com/id/1034332
    * http://www.securitytracker.com/id/1034336


CVE Record: CVE-2015-6107
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6107
=============

CNA: Microsoft Corporation
==========================

Published: 2015-12-09
Updated: 2018-10-12

Description
-----------

The Windows font library in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT Gold and 8.1, Windows 10 Gold and 1511, Office 2007 SP3, Office 2010 SP2, Word Viewer, Skype for Business 2016, Lync 2010, Lync 2013 SP1, and Live Meeting 2007 Console allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Graphics Memory Corruption Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1034333
    * http://www.securitytracker.com/id/1034331
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-128
    * http://www.securitytracker.com/id/1034332
    * http://www.securitytracker.com/id/1034336


CVE Record: CVE-2015-6108
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2015-6108
=============

CNA: Microsoft Corporation
==========================

Published: 2015-12-09
Updated: 2018-10-12

Description
-----------

The Windows font library in Microsoft Windows Vista SP2; Windows Server 2008 SP2 and R2 SP1; Windows 7 SP1; Windows 8; Windows 8.1; Windows Server 2012 Gold and R2; Windows RT Gold and 8.1; Office 2007 SP3; Office 2010 SP2; Word Viewer; .NET Framework 3.0 SP2, 3.5, 3.5.1, 4, 4.5, 4.5.1, 4.5.2, and 4.6; Skype for Business 2016; Lync 2010; Lync 2013 SP1; Live Meeting 2007 Console; and Silverlight 5 allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Graphics Memory Corruption Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1034333
    * http://www.securitytracker.com/id/1034331
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2015/ms15-128
    * http://www.securitytracker.com/id/1034329
    * http://www.securitytracker.com/id/1034330
    * http://www.securitytracker.com/id/1034332
    * http://www.securitytracker.com/id/1034336


Microsoft Security Bulletin MS15-128 - Critical

Security Update for Microsoft Graphics Component to Address Remote Code Execution (3104503)

Published: December 8, 2015 | Updated: February 9, 2016

Version: 1.1

Executive Summary

This security update resolves vulnerabilities in Microsoft Windows, .NET Framework, Microsoft Office, Skype for Business, Microsoft Lync, and Silverlight. The vulnerabilities could allow remote code execution if a user opens a specially crafted document or visits a webpage that contains specially crafted embedded fonts.

This security update is rated Critical for:

  • All supported releases of Microsoft Windows
  • Affected versions of Microsoft .NET Framework on all supported releases of Microsoft Windows
  • Affected editions of Skype for Business 2016, Microsoft Lync 2013, and Microsoft Lync 2010
  • Affected editions of Microsoft Office 2007 and Microsoft Office 2010

For more information, see the Affected Software section.

The security update addresses the vulnerabilities by correcting how the Windows font library handles embedded fonts. For more information about the vulnerabilities, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3104503.

Affected Software and Vulnerability Severity Ratings

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected.

The severity ratings indicated for each affected software assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin’s release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the December bulletin summary.

Microsoft Windows

Operating System | Graphics Memory Corruption Vulnerability - CVE-2015-6106 | Graphics Memory Corruption Vulnerability - CVE-2015-6107 | Graphics Memory Corruption Vulnerability - CVE-2015-6108 | Updates Replaced*
Windows Vista
Windows Vista Service Pack 2 \ (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Vista x64 Edition Service Pack 2 \ (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 for x64-based Systems Service Pack 2 (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 7 for x64-based Systems Service Pack 1 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 8 for x64-based Systems \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 8.1 for 32-bit Systems \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 8.1 for x64-based Systems \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2012 R2 \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows RT and Windows RT 8.1
Windows RT [1](3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows RT 8.1 [1](3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows 10
Windows 10 for 32-bit Systems [2]\ (3116869) | Not applicable | Critical Remote Code Execution | Not applicable | 3105213
Windows 10 for x64-based Systems [2]\ (3116869) | Not applicable | Critical Remote Code Execution | Not applicable | 3105213
Windows 10 Version 1511 for 32-bit Systems [2]\ (3116900) | Not applicable | Critical Remote Code Execution | Not applicable | 3105211
Windows 10 Version 1511 for x64-based Systems [2]\ (3116900) | Not applicable | Critical Remote Code Execution | Not applicable | 3105211
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) \ (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) \ (3109094) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2012 (Server Core installation) \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115
Windows Server 2012 R2 (Server Core installation) \ (3109094) | Not applicable | Critical Remote Code Execution | Critical Remote Code Execution | 3097877 in MS15-115

[1]This update is only available via Windows Update.

[2]Windows 10 updates are cumulative. In addition to containing non-security updates, they also contain all of the security fixes for all of the Windows 10-affected vulnerabilities shipping with the monthly security release. The updates are available via the Microsoft Update Catalog.

Note Windows Server Technical Preview 3 and Windows Server Technical Preview 4 are affected. Customers running these operating systems are encouraged to apply the update, which is available via Windows Update.

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Microsoft Office

Operating System | Graphics Memory Corruption Vulnerability - CVE-2015-6106 | Graphics Memory Corruption Vulnerability - CVE-2015-6107 | Graphics Memory Corruption Vulnerability - CVE-2015-6108 | Updates Replaced*
Microsoft Office 2007
Microsoft Office 2007 Service Pack 3 (3085616) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085546 in MS15-097
Microsoft Office 2010
Microsoft Office 2010 Service Pack 2 (32-bit editions) (3085612) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085529 in MS15-097
Microsoft Office 2010 Service Pack 2 (64-bit editions) (3085612) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085529 in MS15-097
Other Office Software
Microsoft Word Viewer (3114478) | Important Remote Code Execution | Important Remote Code Execution | Important Remote Code Execution | None

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Microsoft .NET Framework

Operating System | Component | Graphics Memory Corruption Vulnerability - CVE-2015-6108 | Updates Replaced
Windows Vista
Windows Vista Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3099860) | Critical Remote Code Execution | 3072303 in MS15-080, 3048068 in MS15-044
Windows Vista Service Pack 2 | Microsoft .NET Framework 4 [1] [2](3099866) | Critical Remote Code Execution | 3072309 in MS15-080, 3048074 in MS15-044
Windows Vista Service Pack 2 | Microsoft .NET Framework 4.5/4.5.1/4.5.2 [2](3099869) | Critical Remote Code Execution | 3072310 in MS15-080, 3048077 in MS15-044
Windows Vista Service Pack 2 | Microsoft .NET Framework 4.6 [2](3099874) | Critical Remote Code Execution | None
Windows Vista x64 Edition Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3099860) | Critical Remote Code Execution | 3072303 in MS15-080, 3048068 in MS15-044
Windows Vista x64 Edition Service Pack 2 | Microsoft .NET Framework 4 [1] [2](3099866) | Critical Remote Code Execution | 3072309 in MS15-080, 3048074 in MS15-044
Windows Vista x64 Edition Service Pack 2 | Microsoft .NET Framework 4.5/4.5.1/4.5.2 [2](3099869) | Critical Remote Code Execution | 3072310 in MS15-080, 3048077 in MS15-044
Windows Vista x64 Edition Service Pack 2 | Microsoft .NET Framework 4.6 [2](3099874) | Critical Remote Code Execution | None
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3099860) | Critical Remote Code Execution | 3072303 in MS15-080, 3048068 in MS15-044
Windows Server 2008 for 32-bit Systems Service Pack 2 | Microsoft .NET Framework 4 [1] [2](3099866) | Critical Remote Code Execution | 3072309 in MS15-080, 3048074 in MS15-044
Windows Server 2008 for 32-bit Systems Service Pack 2 | Microsoft .NET Framework 4.5/4.5.1/4.5.2 [2](3099869) | Critical Remote Code Execution | 3072310 in MS15-080, 3048077 in MS15-044
Windows Server 2008 for 32-bit Systems Service Pack 2 | Microsoft .NET Framework 4.6 [2](3099874) | Critical Remote Code Execution | None
Windows Server 2008 for x64-based Systems Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3099860) | Critical Remote Code Execution | 3072303 in MS15-080, 3048068 in MS15-044
Windows Server 2008 for x64-based Systems Service Pack 2 | Microsoft .NET Framework 4 [1] [2](3099866) | Critical Remote Code Execution | 3072309 in MS15-080, 3048074 in MS15-044
Windows Server 2008 for x64-based Systems Service Pack 2 | Microsoft .NET Framework 4.5/4.5.1/4.5.2 [2](3099869) | Critical Remote Code Execution | 3072310 in MS15-080, 3048077 in MS15-044
Windows Server 2008 for x64-based Systems Service Pack 2 | Microsoft .NET Framework 4.6 [2](3099874) | Critical Remote Code Execution | None
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3099862) | Critical Remote Code Execution | 3048070 in MS15-044
Windows 7 for x64-based Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3099862) | Critical Remote Code Execution | 3048070 in MS15-044
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3099862) | Critical Remote Code Execution | 3048070 in MS15-044
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems | Microsoft .NET Framework 3.5 (3099863) | Critical Remote Code Execution | None
Windows 8 for x64-based Systems | Microsoft .NET Framework 3.5 (3099863) | Critical Remote Code Execution | None
Windows 8.1 for 32-bit Systems | Microsoft .NET Framework 3.5 (3099864) | Critical Remote Code Execution | None
Windows 8.1 for x64-based Systems | Microsoft .NET Framework 3.5 (3099864) | Critical Remote Code Execution | None
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 | Microsoft .NET Framework 3.5 (3099863) | Critical Remote Code Execution | None
Windows Server 2012 R2 | Microsoft .NET Framework 3.5 (3099864) | Critical Remote Code Execution | None
Windows 10
Windows 10 for 32-bit Systems [3](3116869) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3105213
Windows 10 for 64-bit Systems [3](3116869) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3105213
Server Core installation option
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) | Microsoft .NET Framework 3.5.1 (3099862) | Critical Remote Code Execution | 3048070 in MS15-044
Windows Server 2012 (Server Core installation) | Microsoft .NET Framework 3.5 (3099863) | Critical Remote Code Execution | None
Windows Server 2012 R2 (Server Core installation) | Microsoft .NET Framework 3.5 (3099864) | Critical Remote Code Execution | None

[1].NET Framework 4 and .NET Framework 4 Client Profile affected.

[2]For information about changes in support for .NET Framework 4.x, see Internet Explorer and .NET Framework 4.x Support Announcements.

[3]Windows 10 updates are cumulative. In addition to containing non-security updates, they also contain all of the security fixes for all of the Windows 10-affected vulnerabilities shipping with the monthly security release. The updates are available via the Microsoft Update Catalog.

Microsoft Communications Platforms and Software

Operating System | Graphics Memory Corruption Vulnerability - CVE-2015-6106 | Graphics Memory Corruption Vulnerability - CVE-2015-6107 | Graphics Memory Corruption Vulnerability - CVE-2015-6108 | Updates Replaced*
Skype for Business 2016
Skype for Business 2016 (32-bit editions) \ (3114372) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085634 in MS15-123
Skype for Business Basic 2016 (32-bit editions) \ (3114372) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085634 in MS15-123
Skype for Business 2016 (64-bit editions) \ (3114372) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085634 in MS15-123
Skype for Business Basic 2016 (64-bit editions) \ (3114372) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3085634 in MS15-123
Microsoft Lync 2013
Microsoft Lync 2013 Service Pack 1 (32-bit) [1]\ (Skype for Business) \ (3114351) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3101496 in MS15-123
Microsoft Lync Basic 2013 Service Pack 1 (32-bit) [1]\ (Skype for Business Basic) \ (3114351) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3101496 in MS15-123
Microsoft Lync 2013 Service Pack 1 (64-bit) [1]\ (Skype for Business) \ (3114351) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3101496 in MS15-123
Microsoft Lync Basic 2013 Service Pack 1 (64-bit) [1]\ (Skype for Business Basic)\ (3114351) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3101496 in MS15-123
Microsoft Lync 2010
Microsoft Lync 2010 (32-bit) \ (3115871) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3096735 in MS15-123
Microsoft Lync 2010 (64-bit)\ (3115871) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3096735 in MS15-123
Microsoft Lync 2010 Attendee [2]\ (user level install) \ (3115872) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3096736 in MS15-123
Microsoft Lync 2010 Attendee \ (admin level install) \ (3115873) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | 3096738 in MS15-123
Microsoft Live Meeting 2007 Console
Microsoft Live Meeting 2007 Console [3]\ (3115875) | Critical Remote Code Execution | Critical Remote Code Execution | Critical Remote Code Execution | None

[1]Before installing this update, you must have update 2965218 and security update 3039779 installed. See the Update FAQ for more information.

[2]This update is available from the Microsoft Download Center only.

[3]An update for the Conferencing Add-in for Microsoft Office Outlook is also available. For more information and download links, see Download the Conferencing Add-in for Microsoft Office Outlook.

*The Updates Replaced column shows only the latest update in a chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is on the Package Details tab).

Microsoft Developer Tools and Software

Software | Graphics Memory Corruption Vulnerability - CVE-2015-6108 | Updates Replaced*
Microsoft Silverlight 5 when installed on Mac\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080
Microsoft Silverlight 5 Developer Runtime when installed on Mac\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080
Microsoft Silverlight 5 when installed on all supported releases of Microsoft Windows clients\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080
Microsoft Silverlight 5 Developer Runtime when installed on all supported releases of Microsoft Windows clients\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080
Microsoft Silverlight 5 when installed on all supported releases of Microsoft Windows servers\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080
Microsoft Silverlight 5 Developer Runtime when installed on all supported releases of Microsoft Windows servers\ (3106614) | Critical \ Remote Code Execution | 3080333 in MS15-080

*The Updates Replaced column shows only the latest update in a chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is on the Package Details tab).

Update FAQ

Why are some of the updates listed in this bulletin also denoted in other bulletins releasing this month?
Since bulletins are broken out by the security vulnerabilities they address, not by the update packages being released, it is possible for separate bulletins to reference the same update if the fixes for their respective vulnerabilities have been consolidated into a single update package. In such situations it is also possible for the vulnerabilities described in the one bulletin to have completely different severity and impact ratings than the vulnerabilities described in the other bulletin. This is frequently the case with cumulative updates for products such as Internet Explorer or Silverlight where singular updates contain fixes for very different security vulnerabilities being discussed in separate bulletins.

Note that identical update files shipping with multiple bulletins do not need to be installed more than once.

There are multiple update packages available for some of the affected software. Do I need to install all the updates listed in the Affected Software table for the software?
Yes. Customers should apply all updates offered for the software installed on their systems. If multiple updates apply, they can be installed in any order.

Do I need to install these security updates in a particular sequence?
No. Multiple updates for a given system can be applied in any sequence.

I am running Office 2010, which is listed as affected software. Why am I not being offered the update?
The update is not applicable to Office 2010 on Windows Vista and later versions of Windows because the vulnerable code is not present.

I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335. For a list of Microsoft Office products an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

Are there any prerequisites for any of the updates offered in this bulletin for affected editions of Microsoft Lync 2013 (Skype for Business)?
Yes. Customers running affected editions of Microsoft Lync 2013 (Skype for Business) must first install the 2965218 update for Office 2013 released in April, 2015, and then the 3039779 security update released in May, 2015. For more information about these two prerequisite updates, see:

  • Knowledge Base Article 3039779

Are there any related non-security updates that customers should install along with the Microsoft Live Meeting Console security update?
Yes, in addition to releasing a security update for Microsoft Live Meeting Console, Microsoft has released the following non-security updates for the OCS Conferencing Addin for Outlook. Where applicable, Microsoft recommends that customers install these updates to keep their systems up-to-date:

  • OCS Conferencing Addin for Outlook (32-bit) (3115870)
  • OCS Conferencing Addin for Outlook (64-bit) (3115870)

See Microsoft Knowledge Base Article 3115870 for more information.

Why is the Lync 2010 Attendee (user level install) update only available from the Microsoft Download Center?
Microsoft is releasing the update for Lync 2010 Attendee (user level install) to the Microsoft Download Center only. Because the user level installation of Lync 2010 Attendee is handled through a Lync session, distribution methods such as automatic updating are not appropriate for this type of installation scenario.

Vulnerability Information

Multiple Graphics Memory Corruption Vulnerabilities

Multiple remote code execution vulnerabilities exist when the Windows font library improperly handles specially crafted embedded fonts. An attacker who successfully exploited these vulnerabilities could install programs; view, change, or delete data; or create new accounts with full user rights.

There are multiple ways an attacker could exploit the vulnerabilities, such as by convincing a user to open a specially crafted document, or by convincing a user to visit an untrusted webpage that contains embedded fonts. The security update addresses the vulnerabilities by correcting how the Windows font library handles embedded fonts.

The following tables contain links to the standard entry for each vulnerability in the Common Vulnerabilities and Exposures list:

Vulnerability title | CVE number | Publicly disclosed | Exploited
Graphics Memory Corruption Vulnerability | CVE-2015-6106 | No | No
Graphics Memory Corruption Vulnerability | CVE-2015-6107 | No | No
Graphics Memory Corruption Vulnerability | CVE-2015-6108 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for these vulnerabilities.

Workarounds

Microsoft has not identified any workarounds for these vulnerabilities.

Security Update Deployment

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced in the Executive Summary.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

Disclaimer

The information provided in the Microsoft Knowledge Base is provided “as is” without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (December 8, 2015): Bulletin published.
  • V1.1 (February 9, 2016): Revised bulletin to correct the updates replaced for .NET Framework 3.5.1 installed on supported editions of Windows 7 and Windows Server 2008 R2. This is an informational change only. There were no changes to the update files. Customers who have already successfully updated their systems do not need to take any action.

Page generated 2016-02-04 11:14-08:00.


CVE Record: CVE-2016-0008
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0008
=============

CNA: Microsoft Corporation
==========================

Published: 2016-01-13
Updated: 2018-10-12

Description
-----------

The graphics device interface in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT Gold and 8.1 allows remote attackers to bypass the ASLR protection mechanism via unspecified vectors, aka "Windows GDI32.dll ASLR Bypass Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-005
    * https://www.verisign.com/en_US/security-services/security-intelligence/vulnerability-reports/articles/index.xhtml?id=1216
    * http://www.securitytracker.com/id/1034654


CVE Record: CVE-2016-0009
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0009
=============

CNA: Microsoft Corporation
==========================

Published: 2016-01-13
Updated: 2018-10-12

Description
-----------

Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, and Windows 10 Gold and 1511 allow remote attackers to execute arbitrary code via unspecified vectors, aka "Win32k Remote Code Execution Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-005
    * http://www.securitytracker.com/id/1034654


Microsoft Security Bulletin MS16-005 - Critical

Security Update for Windows Kernel-Mode Drivers to Address Remote Code Execution (3124584)

Published: January 12, 2016 | Updated: January 13, 2016

Version: 1.1

Executive Summary

This security update resolves vulnerabilities in Microsoft Windows. The more severe of the vulnerabilities could allow remote code execution if a user visits a malicious website.

This security update is rated Critical for all supported editions of Windows Vista, Windows Server 2008, Windows 7, and Windows Server 2008 R2; it is rated Important for all supported editions of Windows 8, Windows Server 2012, Windows RT, Windows 8.1, Windows Server 2012 R2, Windows RT 8.1, Windows 10, and Windows 10 Version 1511. For more information, see the Affected Software section.

The security update addresses the vulnerabilities by correcting how Windows handles objects in memory. For more information about the vulnerabilities, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3124584.

Affected Software and Vulnerability Severity Ratings

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected.

The severity ratings indicated for each affected software assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin’s release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the January bulletin summary.

Operating System | Win32k Remote Code Execution Vulnerability - CVE-2016-0009 | Windows GDI32.dll ASLR Bypass Vulnerability - CVE-2016-0008 | Updates Replaced*
Windows Vista
Windows Vista Service Pack 2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Vista Service Pack 2 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Vista x64 Edition Service Pack 2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Vista x64 Edition Service Pack 2 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 for 32-bit Systems Service Pack 2 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 for x64-based Systems Service Pack 2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 for x64-based Systems Service Pack 2 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 7 for 32-bit Systems Service Pack 1 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows 7 for x64-based Systems Service Pack 1 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 7 for x64-based Systems Service Pack 1 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows 8 and Windows 8.1
Windows 8 for 32-bit Systems (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 8 for x64-based Systems (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 8.1 for 32-bit Systems (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 8.1 for x64-based Systems (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2012 R2 (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows RT and Windows RT 8.1
Windows RT[1](3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows RT 8.1[1](3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows 10
Windows 10 for 32-bit Systems [2][3](3124266) | Not applicable | Important Information Disclosure | 3116869
Windows 10 for x64-based Systems [2][3](3124266) | Not applicable | Important Information Disclosure | 3116869
Windows 10 Version 1511 for 32-bit Systems [2][3](3124263) | Not applicable | Important Information Disclosure | 3116900
Windows 10 Version 1511 for x64-based Systems [2][3](3124263) | Not applicable | Important Information Disclosure | 3116900
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3124000) | Critical Remote Code Execution | Not applicable | 3070102 in MS15-073
Windows Server 2012 (Server Core installation) (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072
Windows Server 2012 R2 (Server Core installation) (3124001) | Not applicable | Important Information Disclosure | 3069392 in MS15-072

[1]This update is only available via Windows Update.

[2]Windows 10 updates are cumulative. In addition to containing non-security updates, they also contain all of the security fixes for all of the Windows 10-affected vulnerabilities shipping with the monthly security release. The update is available via the Windows Update Catalog.

[3]Customers running Windows 10 or Windows 10 Version 1511 who have Citrix XenDesktop installed will not be offered the update. Because of a Citrix issue with the XenDesktop software, users who install the update will be prevented from logging on. To stay protected, Microsoft recommends uninstalling the incompatible software and installing this update. Customers should contact Citrix for more information and help with this XenDesktop software issue.

The third-party products that this bulletin discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Note Windows Server Technical Preview 3 and Windows Server Technical Preview 4 are affected. Customers running these operating systems are encouraged to apply the update, which is available via Windows Update.

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Vulnerability Information

Windows GDI32.dll ASLR Bypass Vulnerability - CVE-2016-0008

A security feature bypass vulnerability exists in the way that the Windows graphics device interface handles objects in memory, allowing an attacker to retrieve information that could lead to an Address Space Layout Randomization (ASLR) bypass.

To exploit this vulnerability, in a web-based attack scenario, an attacker could host a specially crafted website that is designed to exploit the vulnerability through Internet Explorer and then convince users to view the website. This could also include compromised websites or websites that accept or host user-provided content or banner advertisements; such websites could contain specially crafted content that is designed to exploit the vulnerability. In all cases, however, an attacker would have no way to force users to visit such websites. Instead, an attacker would have to convince users to do so, typically by getting them to click a link in an email or Instant Messenger request.

In an email attack scenario, an attacker could exploit the vulnerability by sending Outlook users a specially crafted email, or sending them a specially crafted Office document as an attachment, and convincing the user to read the message or open the file.

An attacker could also exploit this vulnerability by hosting a malicious file on a network share and convincing users to navigate to the folder in Windows Explorer. The security update addresses the vulnerability by correcting how the Windows graphics device interface handles memory addresses, thereby helping to protect the integrity of the ASLR security feature.

Microsoft received information about this vulnerability through coordinated vulnerability disclosure. At the time this security bulletin was originally issued, Microsoft was unaware of any attack attempting to exploit this vulnerability.

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Win32k Remote Code Execution Vulnerability - CVE-2016-0009

A remote code execution vulnerability exists in the way that Windows handles objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code on a target system.

To exploit this vulnerability, an attacker would first have to convince a user to visit a malicious website that could exploit the vulnerability and run arbitrary code with the logged on user’s privileges. The security update addresses this vulnerability by correcting how Windows handles objects in memory.

This vulnerability has been publicly disclosed. It has been assigned Common Vulnerability and Exposure number CVE-2016-0009. At the time this security bulletin was originally issued, Microsoft was unaware of any attack attempting to exploit this vulnerability.

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Security Update Deployment

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced here in the Executive Summary.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

Disclaimer

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (January 12, 2015): Bulletin published.
  • V1.1 (January 13, 2015): Corrected severity and impact entries for Windows 10 in the Affected Software and Vulnerability Severity Ratings table. This is an informational change only. Customers who have successfully installed the update do not need to take any further action.

Page generated 2016-01-13 16:34-08:00.


CVE Record: CVE-2016-0143
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0143
=============

CNA: Microsoft Corporation
==========================

Published: 2016-04-12
Updated: 2018-10-12

Description
-----------

The kernel-mode driver in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, and Windows 10 Gold and 1511 allows local users to gain privileges via a crafted application, aka "Win32k Elevation of Privilege Vulnerability," a different vulnerability than CVE-2016-0165 and CVE-2016-0167.

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1035529
    * http://www.securitytracker.com/id/1035532
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-039
    * http://www.securityfocus.com/bid/85896
    * https://www.exploit-db.com/exploits/39712/


CVE-2016-0143 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Apr 12, 2016
Last updated: Apr 10, 2018
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2016-0143

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Windows kernel-mode driver fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how the Windows kernel-mode driver handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Nils Sommer
      of bytegeist
      working with Google Project Zero

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Apr 12, 2016
Windows 10 Version 1709 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/help/4093112

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4093112

---

Apr 12, 2016
Windows 10 Version 1709 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/help/4093112

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4093112

---

Apr 12, 2016
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update:

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c75e35-49e6-4839-bd53-649bf12384bb

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ba86f043-2390-4ceb-bed0-6c16b1433bc4

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Vista x64 Edition Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Vista Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=669cd30d-d220-49b0-ad48-f251debabce4

---

Apr 12, 2016
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=126dba8b-91ed-4981-a48b-ce7f80d5bb94

---

Apr 12, 2016
Windows 10 Version 1511 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 Version 1511 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 2.0
revision date: Apr 10, 2018
description: Revised the Affected Products table to include Windows 10 Version 1709 for 32-bit Systems and Windows 10 Version 1709 for x64-based Systems because they are affected by CVE-2016-0143. Microsoft strongly recommends that customers install the updates to be fully protected from the vulnerability. Customers whose systems are configured to receive automatic updates do not need to take any further action.

---

version: 1.0
revision date: Apr 12, 2016
description: Information published.


CVE Record: CVE-2016-0145
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0145
=============

CNA: Microsoft Corporation
==========================

Published: 2016-04-12
Updated: 2018-10-12

Description
-----------

The font library in Microsoft Windows Vista SP2; Windows Server 2008 SP2 and R2 SP1; Windows 7 SP1; Windows 8.1; Windows Server 2012 Gold and R2; Windows RT 8.1; Windows 10 Gold and 1511; Office 2007 SP3 and 2010 SP2; Word Viewer; .NET Framework 3.0 SP2, 3.5, and 3.5.1; Skype for Business 2016; Lync 2010; Lync 2010 Attendee; Lync 2013 SP1; and Live Meeting 2007 Console allows remote attackers to execute arbitrary code via a crafted embedded font, aka "Graphics Memory Corruption Vulnerability."

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1035529
    * http://www.securitytracker.com/id/1035530
    * http://www.securitytracker.com/id/1035532
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-039
    * http://www.securitytracker.com/id/1035528
    * https://www.exploit-db.com/exploits/39743/
    * http://www.securitytracker.com/id/1035531


CVE-2016-0145 - Security Update Guide - Microsoft - GDI+ Remote Code Execution Vulnerability
============================================================================================

Security Vulnerability
Released: Apr 12, 2016
Last updated: Jun 14, 2016
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2016-0145

Executive Summary
-----------------

A remote code execution vulnerability exists when the Windows font library improperly handles specially crafted embedded fonts. An attacker who successfully exploited the vulnerability could take control of the affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

There are multiple ways an attacker could exploit the vulnerability:
    * In a web-based attack scenario, an attacker could host a specially crafted website that is designed to exploit the vulnerability and then convince users to view the website. An attacker would have no way to force users to view the attacker-controlled content. Instead, an attacker would have to convince users to take action, typically by getting them to click a link in an email or instant message that takes users to the attacker's website, or by opening an attachment sent through email.
    * In a file-sharing attack scenario, an attacker could provide a specially crafted document file that is designed to exploit the vulnerability and then convince users to open the document file. The security update addresses the vulnerability by correcting how the Windows font library handles embedded fonts.

Note that where the severity is indicated as Critical in the Affected Products table, the Preview Pane is an attack vector for this vulnerability. The security update addresses the vulnerability by correcting how the Windows font library handles embedded fonts.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

FAQ
---

    I am running Office 2010, which is listed as affected software. Why am I not being offered the update?
    ------------------------------------------------------------------------------------------------------
    The update is not applicable to Office 2010 on Windows Vista and later versions of Windows because the vulnerable code is not present.

    ---

    I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

    For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

    For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335 (https://support.microsoft.com/kb/830335). For a list of Microsoft Office products an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

    ---

    Are there any prerequisites for any of the updates offered in this bulletin for affected editions of Microsoft Lync 2013 (Skype for Business)?
    ----------------------------------------------------------------------------------------------------------------------------------------------
    Yes. Customers running affected editions of Microsoft Lync 2013 (Skype for Business) must first install the 2965218 update for Office 2013 released in April, 2015, and then the 3039779 security update released in May, 2015. For more information about these two prerequisite updates, see: https://support.microsoft.com/en-us/kb/2965218 and Knowledge Base Article 3039779 (https://support.microsoft.com/en-us/kb/3039779)

    ---

    Are there any related non-security updates that customers should install along with the Microsoft Live Meeting Console security update?
    ---------------------------------------------------------------------------------------------------------------------------------------
    Yes, in addition to releasing a security update for Microsoft Live Meeting Console, Microsoft has released the following non-security updates for the OCS Conferencing Addin for Outlook. Where applicable, Microsoft recommends that customers install these updates to keep their systems up-to-date:

    OCS Conferencing Addin for Outlook (32-bit) (3144431) OCS Conferencing Addin for Outlook (64-bit) (3144431)

    See Microsoft Knowledge Base Article 3144431 (https://support.microsoft.com/kb/3144431) for more information.

    ---

    Why is the Lync 2010 Attendee (user level install) update only available from the Microsoft Download Center?
    ------------------------------------------------------------------------------------------------------------
    Microsoft is releasing the update for Lync 2010 Attendee (user level install) to the Microsoft Download Center (http://go.microsoft.com/fwlink/?LinkId=21129) only. Because the user level installation of Lync 2010 Attendee is handled through a Lync session, distribution methods such as automatic updating are not appropriate for this type of installation scenario.

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows Server 2012
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142043

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142043

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows Server 2012 (Server Core installation)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142043

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142043

---

Apr 12, 2016
Microsoft .NET Framework 3.0 Service Pack 2
Windows Server 2008 for 32-bit Systems Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142041

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142041

---

Apr 12, 2016
Microsoft .NET Framework 3.0 Service Pack 2
Windows Vista x64 Edition Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142041

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142041

---

Apr 12, 2016
Microsoft .NET Framework 3.0 Service Pack 2
Windows Server 2008 for x64-based Systems Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142041

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142041

---

Apr 12, 2016
Microsoft .NET Framework 3.0 Service Pack 2
Windows Vista Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142041

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142041

---

Apr 12, 2016
Microsoft .NET Framework 3.5.1
Windows 7 for x64-based Systems Service Pack 1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142042

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142042

---

Apr 12, 2016
Microsoft .NET Framework 3.5.1
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142042

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142042

---

Apr 12, 2016
Microsoft .NET Framework 3.5.1
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142042

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142042

---

Apr 12, 2016
Microsoft .NET Framework 3.5.1
Windows 7 for 32-bit Systems Service Pack 1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142042

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142042

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 10 Version 1511 for x64-based Systems
Remote Code Execution
Critical

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 10 Version 1511 for 32-bit Systems
Remote Code Execution
Critical

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 10 for x64-based Systems
Remote Code Execution
Critical

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 10 for 32-bit Systems
Remote Code Execution
Critical

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows Server 2012 R2 (Server Core installation)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142045

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142045

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows Server 2012 R2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142045

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142045

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 8.1 for x64-based systems
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142045

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142045

---

Apr 12, 2016
Microsoft .NET Framework 3.5
Windows 8.1 for 32-bit systems
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3142045

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3142045

---

Apr 12, 2016
Microsoft Word 2010 Service Pack 2 (64-bit editions)
Remote Code Execution
Important

    * https://support.microsoft.com/en-us/kb/3114566

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=8df220ed-e745-4517-9814-f819c08112fb

---

Apr 12, 2016
Microsoft Word 2010 Service Pack 2 (32-bit editions)
Remote Code Execution
Important

    * https://support.microsoft.com/en-us/kb/3114566

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=8df220ed-e745-4517-9814-f819c08112fb

---

Apr 12, 2016
Microsoft Word 2007 Service Pack 3
Remote Code Execution
Important

    * https://support.microsoft.com/en-us/kb/3114542

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=72c16021-7682-4966-8761-250cb114c220

---

Apr 12, 2016
Microsoft Office Word Viewer
Remote Code Execution
Important

    * http://support.microsoft.com/kb/3114985

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=6230a277-b747-40c0-85db-28759b841cc0

---

Apr 12, 2016
Skype for Business 2016 Basic (64-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114960

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=cf6c0028-a0cb-458b-9ceb-f63a9a4a1e6e

---

Apr 12, 2016
Skype for Business 2016 Basic (32-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114960

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=d9f0dd7b-fbe4-42fc-907c-a325d336775e

---

Apr 12, 2016
Skype for Business 2016 (64-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114960

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=cf6c0028-a0cb-458b-9ceb-f63a9a4a1e6e

---

Apr 12, 2016
Skype for Business 2016 (32-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114960

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=d9f0dd7b-fbe4-42fc-907c-a325d336775e

---

Apr 12, 2016
Microsoft Lync 2010 (64-bit)
Remote Code Execution
Critical

    * http://support.microsoft.com/kb/3144427

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=4948767a-288d-4435-8483-49994188abd8

---

Apr 12, 2016
Microsoft Lync 2010 Attendee (user level install)
Remote Code Execution
Critical

    * http://support.microsoft.com/kb/3144428

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=b04810c4-846d-49c5-a3ba-b84e22004cd3

---

Apr 12, 2016
Microsoft Lync 2010 (32-bit)
Remote Code Execution
Critical

    * http://support.microsoft.com/kb/3144427

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=4f723b2b-1c50-4bc6-a528-fb909abaa9d4

---

Apr 12, 2016
Microsoft Lync 2010 Attendee (admin level install)
Remote Code Execution
Critical

    * http://support.microsoft.com/kb/3144429

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e060bf8f-2b35-4f92-81f3-493bee50bd20

---

Apr 12, 2016
Microsoft Lync Basic 2013 Service Pack 1 (64-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114944

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=64b9da10-f429-4b4a-9da2-4d38c78b5ec5

---

Apr 12, 2016
Microsoft Lync 2013 Service Pack 1 (64-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114944

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=64b9da10-f429-4b4a-9da2-4d38c78b5ec5

---

Apr 12, 2016
Microsoft Lync Basic 2013 Service Pack 1 (32-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114944

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2c6cf87e-7e8f-4456-92d0-79aa8c56198b

---

Apr 12, 2016
Microsoft Lync 2013 Service Pack 1 (32-bit)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3114944

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2c6cf87e-7e8f-4456-92d0-79aa8c56198b

---

Apr 12, 2016
Windows RT 8.1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update:

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c75e35-49e6-4839-bd53-649bf12384bb

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Remote Code Execution
Critical

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ba86f043-2390-4ceb-bed0-6c16b1433bc4

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 3.0
revision date: Jun 14, 2016
description: Microsoft has re-released security update 3144427 for affected editions of Microsoft Lync 2010 and Microsoft Lync 2010 Attendee. The re-release addresses issues customers might have experienced downloading security update 3144427. Customers running Microsoft Lync 2010 should install the update to be fully protected from the vulnerability. See Microsoft Knowledge Base Article 3144427 for more information.

---

version: 2.0
revision date: Apr 19, 2016
description: To comprehensively address CVE-2016-0145, Microsoft re-released security update 3144432 for affected editions of Microsoft Live Meeting 2007 Console. Customers running Microsoft Live Meeting 2007 Console should install the update to be fully protected from the vulnerability. See Microsoft Knowledge Base Article 3144432 for more information.

---

version: 1.0
revision date: Apr 12, 2016
description: Information published.


CVE Record: CVE-2016-0165
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0165
=============

CNA: Microsoft Corporation
==========================

Published: 2016-04-12
Updated: 2018-10-12

Description
-----------

The kernel-mode driver in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, and Windows 10 Gold and 1511 allows local users to gain privileges via a crafted application, aka "Win32k Elevation of Privilege Vulnerability," a different vulnerability than CVE-2016-0143 and CVE-2016-0167.

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1035529
    * https://www.exploit-db.com/exploits/44480/
    * http://www.securitytracker.com/id/1035532
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-039


CVE-2016-0165 - Security Update Guide - Microsoft - Windows Graphics Component Elevation of Privilege Vulnerability
===================================================================================================================

Security Vulnerability
Released: Apr 12, 2016
Last updated: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2016-0165

Executive Summary
-----------------

An elevation of privilege vulnerability exists when the Windows Graphics Component improperly handles objects in memory. An attacker who successfully exploited this vulnerability could run processes in an elevated context.

In a local attack scenario, an attacker could exploit this vulnerability by running a specially crafted application to take control over the affected system.

The update addresses the vulnerability by correcting the way in which the Microsoft Graphics Component handles objects in memory and preventing unintended elevation from user mode.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Anton Ivanov
      of Kaspersky Lab
    * Sebastian Apelt
      of Siberas
      working with Trend Micro's Zero Day Initiative

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Apr 12, 2016
Windows 10 Version 1511 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 Version 1511 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Windows Vista x64 Edition Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Vista Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c75e35-49e6-4839-bd53-649bf12384bb

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ba86f043-2390-4ceb-bed0-6c16b1433bc4

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update:

---

Apr 12, 2016
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=669cd30d-d220-49b0-ad48-f251debabce4

---

Apr 12, 2016
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=126dba8b-91ed-4981-a48b-ce7f80d5bb94

---

Apr 12, 2016
Windows 10 Version 1703 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

---

Apr 12, 2016
Windows 10 Version 1703 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 2.0
revision date: Sep 12, 2017
description: Revised the Affected Products table to include Windows 10 Version 1703 for 32-bit Systems and Windows 10 Version 1703 for x64-based Systems because they are affected by CVE-2016-0165. Consumers running Windows 10 are automatically protected. Microsoft recommends that enterprise customers running Windows 10 Version 1703 ensure they have update 4038788 installed to be protected from this vulnerability.

---

version: 1.0
revision date: Apr 12, 2016
description: Information published.


CVE Record: CVE-2016-0167
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2016-0167
=============

CNA: Microsoft Corporation
==========================

Published: 2016-04-12
Updated: 2018-10-12

Description
-----------

The kernel-mode driver in Microsoft Windows Vista SP2, Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, and Windows 10 Gold and 1511 allows local users to gain privileges via a crafted application, aka "Win32k Elevation of Privilege Vulnerability," a different vulnerability than CVE-2016-0143 and CVE-2016-0165.

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1035529
    * http://www.securitytracker.com/id/1035532
    * https://docs.microsoft.com/en-us/security-updates/securitybulletins/2016/ms16-039


CVE-2016-0167 - Security Update Guide - Microsoft - Windows Graphics Component Elevation of Privilege Vulnerability
===================================================================================================================

Security Vulnerability
Released: Apr 12, 2016
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2016-0167

Executive Summary
-----------------

An elevation of privilege vulnerability exists when the Windows Graphics Component improperly handles objects in memory. An attacker who successfully exploited this vulnerability could run processes in an elevated context.

In a local attack scenario, an attacker could exploit this vulnerability by running a specially crafted application to take control over the affected system.

The update addresses the vulnerability by correcting the way in which the Microsoft Graphics Component handles objects in memory and preventing unintended elevation from user mode.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: Yes
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Dhanesh Kizhakkinan
      of FireEye, Inc.

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Apr 12, 2016
Windows 10 Version 1511 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 Version 1511 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147458

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147458

---

Apr 12, 2016
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/kb/3147461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB3147461

---

Apr 12, 2016
Windows Vista x64 Edition Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Vista Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ebf824a1-d6c9-4f0a-9fa5-1073434db026

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c75e35-49e6-4839-bd53-649bf12384bb

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=e293a8bc-45d4-4a93-93a9-cfbb18ca80fa

---

Apr 12, 2016
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=ba86f043-2390-4ceb-bed0-6c16b1433bc4

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=2350321c-7c6e-4e76-9fa1-06b3906d3ba8

---

Apr 12, 2016
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update:

---

Apr 12, 2016
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=9d14fc68-41a1-464d-ac62-02771431af37

---

Apr 12, 2016
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=669cd30d-d220-49b0-ad48-f251debabce4

---

Apr 12, 2016
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=18c67970-0068-4faf-b2c8-8391a7ccb289

---

Apr 12, 2016
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/en-us/kb/3145739

    * Security Update: https://www.microsoft.com/downloads/details.aspx?familyid=126dba8b-91ed-4981-a48b-ce7f80d5bb94

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Apr 12, 2016
description: Information published.


Microsoft Security Bulletin MS16-039 - Critical

Security Update for Microsoft Graphics Component (3148522)

Published: April 12, 2016 | Updated: April 10, 2018

Version: 5.0

Executive Summary

This security update resolves vulnerabilities in Microsoft Windows, Microsoft .NET Framework, Microsoft Office, Skype for Business, and Microsoft Lync. The most severe of the vulnerabilities could allow remote code execution if a user opens a specially crafted document or visits a webpage that contains specially crafted embedded fonts.

This security update is rated Critical for:

  • All supported releases of Microsoft Windows
  • Affected versions of Microsoft .NET Framework on all supported releases of Microsoft Windows
  • Affected editions of Skype for Business 2016, Microsoft Lync 2013, and Microsoft Lync 2010

This security update is rated Important for all affected editions of Microsoft Office 2007 and Microsoft Office 2010.

For more information, see the Affected Software section.

The security update addresses the vulnerabilities by correcting how the Windows font library handles embedded fonts. For more information about the vulnerabilities, see the Vulnerability Information section.

For more information about this update, see Microsoft Knowledge Base Article 3148522.

Affected Software and Vulnerability Severity Ratings

The following software versions or editions are affected. Versions or editions that are not listed are either past their support life cycle or are not affected.

The severity ratings indicated for each affected software assume the potential maximum impact of the vulnerability. For information regarding the likelihood, within 30 days of this security bulletin’s release, of the exploitability of the vulnerability in relation to its severity rating and security impact, please see the Exploitability Index in the April bulletin summary.

Microsoft Windows

Operating System | Win32k Elevation of Privilege Vulnerability - CVE-2016-0143 | Graphics Memory Corruption Vulnerability - CVE-2016-0145 | Win32k Elevation of Privilege Vulnerability - CVE-2016-0165 | Win32k Elevation of Privilege Vulnerability - CVE-2016-0167 | Updates Replaced*
Windows Vista
Windows Vista Service Pack 2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Vista x64 Edition Service Pack 2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 for x64-based Systems Service Pack 2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 for Itanium-based Systems Service Pack 2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows 7 for x64-based Systems Service Pack 1 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows 8.1
Windows 8.1 for 32-bit Systems (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows 8.1 for x64-based Systems (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2012 R2 (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows RT 8.1
Windows RT 8.1[1](3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows 10
Windows 10 for 32-bit Systems [2](3147461) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3140745
Windows 10 for x64-based Systems [2](3147461) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3140745
Windows 10 Version 1511 for 32-bit Systems [2](3147458) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3140768
Windows 10 Version 1511 for x64-based Systems [2](3147458) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3140768
Windows 10 Version 1703 for 32-bit Systems [2](4038788) | Not applicable | Not applicable | Important Elevation of Privilege | Not applicable | 4034674
Windows 10 Version 1703 for x64-based Systems [2](4038788) | Not applicable | Not applicable | Important Elevation of Privilege | Not applicable | 4034674
Windows 10 Version 1709 for 32-bit Systems [2](4093112) | Important Elevation of Privilege | Not applicable | Not applicable | Not applicable | 4088776
Windows 10 Version 1709 for x64-based Systems [2](4093112) | Important Elevation of Privilege | Not applicable | Not applicable | Not applicable | 4088776
Server Core installation option
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2012 (Server Core installation) (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034
Windows Server 2012 R2 (Server Core installation) (3145739) | Important Elevation of Privilege | Critical Remote Code Execution | Important Elevation of Privilege | Important Elevation of Privilege | 3139852 in MS16-034

[1]This update is only available via Windows Update.

[2]Windows 10 updates are cumulative. The monthly security release includes all security fixes for vulnerabilities that affect Windows 10, in addition to non-security updates. The updates are available via the Microsoft Update Catalog.

Note Windows Server 2016 Technical Preview 4 and Windows Server 2016 Technical Preview 5 are affected. Customers running these operating systems are encouraged to apply the update, which is available via Windows Update.

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Microsoft Office

Operating System | Graphics Memory Corruption Vulnerability - CVE-2016-0145 | Updates Replaced*
Microsoft Office 2007
Microsoft Office 2007 Service Pack 3 (3114542) | Important Remote Code Execution | 3085616 in MS15-128
Microsoft Office 2010
Microsoft Office 2010 Service Pack 2 (32-bit editions) (3114566) | Important Remote Code Execution | 3085612 in MS15-128
Microsoft Office 2010 Service Pack 2 (64-bit editions) (3114566) | Important Remote Code Execution | 3085612 in MS15-128
Other Office Software
Microsoft Word Viewer (3114985) | Important Remote Code Execution | 3114478 in MS15-128

*The Updates Replaced column shows only the latest update in any chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is provided on the Package Details tab).

Microsoft .NET Framework

Operating System | Component | Graphics Memory Corruption Vulnerability - CVE-2016-0145 | Updates Replaced
Windows Vista
Windows Vista Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3142041) | Critical Remote Code Execution | 3135987 in MS16-035
Windows Vista x64 Edition Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3142041) | Critical Remote Code Execution | 3135987 in MS16-035
Windows Server 2008
Windows Server 2008 for 32-bit Systems Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3142041) | Critical Remote Code Execution | 3135987 in MS16-035
Windows Server 2008 for x64-based Systems Service Pack 2 | Microsoft .NET Framework 3.0 Service Pack 2 (3142041) | Critical Remote Code Execution | 3135987 in MS16-035
Windows 7
Windows 7 for 32-bit Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3142042) | Critical Remote Code Execution | 3135988 in MS16-035
Windows 7 for x64-based Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3142042) | Critical Remote Code Execution | 3135988 in MS16-035
Windows Server 2008 R2
Windows Server 2008 R2 for x64-based Systems Service Pack 1 | Microsoft .NET Framework 3.5.1 (3142042) | Critical Remote Code Execution | 3135988 in MS16-035
Windows 8.1
Windows 8.1 for 32-bit Systems | Microsoft .NET Framework 3.5 (3142045) | Critical Remote Code Execution | 3135991 in MS16-035
Windows 8.1 for x64-based Systems | Microsoft .NET Framework 3.5 (3142045) | Critical Remote Code Execution | 3135991 in MS16-035
Windows Server 2012 and Windows Server 2012 R2
Windows Server 2012 | Microsoft .NET Framework 3.5 (3142043) | Critical Remote Code Execution | 3135989 in MS16-035
Windows Server 2012 R2 | Microsoft .NET Framework 3.5 (3142045) | Critical Remote Code Execution | 3135991 in MS16-035
Windows 10
Windows 10 for 32-bit Systems [1](3147461) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3140745
Windows 10 for 64-bit Systems [1](3147461) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3140745
Windows 10 Version 1511 for 32-bit Systems [1](3147458) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3140768
Windows 10 Version 1511 for x64-based Systems [2](3147458) | Microsoft .NET Framework 3.5 | Critical Remote Code Execution | 3140768
Server Core installation option
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) | Microsoft .NET Framework 3.5.1 (3142042) | Critical Remote Code Execution | 3135988 in MS16-035
Windows Server 2012 (Server Core installation) | Microsoft .NET Framework 3.5 (3142043) | Critical Remote Code Execution | 3135989 in MS16-035
Windows Server 2012 R2 (Server Core installation) | Microsoft .NET Framework 3.5 (3142045) | Critical Remote Code Execution | 3135991 in MS16-035

[1]Windows 10 updates are cumulative. The monthly security release includes all security fixes for vulnerabilities that affect Windows 10, in addition to non-security updates. The updates are available via the Microsoft Update Catalog.

Note Windows Server 2016 Technical Preview 4 and Windows Server 2016 Technical Preview 5 are affected. Customers running these operating systems are encouraged to apply the update, which is available via Windows Update.

Microsoft Communications Platforms and Software

Operating System | Graphics Memory Corruption Vulnerability - CVE-2016-0145 | Updates Replaced*
Skype for Business 2016
Skype for Business 2016 (32-bit editions) (3114960) | Critical Remote Code Execution | 3114372 in MS15-128
Skype for Business Basic 2016 (32-bit editions) (3114960) | Critical Remote Code Execution | 3114372 in MS15-128
Skype for Business 2016 (64-bit editions) (3114960) | Critical Remote Code Execution | 3114372 in MS15-128
Skype for Business Basic 2016 (64-bit editions) (3114960) | Critical Remote Code Execution | 3114372 in MS15-128
Microsoft Lync 2013
Microsoft Lync 2013 Service Pack 1 (32-bit)[1](Skype for Business) (3114944) | Critical Remote Code Execution | 3114351 in MS15-128
Microsoft Lync Basic 2013 Service Pack 1 (32-bit)[1](Skype for Business Basic) (3114944) | Critical Remote Code Execution | 3114351 in MS15-128
Microsoft Lync 2013 Service Pack 1 (64-bit)[1](Skype for Business) (3114944) | Critical Remote Code Execution | 3114351 in MS15-128
Microsoft Lync Basic 2013 Service Pack 1 (64-bit)[1](Skype for Business Basic) (3114944) | Critical Remote Code Execution | 3114351 in MS15-128
Microsoft Lync 2010
Microsoft Lync 2010 (32-bit) (3144427) | Critical Remote Code Execution | 3115871 in MS15-128
Microsoft Lync 2010 (64-bit) (3144427) | Critical Remote Code Execution | 3115871 in MS15-128
Microsoft Lync 2010 Attendee [2](user level install) (3144428) | Critical Remote Code Execution | 3115872 in MS15-128
Microsoft Lync 2010 Attendee (admin level install) (3144429) | Critical Remote Code Execution | 3115873 in MS15-128
Microsoft Live Meeting 2007 Console
Microsoft Live Meeting 2007 Console [3](3144432) | Critical Remote Code Execution | 3115875 in MS15-128

[1]Before installing this update, you must have update 2965218 and security update 3039779 installed. See the Update FAQ for more information.

[2]This update is available from the Microsoft Download Center only.

[3]An update for the Conferencing Add-in for Microsoft Office Outlook is also available. For more information and download links, see Download the Conferencing Add-in for Microsoft Office Outlook.

*The Updates Replaced column shows only the latest update in a chain of superseded updates. For a comprehensive list of updates replaced, go to the Microsoft Update Catalog, search for the update KB number, and then view update details (updates replaced information is on the Package Details tab).

Update FAQ

Does this update contain any additional security-related changes to functionality?
In addition to the changes that are listed for the vulnerabilities described in this bulletin, this update includes defense-in-depth updates to help improve security-related features.

I am running Office 2010, which is listed as affected software. Why am I not being offered the update?
The update is not applicable to Office 2010 on Windows Vista and later versions of Windows because the vulnerable code is not present.

I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335. For a list of Microsoft Office products an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

Are there any prerequisites for any of the updates offered in this bulletin for affected editions of Microsoft Lync 2013 (Skype for Business)?
Yes. Customers running affected editions of Microsoft Lync 2013 (Skype for Business) must first install the 2965218 update for Office 2013 released in April, 2015, and then the 3039779 security update released in May, 2015. For more information about these two prerequisite updates, see:

  • Knowledge Base Article 3039779

Are there any related non-security updates that customers should install along with the Microsoft Live Meeting Console security update?
Yes, in addition to releasing a security update for Microsoft Live Meeting Console, Microsoft has released the following non-security updates for the OCS Conferencing Addin for Outlook. Where applicable, Microsoft recommends that customers install these updates to keep their systems up-to-date:

  • OCS Conferencing Addin for Outlook (32-bit) (3144431)
  • OCS Conferencing Addin for Outlook (64-bit) (3144431)

See Microsoft Knowledge Base Article 3144431 for more information.

Why is the Lync 2010 Attendee (user level install) update only available from the Microsoft Download Center?
Microsoft is releasing the update for Lync 2010 Attendee (user level install) to the Microsoft Download Center only. Because the user level installation of Lync 2010 Attendee is handled through a Lync session, distribution methods such as automatic updating are not appropriate for this type of installation scenario.

Vulnerability Information

Multiple Win32k Elevation of Privilege Vulnerabilities

Elevation of privilege vulnerabilities exist when the Windows kernel-mode driver fails to properly handle objects in memory. An attacker who successfully exploited the vulnerabilities could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit the vulnerabilities, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerabilities and take control of an affected system. The update addresses the vulnerabilities by correcting how the Windows kernel-mode driver handles objects in memory.

The following tables contain links to the standard entry for each vulnerability in the Common Vulnerabilities and Exposures list:

Vulnerability title | CVE number | Publicly disclosed | Exploited
Win32k Elevation of Privilege Vulnerability | CVE-2016-0143 | No | No
Win32k Elevation of Privilege Vulnerability | CVE-2016-0165 | No | Yes
Win32k Elevation of Privilege Vulnerability | CVE-2016-0167 | No | Yes

Mitigating Factors

Microsoft has not identified any mitigating factors for these vulnerabilities.

Workarounds

Microsoft has not identified any workarounds for these vulnerabilities.

Graphics Memory Corruption Vulnerability - CVE-2016-0145

A remote code execution vulnerability exists when the Windows font library improperly handles specially crafted embedded fonts. An attacker who successfully exploited the vulnerability could install programs; view, change, or delete data; or create new accounts with full user rights.

There are multiple ways an attacker could exploit the vulnerability, such as by convincing a user to open a specially crafted document, or by convincing a user to visit an untrusted webpage that contains embedded fonts. The security update addresses the vulnerability by correcting how the Windows font library handles embedded fonts.

The following tables contain links to the standard entry for each vulnerability in the Common Vulnerabilities and Exposures list:

Vulnerability title | CVE number | Publicly disclosed | Exploited
Graphics Memory Corruption Vulnerability | CVE-2016-0145 | No | No

Mitigating Factors

Microsoft has not identified any mitigating factors for this vulnerability.

Workarounds

Microsoft has not identified any workarounds for this vulnerability.

Security Update Deployment

For Security Update Deployment information, see the Microsoft Knowledge Base article referenced in the Executive Summary.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure. See Acknowledgments for more information.

Disclaimer

The information provided in the Microsoft Knowledge Base is provided “as is” without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions

  • V1.0 (April 12, 2016): Bulletin published.
  • V2.0 (April 19, 2016): To comprehensively address CVE-2016-0145, Microsoft re-released security update 3144432 for affected editions of Microsoft Live Meeting 2007 Console. Customers running Microsoft Live Meeting 2007 Console should install the update to be fully protected from the vulnerability. See Microsoft Knowledge Base Article 3144432 for more information.
  • V3.0 (June 14, 2016): Microsoft has re-released security update 3144427 for affected editions of Microsoft Lync 2010 and Microsoft Lync 2010 Attendee. The re-release addresses issues customers might have experienced downloading security update 3144427. Customers running Microsoft Lync 2010 should install the update to be fully protected from the vulnerability. See Microsoft Knowledge Base Article 3144427 for more information.
  • V4.0 (September 12, 2017): Revised the Microsoft Windows affected software table to include Windows 10 Version 1703 for 32-bit Systems and Windows 10 Version 1703 for x64-based Systems because they are affected by CVE-2016-0165. Consumers running Windows 10 are automatically protected. Microsoft recommends that enterprise customers running Windows 10 Version 1703 ensure they have update 4038788 installed to be protected from this vulnerability.
  • V5.0 (April 10, 2018): Revised the Microsoft Windows affected software table to include Windows 10 Version 1709 for 32-bit Systems and Windows 10 Version 1709 for x64-based Systems because they are affected by CVE-2016-0143. Microsoft strongly recommends that customers install the updates to be fully protected from the vulnerability. Customers whose systems are configured to receive automatic updates do not need to take any further action.

Page generated 2016-06-13 16:43-07:00.


CVE Record: CVE-2019-1395
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2019-1395
=============

CNA: Microsoft Corporation
==========================

Published: 2019-11-12
Updated: 2019-11-14

Description
-----------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory, aka 'Win32k Elevation of Privilege Vulnerability'. This CVE ID is unique from CVE-2019-1393, CVE-2019-1394, CVE-2019-1396, CVE-2019-1408, CVE-2019-1434.

Product Status
--------------

Vendor: Microsoft
Product: Windows

affected
    * 7 for 32-bit Systems Service Pack 1
    * 7 for x64-based Systems Service Pack 1
    * 8.1 for 32-bit systems
    * 8.1 for x64-based systems
    * RT 8.1
    * 10 for 32-bit Systems
    * 10 for x64-based Systems
    * 10 Version 1607 for 32-bit Systems
    * 10 Version 1607 for x64-based Systems
    * 10 Version 1709 for 32-bit Systems
    * 10 Version 1709 for ARM64-based Systems
    * 10 Version 1709 for x64-based Systems
    * 10 Version 1803 for 32-bit Systems
    * 10 Version 1803 for ARM64-based Systems
    * 10 Version 1803 for x64-based Systems
    * 10 Version 1809 for 32-bit Systems
    * 10 Version 1809 for ARM64-based Systems
    * 10 Version 1809 for x64-based Systems
    * 10 Version 1903 for 32-bit Systems
    * 10 Version 1903 for ARM64-based Systems
    * 10 Version 1903 for x64-based Systems

Vendor: Microsoft
Product: Windows Server

affected
    * 2008 for 32-bit Systems Service Pack 2 (Core installation)
    * 2008 for 32-bit Systems Service Pack 2
    * 2008 for Itanium-Based Systems Service Pack 2
    * 2008 for x64-based Systems Service Pack 2 (Core installation)
    * 2008 for x64-based Systems Service Pack 2
    * 2008 R2 for Itanium-Based Systems Service Pack 1
    * 2008 R2 for x64-based Systems Service Pack 1 (Core installation)
    * 2008 R2 for x64-based Systems Service Pack 1
    * 2012 (Core installation)
    * 2012 R2 (Core installation)
    * 2012 R2
    * 2012
    * 2016 (Core installation)
    * 2016
    * 2019 (Core installation)
    * 2019
    * version 1803 (Core Installation)
    * version 1903 (Server Core installation)

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1395
    * https://www.zerodayinitiative.com/advisories/ZDI-19-981/


CVE-2019-1395 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Nov 12, 2019
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2019-1395

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how Win32k handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Marcin Wiazowski working with Trend Micro's Zero Day Initiative

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Nov 12, 2019
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525246
    * https://support.microsoft.com/help/4525253

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525246
    * Security Only:: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525253

---

Nov 12, 2019
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525246
    * https://support.microsoft.com/help/4525253

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525246
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525253

---

Nov 12, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243

    * Monthly Rollup

---

Nov 12, 2019
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2016 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows Server 2016
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 Version 1607 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 Version 1607 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525232

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525232

---

Nov 12, 2019
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525232

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525232

---

Nov 12, 2019
Windows Server, version 1903 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1709 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows 10 Version 1709 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows 10 Version 1709 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows Server 2019 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows Server 2019
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1803 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows Server, version 1803 (Server Core Installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows 10 Version 1803 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows 10 Version 1803 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Nov 12, 2019
description: Information published.


CVE Record: CVE-2019-1396
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2019-1396
=============

CNA: Microsoft Corporation
==========================

Published: 2019-11-12
Updated: 2019-11-14

Description
-----------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory, aka 'Win32k Elevation of Privilege Vulnerability'. This CVE ID is unique from CVE-2019-1393, CVE-2019-1394, CVE-2019-1395, CVE-2019-1408, CVE-2019-1434.

Product Status
--------------

Vendor: Microsoft
Product: Windows

affected
    * 7 for 32-bit Systems Service Pack 1
    * 7 for x64-based Systems Service Pack 1
    * 8.1 for 32-bit systems
    * 8.1 for x64-based systems
    * RT 8.1
    * 10 for 32-bit Systems
    * 10 for x64-based Systems
    * 10 Version 1607 for 32-bit Systems
    * 10 Version 1607 for x64-based Systems
    * 10 Version 1709 for 32-bit Systems
    * 10 Version 1709 for ARM64-based Systems
    * 10 Version 1709 for x64-based Systems
    * 10 Version 1803 for 32-bit Systems
    * 10 Version 1803 for ARM64-based Systems
    * 10 Version 1803 for x64-based Systems
    * 10 Version 1809 for 32-bit Systems
    * 10 Version 1809 for ARM64-based Systems
    * 10 Version 1809 for x64-based Systems
    * 10 Version 1903 for 32-bit Systems
    * 10 Version 1903 for ARM64-based Systems
    * 10 Version 1903 for x64-based Systems

Vendor: Microsoft
Product: Windows Server

affected
    * 2008 for 32-bit Systems Service Pack 2 (Core installation)
    * 2008 for 32-bit Systems Service Pack 2
    * 2008 for Itanium-Based Systems Service Pack 2
    * 2008 for x64-based Systems Service Pack 2 (Core installation)
    * 2008 for x64-based Systems Service Pack 2
    * 2008 R2 for Itanium-Based Systems Service Pack 1
    * 2008 R2 for x64-based Systems Service Pack 1 (Core installation)
    * 2008 R2 for x64-based Systems Service Pack 1
    * 2012 (Core installation)
    * 2012 R2 (Core installation)
    * 2012 R2
    * 2012
    * 2016 (Core installation)
    * 2016
    * 2019 (Core installation)
    * 2019
    * version 1803 (Core Installation)
    * version 1903 (Server Core installation)

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1396
    * https://www.zerodayinitiative.com/advisories/ZDI-19-982/


CVE-2019-1396 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Nov 12, 2019
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2019-1396

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how Win32k handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Marcin Wiazowski working with Trend Micro's Zero Day Initiative

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Nov 12, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525234
    * https://support.microsoft.com/help/4525239

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525234
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525239

---

Nov 12, 2019
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243

    * Monthly Rollup

---

Nov 12, 2019
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

---

Nov 12, 2019
Windows Server 2016 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows Server 2016
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 Version 1607 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 Version 1607 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525236

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525236

---

Nov 12, 2019
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525232

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525232

---

Nov 12, 2019
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525232

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525232

---

Nov 12, 2019
Windows Server, version 1903 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1903 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4524570

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4524570

---

Nov 12, 2019
Windows 10 Version 1709 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows 10 Version 1709 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows 10 Version 1709 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525241

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525241

---

Nov 12, 2019
Windows Server 2019 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows Server 2019
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1809 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4523205

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4523205

---

Nov 12, 2019
Windows 10 Version 1803 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows Server, version 1803 (Server Core Installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows 10 Version 1803 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows 10 Version 1803 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525237

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525237

---

Nov 12, 2019
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525243
    * https://support.microsoft.com/help/4525250

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525243
    * Security Only: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525250

---

Nov 12, 2019
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525246
    * https://support.microsoft.com/help/4525253

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525246
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525253

---

Nov 12, 2019
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525246
    * https://support.microsoft.com/help/4525253

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525246
    * Security Only: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525253

---

Nov 12, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4525235
    * https://support.microsoft.com/help/4525233

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525235
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4525233

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Nov 12, 2019
description: Information published.


CVE Record: CVE-2020-0788
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2020-0788
=============

CNA: Microsoft Corporation
==========================

Published: 2020-03-12
Updated: 2020-03-12

Description
-----------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory, aka 'Win32k Elevation of Privilege Vulnerability'. This CVE ID is unique from CVE-2020-0877, CVE-2020-0887.

Product Status
--------------

Vendor: Microsoft
Product: Windows

affected
    * 7 for 32-bit Systems Service Pack 1
    * 7 for x64-based Systems Service Pack 1
    * 8.1 for 32-bit systems
    * 8.1 for x64-based systems
    * RT 8.1
    * 10 for 32-bit Systems
    * 10 for x64-based Systems
    * 10 Version 1607 for 32-bit Systems
    * 10 Version 1607 for x64-based Systems
    * 10 Version 1709 for 32-bit Systems
    * 10 Version 1709 for ARM64-based Systems
    * 10 Version 1709 for x64-based Systems
    * 10 Version 1803 for 32-bit Systems
    * 10 Version 1803 for ARM64-based Systems
    * 10 Version 1803 for x64-based Systems
    * 10 Version 1809 for 32-bit Systems
    * 10 Version 1809 for ARM64-based Systems
    * 10 Version 1809 for x64-based Systems
    * 10 Version 1903 for 32-bit Systems
    * 10 Version 1903 for ARM64-based Systems
    * 10 Version 1903 for x64-based Systems
    * 10 Version 1909 for 32-bit Systems
    * 10 Version 1909 for ARM64-based Systems
    * 10 Version 1909 for x64-based Systems

Vendor: Microsoft
Product: Windows Server

affected
    * 2008 for 32-bit Systems Service Pack 2 (Core installation)
    * 2008 for 32-bit Systems Service Pack 2
    * 2008 for Itanium-Based Systems Service Pack 2
    * 2008 for x64-based Systems Service Pack 2 (Core installation)
    * 2008 for x64-based Systems Service Pack 2
    * 2008 R2 for Itanium-Based Systems Service Pack 1
    * 2008 R2 for x64-based Systems Service Pack 1 (Core installation)
    * 2008 R2 for x64-based Systems Service Pack 1
    * 2012 (Core installation)
    * 2012 R2 (Core installation)
    * 2012 R2
    * 2012
    * 2016 (Core installation)
    * 2016
    * 2019 (Core installation)
    * 2019
    * version 1803 (Core Installation)
    * version 1903 (Server Core installation)
    * version 1909 (Server Core installation)

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-0788


CVE-2020-0788 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Mar 10, 2020
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2020-0788

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how Win32k handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * Marcin Wiazowski working with Trend Micro's Zero Day Initiative

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Mar 10, 2020
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541509
    * https://support.microsoft.com/help/4541505

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541509
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541505

---

Mar 10, 2020
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541509
    * https://support.microsoft.com/help/4541505

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541509
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541505

---

Mar 10, 2020
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541510
    * https://support.microsoft.com/help/4540694

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541510
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540694

---

Mar 10, 2020
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541510
    * https://support.microsoft.com/help/4540694

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541510
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540694

---

Mar 10, 2020
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540688
    * https://support.microsoft.com/help/4541500

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540688
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541500

---

Mar 10, 2020
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540688
    * https://support.microsoft.com/help/4541500

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540688
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541500

---

Mar 10, 2020
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541506
    * https://support.microsoft.com/help/4541504

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541506
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541504

---

Mar 10, 2020
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541506
    * https://support.microsoft.com/help/4541504

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541506
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541504

---

Mar 10, 2020
Windows 10 Version 1809 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4538461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4538461

---

Mar 10, 2020
Windows 10 Version 1809 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4538461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4538461

---

Mar 10, 2020
Windows 10 Version 1803 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540689

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540689

---

Mar 10, 2020
Windows Server, version 1803 (Server Core Installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540689

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540689

---

Mar 10, 2020
Windows 10 Version 1803 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540689

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540689

---

Mar 10, 2020
Windows 10 Version 1803 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540689

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540689

---

Mar 10, 2020
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541506
    * https://support.microsoft.com/help/4541504

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541506
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541504

---

Mar 10, 2020
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541506
    * https://support.microsoft.com/help/4541504

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541506
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541504

---

Mar 10, 2020
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541509

    * Monthly Rollup

---

Mar 10, 2020
Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541509
    * https://support.microsoft.com/help/4541505

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541509
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541505

---

Mar 10, 2020
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4541509
    * https://support.microsoft.com/help/4541505

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541509
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541505

---

Mar 10, 2020
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540688
    * https://support.microsoft.com/help/4541500

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540688
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541500

---

Mar 10, 2020
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540688
    * https://support.microsoft.com/help/4541500

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540688
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4541500

---

Mar 10, 2020
Windows Server 2016 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540670

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540670

---

Mar 10, 2020
Windows Server 2016
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540670

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540670

---

Mar 10, 2020
Windows 10 Version 1607 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540670

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540670

---

Mar 10, 2020
Windows 10 Version 1607 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540670

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540670

---

Mar 10, 2020
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540693

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540693

---

Mar 10, 2020
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540693

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540693

---

Mar 10, 2020
Windows Server, version 1903 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1903 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1903 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1903 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1709 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540681

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540681

---

Mar 10, 2020
Windows 10 Version 1709 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540681

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540681

---

Mar 10, 2020
Windows 10 Version 1709 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540681

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540681

---

Mar 10, 2020
Windows Server, version 1909 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1909 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1909 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows 10 Version 1909 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4540673

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4540673

---

Mar 10, 2020
Windows Server 2019 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4538461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4538461

---

Mar 10, 2020
Windows Server 2019
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4538461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4538461

---

Mar 10, 2020
Windows 10 Version 1809 for ARM64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4538461

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4538461

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Mar 10, 2020
description: Information published.


ZDI-19-981 | Zero Day Initiative

Advisory Details

November 13th, 2019

Microsoft Windows CreateXlateObject Out-Of-Bounds Write Privilege Escalation Vulnerability

ZDI-19-981
ZDI-CAN-9110

CVE ID | CVE-2019-1395
CVSS SCORE | 8.8, AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
AFFECTED VENDORS | Microsoft
AFFECTED PRODUCTS | Windows
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Microsoft Windows. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the CreateXlateObject function in win32k.sys. The issue results from the lack of proper validation of user-supplied data, which can result in a write outside the bounds of an allocated array. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of SYSTEM.
ADDITIONAL DETAILS Microsoft has issued an update to correct this vulnerability. More details can be found at:
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1395
DISCLOSURE TIMELINE
  • 2019-08-12 - Vulnerability reported to vendor
  • 2019-11-13 - Coordinated public release of advisory
CREDIT | Marcin Wiazowski


ZDI-19-982 | Zero Day Initiative

Advisory Details

November 13th, 2019

Microsoft Windows CreateXlateObject Out-Of-Bounds Write Privilege Escalation Vulnerability

ZDI-19-982
ZDI-CAN-9118

CVE ID | CVE-2019-1396
CVSS SCORE | 8.8, AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
AFFECTED VENDORS | Microsoft
AFFECTED PRODUCTS | Windows
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Microsoft Windows. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the CreateXlateObject function in win32k.sys. The issue results from the lack of proper validation of user-supplied data, which can result in a write outside the bounds of an allocated array. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of SYSTEM.
ADDITIONAL DETAILS Microsoft has issued an update to correct this vulnerability. More details can be found at:
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-1396
DISCLOSURE TIMELINE
  • 2019-08-12 - Vulnerability reported to vendor
  • 2019-11-13 - Coordinated public release of advisory
CREDIT | Marcin Wiazowski


ZDI-20-279 | Zero Day Initiative

Advisory Details

March 12th, 2020

Microsoft Windows CreateXlateObject Out-Of-Bounds Write Privilege Escalation Vulnerability

ZDI-20-279
ZDI-CAN-9857

CVE ID | CVE-2020-0788
CVSS SCORE | 8.8, AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
AFFECTED VENDORS | Microsoft
AFFECTED PRODUCTS | Windows
VULNERABILITY DETAILS

This vulnerability allows local attackers to escalate privileges on affected installations of Microsoft Windows. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the CreateXlateObject function in win32k.sys. The issue results from the lack of proper validation of user-supplied data, which can result in a write outside the bounds of an allocated array. An attacker can leverage this vulnerability to escalate privileges and execute code in the context of SYSTEM.
ADDITIONAL DETAILS Microsoft has issued an update to correct this vulnerability. More details can be found at:
https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2020-0788
DISCLOSURE TIMELINE
  • 2019-11-28 - Vulnerability reported to vendor
  • 2020-03-12 - Coordinated public release of advisory
CREDIT | Marcin Wiazowski


CVE Record: CVE-2019-0848
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2019-0848
=============

CNA: Microsoft Corporation
==========================

Published: 2019-04-09
Updated: 2019-04-09

Description
-----------

An information disclosure vulnerability exists when the win32k component improperly provides kernel information, aka 'Win32k Information Disclosure Vulnerability'. This CVE ID is unique from CVE-2019-0814.

Product Status
--------------

Vendor: Microsoft
Product: Windows

affected
    * 7 for 32-bit Systems Service Pack 1
    * 7 for x64-based Systems Service Pack 1
    * 8.1 for 32-bit systems
    * 8.1 for x64-based systems
    * RT 8.1
    * 10 for 32-bit Systems
    * 10 for x64-based Systems
    * 10 Version 1607 for 32-bit Systems
    * 10 Version 1607 for x64-based Systems
    * 10 Version 1703 for 32-bit Systems
    * 10 Version 1703 for x64-based Systems
    * 10 Version 1709 for 32-bit Systems
    * 10 Version 1709 for ARM64-based Systems
    * 10 Version 1709 for x64-based Systems
    * 10 Version 1803 for 32-bit Systems
    * 10 Version 1803 for ARM64-based Systems
    * 10 Version 1803 for x64-based Systems
    * 10 Version 1809 for 32-bit Systems
    * 10 Version 1809 for ARM64-based Systems
    * 10 Version 1809 for x64-based Systems

Vendor: Microsoft
Product: Windows Server

affected
    * 2008 R2 for Itanium-Based Systems Service Pack 1
    * 2008 R2 for x64-based Systems Service Pack 1
    * 2008 R2 for x64-based Systems Service Pack 1 (Core installation)
    * 2008 for 32-bit Systems Service Pack 2
    * 2008 for 32-bit Systems Service Pack 2 (Core installation)
    * 2008 for Itanium-Based Systems Service Pack 2
    * 2008 for x64-based Systems Service Pack 2
    * 2008 for x64-based Systems Service Pack 2 (Core installation)
    * 2012
    * 2012 (Core installation)
    * 2012 R2
    * 2012 R2 (Core installation)
    * 2016
    * 2016 (Core installation)
    * 2019
    * 2019 (Core installation)
    * version 1709 (Core Installation)
    * version 1803 (Core Installation)

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2019-0848


CVE-2019-0848 - Security Update Guide - Microsoft - Win32k Information Disclosure Vulnerability
===============================================================================================

Security Vulnerability
Released: Apr 9, 2019
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2019-0848

Executive Summary
-----------------

An information disclosure vulnerability exists when the win32k component improperly provides kernel information. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application.

The security update addresses the vulnerability by correcting how win32k handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

FAQ
---

    What type of information could be disclosed by this vulnerability?
    ------------------------------------------------------------------
    - The type of information that could be disclosed if an attacker successfully exploited this vulnerability is uninitialized memory.

Acknowledgements
----------------

    * Michael James Loftus

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Apr 9, 2019
Windows Server 2012 R2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493446
    * https://support.microsoft.com/help/4493467

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493446
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493467

---

Apr 9, 2019
Windows Server 2012 R2
Information Disclosure
Important

    * https://support.microsoft.com/help/4493446
    * https://support.microsoft.com/help/4493467

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493446
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493467

---

Apr 9, 2019
Windows Server 2012 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493451
    * https://support.microsoft.com/help/4493450

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493451
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493450

---

Apr 9, 2019
Windows Server 2012
Information Disclosure
Important

    * https://support.microsoft.com/help/4493451
    * https://support.microsoft.com/help/4493450

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493451
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493450

---

Apr 9, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493472
    * https://support.microsoft.com/help/4493448

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493472
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493448

---

Apr 9, 2019
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4493472
    * https://support.microsoft.com/help/4493448

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493472
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493448

---

Apr 9, 2019
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4493472
    * https://support.microsoft.com/help/4493448

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493472
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493448

---

Apr 9, 2019
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493471
    * https://support.microsoft.com/help/4493458

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493471
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493458

---

Apr 9, 2019
Windows Server 2008 for x64-based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4493471
    * https://support.microsoft.com/help/4493458

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493471
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493458

---

Apr 9, 2019
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4493471
    * https://support.microsoft.com/help/4493458

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493471
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493458

---

Apr 9, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493471
    * https://support.microsoft.com/help/4493458

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493471
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493458

---

Apr 9, 2019
Windows Server 2008 for 32-bit Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4493471
    * https://support.microsoft.com/help/4493458

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493471
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493458

---

Apr 9, 2019
Windows RT 8.1
Information Disclosure
Important

    * https://support.microsoft.com/help/4493446

---

Apr 9, 2019
Windows 8.1 for x64-based systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4493446
    * https://support.microsoft.com/help/4493467

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493446
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493467

---

Apr 9, 2019
Windows 8.1 for 32-bit systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4493446
    * https://support.microsoft.com/help/4493467

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493446
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493467

---

Apr 9, 2019
Windows 7 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4493472
    * https://support.microsoft.com/help/4493448

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493472
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493448

---

Apr 9, 2019
Windows 7 for 32-bit Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4493472
    * https://support.microsoft.com/help/4493448

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493472
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493448

---

Apr 9, 2019
Windows Server 2016 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4493470

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493470

---

Apr 9, 2019
Windows Server 2016
Information Disclosure
Important

    * https://support.microsoft.com/help/4493470

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493470

---

Apr 9, 2019
Windows 10 Version 1607 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4493470

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4493470

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Apr 9, 2019
description: Information published.


Updates causing crashes on processors without SSE2
==================================================

In May 2018, Microsoft silently began using the SSE2 (Streaming SIMD Extensions 2) CPU instruction set in all updates. The SSE family of instructions allow programs to achieve higher performance in certain math operations.

Processors that initially implemented SSE2 instructions include Intel Pentium 4 (2000), Pentium M (2003), and AMD Athlon 64 (2003). Processors that **do not** implement SSE2 include Intel Pentium, Pentium Pro, Pentium II, and Pentium III; AMD K5, K6, Athlon, and Athlon XP.

SSE2 was added as a minimum processor requirement in Windows 8, but this change unexpectedly brings this requirement back to earlier versions of Windows. Microsoft did not notify customers of this change, and Windows Update does not check if the processor supports SSE2. This can cause these updates to be installed on an incompatible system, causing programs to crash.

The following products are known to be affected:

    * Windows Embedded 2009
    * Windows 7
    * Windows Server 2008 and 2008 R2 Extended Security Updates (ESUs; https://legacyupdate.net/help/extended-security-updates)
    * Office 2010
    * Microsoft Security Essentials and Windows Defender

If you enable receiving Windows Embedded 2009 updates on Windows XP, you may install incompatible updates. The most commonly reported crash is in Internet Explorer, when attempting to load a page. If your processor does not support SSE2, Legacy Update Setup will prevent you from enabling Windows Embedded 2009 updates. Legacy Update currently does not detect if you have already used another tool to enable these updates. (It is difficult to disable Windows Embedded 2009 updates, as Windows protects the relevant registry key from modification.)

If you are experiencing such crashes, use the Add or Remove Programs control panel to uninstall the following updates:
    | ---------- | ---------------------------------------------------------------------------------- |
    | KB Article | Name                                                                               |
    | ---------- | ---------------------------------------------------------------------------------- |
    | KB4034775  | Security Update for WES09 and POSReady 2009                                        |
    | KB4343674  | 2018-08 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4344180  | 2018-08 Security Only Update for .NET Framework 2.0 on WES09 and POSReady 2009     |
    | KB4457046  | 2018-09 Security Only Update for .NET Framework 4.0 on WES09 and POSReady 2009     |
    | KB4458000  | 2018-09 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4458006  | 2018-09 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4458318  | 2018-09 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4462774  | 2018-08 Security Only Update for .NET Framework 4.0 on WES09 and POSReady 2009     |
    | KB4462987  | 2018-10 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4463573  | 2018-10 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4470490  | 2018-12 Security Only Update for .NET Framework 4.0 on WES09 and POSReady 2009     |
    | KB4470633  | 2018-12 Security Only Update for .NET Framework 3.5 SP1 on WES09 and POSReady 2009 |
    | KB4473077  | 2018-12 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4483475  | 2019-02 Security Only Update for .NET Framework 4.0 on WES09 and POSReady 2009     |
    | KB4483485  | 2019-02 Security Only Update for .NET Framework 2.0 SP2 on WES09 and POSReady 2009 |
    | KB4483495  | 2019-02 Security Only Update for .NET Framework 3.0 SP2 on WES09 and POSReady 2009 |
    | KB4486463  | 2019-02 Security Update for WES09 and POSReady 2009 for x86-based Systems          |
    | KB4487085  | Security Update for WES09 and POSReady 2009 for x86-based Systems                  |
    | KB4489973  | 2019-03 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4489977  | 2019-03 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4490385  | 2019-03 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4493793  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4493794  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4493795  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4493796  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4493797  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4494528  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | KB4495022  | 2019-04 Security Update for POSReady 2009 for x86-based Systems                    |
    | ---------- | ---------------------------------------------------------------------------------- |

We also recommend using Legacy Update to hide these updates (“Don’t show this update again” checkbox) to ensure Automatic Updates doesn’t reinstall them.

You may also have issues with the 2019-02 Security Update for WES09 and POSReady 2009 for x86-based Systems (KB4486463). Refer to our article (https://legacyupdate.net/help/kb4486463) on it for more information.


CVE Record: CVE-2017-8675
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8675
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-13

Description
-----------

The Windows Kernel-Mode Drivers component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016 allows an elevation of privilege vulnerability when the Win32k component fails to properly handle objects in memory, aka "Win32k Elevation of Privilege Vulnerability".. This CVE ID is unique from CVE-2017-8720.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows Kernel-Mode Drivers

affected
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2008 SP2 and R2 SP1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8675
    * http://www.securityfocus.com/bid/100752
    * http://www.securitytracker.com/id/1039325


CVE-2017-8675 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8675

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Windows kernel-mode driver fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how the Windows kernel-mode driver handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation More Likely

Acknowledgements
----------------

    * WenQunWang
      of Tencent's Xuanwu LAB
      http://www.tencent.com/

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2012 R2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 R2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2012
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows RT 8.1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038792

---

Windows 8.1 for x64-based systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 8.1 for 32-bit systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 7 for x64-based Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows 7 for 32-bit Systems Service Pack 1
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2016 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows Server 2016
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1607 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1607 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1511 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 Version 1511 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 Version 1703 for x64-based Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

---

Sep 12, 2017
Windows 10 Version 1703 for 32-bit Systems
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8676
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8676
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-13

Description
-----------

The Windows Graphics Device Interface (GDI) in Microsoft Windows Server 2008 SP2 and R2 SP1; Windows 7 SP1; Windows 8.1; Windows Server 2012 Gold and R2; Windows RT 8.1; Windows 10 Gold, 1511, 1607, 1703, and Server 2016; Office 2007 SP3; Office 2010 SP2; Word Viewer; Office for Mac 2011 and 2016; Skype for Business 2016; Lync 2013 SP1; Lync 2010; Lync 2010 Attendee; and Live Meeting 2007 Add-in and Console allows an authenticated attacker to retrieve information from a targeted system via a specially crafted application, aka "Windows GDI+ Information Disclosure Vulnerability."

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows Graphics Device Interface (GDI)

affected
    * Live Meeting 2007 Add-in and Console
    * Lync 2010
    * Lync 2010 Attendee
    * Lync 2013 SP1
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Office 2007 SP3
    * Office 2010 SP2
    * Office for Mac 2011 and 2016
    * Skype for Business 2016
    * Windows 10 Gold, 1511, 1607, 1703, and Server 2016
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2
    * Word Viewer

References
----------

    * http://www.securityfocus.com/bid/100755
    * http://www.securitytracker.com/id/1039333
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8676


CVE-2017-8676 - Security Update Guide - Microsoft - Windows GDI+ Information Disclosure Vulnerability
=====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Last updated: Sep 15, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8676

Executive Summary
-----------------

An information disclosure vulnerability exists in the way that the Windows Graphics Device Interface (GDI) handles objects in memory, allowing an attacker to retrieve information from a targeted system. By itself, the information disclosure does not allow arbitrary code execution; however, it could allow arbitrary code to be run if the attacker uses it in combination with another vulnerability.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application.

Note that where the severity is indicated as Critical in the Affected Products table, the Preview Pane is an attack vector for this vulnerability.

The security update addresses the vulnerability by correcting how GDI handles memory addresses.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

FAQ
---

    I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

    For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

    For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335. For a list of Microsoft Office products that an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

Acknowledgements
----------------

    * Weibo Wang
      of 360 SkyEye Labs
    * bear13oy
      of CloverSec Labs

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.2
revision date: Sep 15, 2017
description: Corrected the Severity entries in the Affected Products table for Microsoft Office 2007 and Microsoft Office 2010 because the Preview Pane is an attack vector for these products. This is an informational change only. Customers who have already successfully installed the updates do not need to take any further action.

---

version: 1.1
revision date: Sep 14, 2017
description: Added an FAQ to explain why security update 3191848 is not applicable to Office 2010 on Windows Server 2008 and later versions. This is an informational change only. Customers who have already installed the updates do not need to take any further action.

---

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8678
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8678
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

The Windows kernel component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016 allows an information disclosure vulnerability when it improperly handles objects in memory, aka "Win32k Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8677, CVE-2017-8680, CVE-2017-8681, and CVE-2017-8687.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows kernel

affected
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Windows 10 Gold, 1511, 1607 and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * https://www.exploit-db.com/exploits/42750/
    * http://www.securityfocus.com/bid/100769
    * http://www.securitytracker.com/id/1039325
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8678


CVE-2017-8678 - Security Update Guide - Microsoft - Windows Kernel Information Disclosure Vulnerability
=======================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8678

Executive Summary
-----------------

An information disclosure vulnerability exists when the Windows kernel improperly handles objects in memory. An attacker who successfully exploited this vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to execute code or to elevate user rights directly, but it could be used to obtain information that could be used to try to further compromise the affected system.

The update addresses the vulnerability by correcting how the Windows kernel handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * fanxiaocao and pjf
      of IceSword Lab, Qihoo 360
      http://weibo.com/jfpan
    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8680
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8680
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

The Windows kernel component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT 8.1 allows an information disclosure vulnerability when it improperly handles objects in memory, aka "Win32k Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8678, CVE-2017-8677, CVE-2017-8681, and CVE-2017-8687.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows kernel

affected
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2

References
----------

    * http://www.securityfocus.com/bid/100722
    * http://www.securitytracker.com/id/1039338
    * https://www.exploit-db.com/exploits/42741/
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8680


CVE-2017-8680 - Security Update Guide - Microsoft - Windows GDI+ Information Disclosure Vulnerability
=====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8680

Executive Summary
-----------------

A information disclosure vulnerability exists when the Windows GDI+ component improperly discloses kernel memory addresses. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to execute code or to elevate user rights directly, but it could be used to obtain information that could be used to try to further compromise the affected system.

The security update addresses the vulnerability by correcting how the Windows GDI+ component handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows RT 8.1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8681
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8681
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

The Windows kernel component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016 allows an information disclosure vulnerability when it improperly handles objects in memory, aka "Win32k Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8678, CVE-2017-8680, CVE-2017-8677, and CVE-2017-8687.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows kernel

affected
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * http://www.securityfocus.com/bid/100727
    * http://www.securitytracker.com/id/1039338
    * https://www.exploit-db.com/exploits/42742/
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8681


CVE-2017-8681 - Security Update Guide - Microsoft - Windows GDI+ Information Disclosure Vulnerability
=====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8681

Executive Summary
-----------------

A information disclosure vulnerability exists when the Windows GDI+ component improperly discloses kernel memory addresses. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to execute code or to elevate user rights directly, but it could be used to obtain information that could be used to try to further compromise the affected system.

The security update addresses the vulnerability by correcting how the Windows GDI+ component handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows RT 8.1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8682
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8682
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

Windows graphics on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, Windows Server 2016, Microsoft Office Word Viewer, Microsoft Office 2007 Service Pack 3 , and Microsoft Office 2010 Service Pack 2 allows an attacker to execute remote code by the way it handles embedded fonts, aka "Win32k Graphics Remote Code Execution Vulnerability". This CVE ID is unique from CVE-2017-8683.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows graphics

affected
    * Office 2007 Service Pack 3
    * Office 2010 Service Pack 2
    * Office Word Viewer
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2008 SP2 and R2 SP1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * http://www.securitytracker.com/id/1039352
    * http://www.securityfocus.com/bid/100772
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8682
    * https://www.exploit-db.com/exploits/42744/


CVE-2017-8682 - Security Update Guide - Microsoft - Win32k Graphics Remote Code Execution Vulnerability
=======================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Last updated: Sep 14, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8682

Executive Summary
-----------------

A remote code execution vulnerability exists when the Windows font library improperly handles specially crafted embedded fonts. An attacker who successfully exploited this vulnerability could take control of the affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

There are multiple ways an attacker could exploit this vulnerability:
    * In a web-based attack scenario, an attacker could host a specially crafted website that is designed to exploit this vulnerability and then convince a user to view the website. An attacker would have no way to force users to view the attacker-controlled content. Instead, an attacker would have to convince users to take action, typically by getting them to click a link in an email message or in an Instant Messenger message that takes users to the attacker's website, or by opening an attachment sent through email.
    * In a file sharing attack scenario, an attacker could provide a specially crafted document file that is designed to exploit this vulnerability, and then convince a user to open the document file.

The security update addresses the vulnerability by correcting how the Windows font library handles embedded fonts.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: N/A

FAQ
---

    I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

    For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

    For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335. For a list of Microsoft Office products that an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.1
revision date: Sep 14, 2017
description: Added an FAQ to explain why security update 3191848 is not applicable to Office 2010 on Windows Server 2008 and later versions. This is an informational change only. Customers who have already installed the updates do not need to take any further action.

---

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8683
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8683
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

Windows graphics on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016, allows an attacker to execute remote code by the way it handles embedded fonts, aka "Win32k Graphics Remote Code Execution Vulnerability". This CVE ID is unique from CVE-2017-8682.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows graphics

affected
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2008 SP2 and R2 SP1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * https://www.exploit-db.com/exploits/42746/
    * http://www.securitytracker.com/id/1039338
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8683
    * http://www.securityfocus.com/bid/100781


CVE-2017-8683 - Security Update Guide - Microsoft - Microsoft Graphics Component Information Disclosure Vulnerability
=====================================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8683

Executive Summary
-----------------

An information disclosure vulnerability exists when the Microsoft Windows Graphics Component improperly handles objects in memory. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application.

The update addresses the vulnerability by correcting the way in which the Windows Graphics Component handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2012 R2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 R2
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2012
Information Disclosure
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows 8.1 for x64-based systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 8.1 for 32-bit systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 7 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows 7 for 32-bit Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows 10 Version 1607 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1607 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1511 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 Version 1511 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 Version 1703 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

---

Sep 12, 2017
Windows 10 Version 1703 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

---

Sep 12, 2017
Windows Server 2016 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows Server 2016
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8684
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8684
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

Windows GDI+ on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, and Windows RT 8.1, allows information disclosure by the way it discloses kernel memory addresses, aka "Windows GDI+ Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8685 and CVE-2017-8688.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows GDI+

affected
    * Windows 7 SP1
    * Windows 8.1
    * Windows GDI+ on Microsoft Windows Server 2008 SP2 and R2 SP1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8684
    * http://www.securityfocus.com/bid/100782
    * http://www.securitytracker.com/id/1039338
    * https://www.exploit-db.com/exploits/42747/


CVE-2017-8684 - Security Update Guide - Microsoft - Windows GDI+ Information Disclosure Vulnerability
=====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8684

Executive Summary
-----------------

A information disclosure vulnerability exists when the Windows GDI+ component improperly discloses kernel memory addresses. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to execute code or to elevate user rights directly, but it could be used to obtain information that could be used to try to further compromise the affected system.

The security update addresses the vulnerability by correcting how the Windows GDI+ component handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows RT 8.1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8685
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8685
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

Windows GDI+ on Microsoft Windows Server 2008 SP2 and R2 SP1, and Windows 7 SP1 allows information disclosure by the way it discloses kernel memory addresses, aka "Windows GDI+ Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8684 and CVE-2017-8688.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows GDI+

affected
    * Windows 7 SP1
    * Windows Server 2008 SP2 and R2 SP1

References
----------

    * https://www.exploit-db.com/exploits/42748/
    * http://www.securitytracker.com/id/1039338
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8685
    * http://www.securityfocus.com/bid/100724


CVE-2017-8685 - Security Update Guide - Microsoft - Windows GDI+ Information Disclosure Vulnerability
=====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8685

Executive Summary
-----------------

A information disclosure vulnerability exists when the Windows GDI+ component improperly discloses kernel memory addresses. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application. The vulnerability would not allow an attacker to execute code or to elevate user rights directly, but it could be used to obtain information that could be used to try to further compromise the affected system.

The security update addresses the vulnerability by correcting how the Windows GDI+ component handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8687
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8687
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-20

Description
-----------

The Windows kernel component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016 allows an information disclosure vulnerability when it improperly handles objects in memory, aka "Win32k Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8678, CVE-2017-8680, CVE-2017-8677, and CVE-2017-8681.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows kernel

affected
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8687
    * http://www.securityfocus.com/bid/100736
    * https://www.exploit-db.com/exploits/42749/
    * http://www.securitytracker.com/id/1039325


CVE-2017-8687 - Security Update Guide - Microsoft - Win32k Information Disclosure Vulnerability
===============================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8687

Executive Summary
-----------------

An information disclosure vulnerability exists in Windows kernel that could allow an attacker to retrieve information that could lead to a Kernel Address Space Layout Randomization (KASLR) bypass. An attacker who successfully exploited this vulnerability could retrieve the memory address of a kernel object.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application.

The security update addresses the vulnerability by correcting how the Windows kernel handles memory addresses.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Mateusz Jurczyk
      of Google Project Zero
      https://www.google.com

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2012 R2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 R2
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows Server 2012 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2012
Information Disclosure
Important

    * https://support.microsoft.com/help/4038799
    * https://support.microsoft.com/help/4038786

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038799
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038786

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 R2 for Itanium-Based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for 32-bit Systems Service Pack 2
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows RT 8.1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792

---

Sep 12, 2017
Windows 8.1 for x64-based systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 8.1 for 32-bit systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038792
    * https://support.microsoft.com/help/4038793

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038792
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038793

---

Sep 12, 2017
Windows 7 for x64-based Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows 7 for 32-bit Systems Service Pack 1
Information Disclosure
Important

    * https://support.microsoft.com/help/4038777
    * https://support.microsoft.com/help/4038779

    * Monthly Rollup: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038777
    * Security Only:  https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038779

---

Sep 12, 2017
Windows Server 2016 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows Server 2016
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1607 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1607 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038782

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038782

---

Sep 12, 2017
Windows 10 Version 1511 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 Version 1511 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038783

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038783

---

Sep 12, 2017
Windows 10 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038781

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038781

---

Sep 12, 2017
Windows 10 Version 1703 for x64-based Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

---

Sep 12, 2017
Windows 10 Version 1703 for 32-bit Systems
Information Disclosure
Important

    * https://support.microsoft.com/help/4038788

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4038788

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8688
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8688
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-13

Description
-----------

Windows GDI+ on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016, allows information disclosure by the way it discloses kernel memory addresses, aka "Windows GDI+ Information Disclosure Vulnerability". This CVE ID is unique from CVE-2017-8684 and CVE-2017-8685.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows GDI+

affected
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2008 SP2 and R2 SP1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * http://www.securityfocus.com/bid/100756
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8688
    * http://www.securitytracker.com/id/1039338


CVE-2017-8688 - Security Update Guide - Microsoft - Windows GDI Information Disclosure Vulnerability
====================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8688

Executive Summary
-----------------

An information disclosure vulnerability exists in the way that the Windows Graphics Device Interface (GDI) handles objects in memory, allowing an attacker to retrieve information from a targeted system. By itself, the information disclosure does not allow arbitrary code execution; however, it could allow arbitrary code to be run if the attacker uses it in combination with another vulnerability.

To exploit this vulnerability, an attacker would have to log on to an affected system and run a specially crafted application.

The security update addresses the vulnerability by correcting how GDI handles memory addresses.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Weibo Wang
      of 360 Skyeye Labs

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Information Disclosure
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8695
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8695
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-15

Description
-----------

Windows Uniscribe in Microsoft Windows Server 2008 SP2 and R2 SP1; Windows 7 SP1; Windows 8.1; Windows Server 2012 Gold and R2; Windows RT 8.1; Windows 10 Gold, 1511, 1607, 1703, and Server 2016; Office 2007 SP3; Office 2010 SP2; Word Viewer; Office for Mac 2011 and 2016; Skype for Business 2016; Lync 2013 SP1; Lync 2010; Lync 2010 Attendee; and Live Meeting 2007 Add-in and Console allows an attacker to obtain information to further compromise a user's system via a specially crafted document or an untrusted webpage, aka "Graphics Component Information Disclosure Vulnerability."

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows Uniscribe

affected
    * Live Meeting 2007 Add-in and Console
    * Lync 2010
    * Lync 2010 Attendee
    * Lync 2013 SP1
    * Microsoft Windows Server 2008 SP2 and R2 SP1
    * Office 2007 SP3
    * Office 2010 SP2
    * Office for Mac 2011 and 2016
    * Server 2016
    * Skype for Business 2016
    * Windows 10 Gold, 1511, 1607, 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2012 Gold and R2
    * Word Viewer

References
----------

    * http://www.securityfocus.com/bid/100773
    * http://www.securitytracker.com/id/1039344
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8695


CVE-2017-8695 - Security Update Guide - Microsoft - Windows Uniscribe Information Disclosure Vulnerability
==========================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Last updated: Oct 4, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8695

Executive Summary
-----------------

An information disclosure vulnerability exists when Windows Uniscribe improperly discloses the contents of its memory. An attacker who successfully exploited the vulnerability could obtain information to further compromise the user’s system.

There are multiple ways an attacker could exploit the vulnerability, such as by convincing a user to open a specially crafted document or by convincing a user to visit an untrusted webpage.

The update addresses the vulnerability by correcting how Windows Uniscribe handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

FAQ
---

    I am being offered this update for software that is not specifically indicated as being affected in the Affected Software and Vulnerability Severity Ratings table. Why am I being offered this update?
    -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    When updates address vulnerable code that exists in a component that is shared between multiple Microsoft Office products or shared between multiple versions of the same Microsoft Office product, the update is considered to be applicable to all supported products and versions that contain the vulnerable component.

    For example, when an update applies to Microsoft Office 2007 products, only Microsoft Office 2007 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2007, Microsoft Excel 2007, Microsoft Visio 2007, Microsoft Compatibility Pack, Microsoft Excel Viewer, or any other Microsoft Office 2007 product that is not specifically listed in the Affected Software table. Furthermore, when an update applies to Microsoft Office 2010 products, only Microsoft Office 2010 may be specifically listed in the Affected Software table. However, the update could apply to Microsoft Word 2010, Microsoft Excel 2010, Microsoft Visio 2010, Microsoft Visio Viewer, or any other Microsoft Office 2010 product that is not specifically listed in the Affected Software table.

    For more information on this behavior and recommended actions, see Microsoft Knowledge Base Article 830335. For a list of Microsoft Office products that an update may apply to, refer to the Microsoft Knowledge Base Article associated with the specific update.

Acknowledgements
----------------

    * Axel Souchet
      of MSRC Vulnerabilities and Mitigations Team

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 2.0
revision date: Oct 4, 2017
description: Removed security update 3213568 for Microsoft Lync Basic 2013 Service Pack 1 (32-bit), Microsoft Lync Basic 2013 Service Pack 1 (64-bit), Microsoft Lync 2013 Service Pack 1 (32-bit), and Microsoft Lync 2013 Service Pack 1 (64-bit) from the Affected Products table because it is not required to address CVE-2017-8695. Customers running these affected versions of Microsoft Lync who have already successfully installed the September Security Updates do not need to take any further action.

---

version: 1.1
revision date: Sep 14, 2017
description: Added an FAQ to explain why security update 3191848 is not applicable to Office 2010 on Windows Server 2008 and later versions. This is an informational change only. Customers who have already installed the updates do not need to take any further action.

---

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8696
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8696
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-15

Description
-----------

Windows Uniscribe in Microsoft Windows Server 2008 SP2 and R2 SP1; Windows 7 SP1; Office 2007 SP3; Office 2010 SP2; Word Viewer; Office for Mac 2011 and 2016; Skype for Business 2016; Lync 2013 SP1; Lync 2010; Lync 2010 Attendee; and Live Meeting 2007 Add-in and Console allows an attacker to execute code remotely via a specially crafted website or a specially crafted document or email attachment, aka "Microsoft Graphics Component Remote Code Execution."

Product Status
--------------

Information not provided

References
----------

    * http://www.securitytracker.com/id/1039344
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8696
    * http://www.securityfocus.com/bid/100780


CVE-2017-8696 - Security Update Guide - Microsoft - Windows Uniscribe Remote Code Execution Vulnerability
=========================================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8696

Executive Summary
-----------------

A remote code execution vulnerability exists due to the way Windows Uniscribe handles objects in memory. An attacker who successfully exploited this vulnerability could take control of the affected system. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights. Users whose accounts are configured to have fewer user rights on the system could be less impacted than users who operate with administrative user rights.

There are multiple ways an attacker could exploit this vulnerability:

    * In a web-based attack scenario, an attacker could host a specially crafted website designed to exploit this vulnerability and then convince a user to view the website. An attacker would have no way to force users to view the attacker-controlled content. Instead, an attacker would have to convince users to take action, typically by getting them to click a link in an email or instant message that takes users to the attacker's website, or by opening an attachment sent through email.
    * In a file-sharing attack scenario, an attacker could provide a specially crafted document file designed to exploit this vulnerability and then convince a user to open the document file.

The security update addresses the vulnerability by correcting how Windows Uniscribe handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Axel Souchet
      of MSRC Vulnerabilities and Mitigations Team

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.


CVE Record: CVE-2017-8720
=========================

Common vulnerabilities and Exposures (CVE)
==========================================

CVE-2017-8720
=============

CNA: Microsoft Corporation
==========================

Published: 2017-09-13
Updated: 2017-09-14

Description
-----------

The Microsoft Windows graphics component on Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1, Windows Server 2012 Gold and R2, Windows RT 8.1, Windows 10 Gold, 1511, 1607, and 1703, and Windows Server 2016 allows an elevation of privilege vulnerability when the Win32k component fails to properly handle objects in memory, aka "Win32k Elevation of Privilege Vulnerability". This CVE ID is unique from CVE-2017-8675.

Product Status
--------------

Vendor: Microsoft Corporation
Product: Windows graphics component

affected
    * Windows 10 Gold, 1511, 1607, and 1703
    * Windows 7 SP1
    * Windows 8.1
    * Windows RT 8.1
    * Windows Server 2008 SP2 and R2 SP1
    * Windows Server 2012 Gold and R2
    * Windows Server 2016

References
----------

    * http://www.securitytracker.com/id/1039325
    * http://www.securityfocus.com/bid/100804
    * https://portal.msrc.microsoft.com/en-US/security-guidance/advisory/CVE-2017-8720


CVE-2017-8720 - Security Update Guide - Microsoft - Win32k Elevation of Privilege Vulnerability
===============================================================================================

Security Vulnerability
Released: Sep 12, 2017
Assigning CNA: Microsoft
CVE.org link: https://www.cve.org/CVERecord?id=CVE-2017-8720

Executive Summary
-----------------

An elevation of privilege vulnerability exists in Windows when the Win32k component fails to properly handle objects in memory. An attacker who successfully exploited this vulnerability could run arbitrary code in kernel mode. An attacker could then install programs; view, change, or delete data; or create new accounts with full user rights.

To exploit this vulnerability, an attacker would first have to log on to the system. An attacker could then run a specially crafted application that could exploit the vulnerability and take control of an affected system.

The update addresses this vulnerability by correcting how Win32k handles objects in memory.

Exploitability
--------------

The following table provides an exploitability assessment for this vulnerability at the time of original publication.

Publicly disclosed: No
Exploited: No
Exploitability assessment: Exploitation Less Likely

Acknowledgements
----------------

    * Jaanus Kp
      of Clarified Security

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

Security Updates
----------------

Sep 12, 2017
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation)
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

---

Sep 12, 2017
Windows Server 2008 for Itanium-Based Systems Service Pack 2
Elevation of Privilege
Important

    * https://support.microsoft.com/help/4039384

    * Security Update: https://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4039384

Disclaimer
----------

The information provided in the Microsoft Knowledge Base is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

Revisions
---------

version: 1.0
revision date: Sep 12, 2017
description: Information published.